Modify

Opened 3 years ago

Closed 3 years ago

#18287 closed defect (obsolete)

WR703N, kernel 2.6.39.4, EHCI/OHCI, usb hub detected properly but no device detected

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: kernel Version: Trunk
Keywords: usb Cc:

Description

hi
i am trying to understand an issue i have with my WR703N board, i am using linux 2.6.39.4 from openWRT trunk r29283

1) i have cloned the repo, svn checkout -r r29283 svn://svn.openwrt.org/openwrt/trunk
2) then i have entered into "trunk", configured for target=WR703N, and invoked "make"
3) after the full build up i have copied the kernel sources (already patched) into a different place
4) and since then i have been compiling the kernel by hands into a MIPS BE real machine

everything is fine, as you can see here from the full log -> http://elinux.org/Flameman/tl-WR703N

the kernel is booting and i can get the console, everything is OK except the USB, so my issue is related to the USB: the kernel seems to have it, it is reporting it has detected the USB-HUB but i can't see any USB device if i physically plug something in the USB connector

i have tested the hardware with an other openWRT prebuilt package and the USB is working, so the problem is related to the software

i have configured the kernel to have a ram rootfs, everything about the USB has been built as "static built in" in the kernel

EHCI HCD (USB 2.0) support

│ + Root Hub Transaction Translators
│ + Improved Transaction Translator scheduling
│ + USB EHCI support for AR71xx

dmesg is reporting the following

ar71xx-ehci ar71xx-ehci: new USB bus registered, assigned bus number 1
ar71xx-ehci ar71xx-ehci: reset command 0080002 (park)=0 ithresh=8 period=1024 Reset HALT
ar71xx-ehci ar71xx-ehci: park 0
ar71xx-ehci ar71xx-ehci: ...powerdown ports...
ar71xx-ehci ar71xx-ehci: irq 3, io mem 0x1b000000
ar71xx-ehci ar71xx-ehci: reset command 0080002 (park)=0 ithresh=8 period=1024 Reset HALT
ar71xx-ehci ar71xx-ehci: init command 0010005 (park)=0 ithresh=1 period=512 RUN
ar71xx-ehci ar71xx-ehci: USB 2.0 started, EHCI 1.00
usb usb1: default language 0x0409
usb usb1: udev 1, busnum 1, minor = 0
usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb1: Product: Atheros AR91xx built-in EHCI controller
usb usb1: Manufacturer: Linux 2.6.39-Flesh-Eating-Bats-TL-WR703N ehci_hcd
usb usb1: SerialNumber: ar71xx-ehci
usb usb1: usb_probe_device
usb usb1: configuration #1 chosen from 1 choice
usb usb1: adding 1-0:1.0 (config #1, interface 0)
hub 1-0:1.0: usb_probe_interface
hub 1-0:1.0: usb_probe_interface - got id
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
hub 1-0:1.0: standalone hub
hub 1-0:1.0: individual port power switching
hub 1-0:1.0: individual port over-current protection
hub 1-0:1.0: Single TT
hub 1-0:1.0: TT requires at most 8 FS bit times (666 ns)
hub 1-0:1.0: power on to power good time: 20ms
hub 1-0:1.0: local power source is good
hub 1-0:1.0: enabling power on all ports

with this additional information

hub 1-0:1.0: port 1: status 0401 change 0000
hub 1-0:1.0: state 7 ports 1 chg 0002 evt 0000
hub 1-0:1.0: port 1, status 0401, change 0000, 480 Mb/s
hub 1-0:1.0: unable to enumerate USB device on port 1

the hub seems to be detected properly, so i have plugged an usb pen drive (USB1) and an usb hard drive (USB2) to the USB (both proved to be working on other PCs) and they don't appear in system, there is no device detected via "lsusb" and no dmesg errors of any kind that we can see. It is as if the device is not plugged in.

# lsusb
Bus 001 Device 001: ID 1d6b:0002 Unix Foundation 2.0 root hub

what's wrong? i have been working on 2.6.39.4 because i have been developed a fb-lcd driver on such old kernel and i can't actually port it to kernel 3.* (it may be in the near future), let me know if kernel 2.6.39 is able to handle the USB, if i am on the right trunk for such a .39 kernel, and … if there something needed in the userland in order to make the USB to work

actually my bootcmd is "board=TL-WR703N console=ttyATH0,115200 rdinit=/bin/bash init=/bin/bash"

regards

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by anonymous

has r29283 issues with USB ? is it the best one for 2.6.39 kernel ?
let me know please

comment:2 Changed 3 years ago by anonymous

i have applied the same procedure to 3.3.8/OpenWRT-trunk-carambola-last, the USB is perfectly working

comment:3 Changed 3 years ago by nbd

  • Resolution set to obsolete
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.