Modify

Opened 3 years ago

Closed 3 years ago

#18212 closed defect (worksforme)

odhcp6c is crashing on ar71xx / r43027

Reported by: bittorf@… Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

bastian@server1:~/openwrt$ scripts/remote-gdb r43027.ar71xx.odhcp6c.20237.6.1414116448.core staging_dir/target-mips_34kc_uClibc-0.9.33.2/root-ar71xx/usr/sbin/odhcp6c
Using target mips_34kc (uClibc-0.9.33.2)
GNU gdb (Linaro GDB) 7.6-2013.05
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "--host=x86_64-linux-gnu --target=mips-openwrt-linux-uclibc".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/root-ar71xx/usr/sbin/odhcp6c...done.
[New LWP 20237]
Core was generated by `odhcp6c -s /lib/netifd/dhcpv6.script -P0 -t120 eth0.2'.
Program terminated with signal 6, Aborted.
#0  0x77d717d0 in __GI_raise (sig=6) at libpthread/nptl/sysdeps/unix/sysv/linux/raise.c:67
67        int res = INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
(gdb) bt full
#0  0x77d717d0 in __GI_raise (sig=6) at libpthread/nptl/sysdeps/unix/sysv/linux/raise.c:67
        err = 0
        result_var = 0
        pd = 0x77dc9000
        pid = 20237
        selftid = 20237
        res = <optimized out>
#1  0x77d6a7c8 in __GI_abort () at libc/stdlib/abort.c:89
        sigs = {__val = {32, 0, 0, 0}}
#2  0x77d69d54 in __malloc_consolidate (av=0x77d8efec <__malloc_state>) at libc/stdlib/malloc-standard/free.c:225
        fb = <optimized out>
        maxfb = <optimized out>
        p = <optimized out>
        nextp = <optimized out>
        unsorted_bin = 0x77d8f020 <__malloc_state+52>
        first_unsorted = <optimized out>
        nextchunk = <optimized out>
        size = <optimized out>
        nextsize = <optimized out>
        prevsize = <optimized out>
        nextinuse = <optimized out>
        bck = <optimized out>
        fwd = <optimized out>
#3  0x77d68d98 in malloc (bytes=<optimized out>) at libc/stdlib/malloc-standard/malloc.c:908
        __infunc_pthread_cleanup_buffer = {__routine = 0x77d724ac <pthread_mutex_unlock>, __arg = 0x77d8a280 <__malloc_lock>, __canceltype = 4087, __prev = 0x77e44758}
        av = 0x77d8efec <__malloc_state>
        nb = 264
        idx = 32
        bin = <optimized out>
        fb = <optimized out>
        victim = <optimized out>
        size = <optimized out>
        victim_index = <optimized out>
        remainder = <optimized out>
        remainder_size = <optimized out>
        block = <optimized out>
        bit = <optimized out>
        map = <optimized out>
        fwd = <optimized out>
        bck = <optimized out>
        retval = <optimized out>
#4  0x77d52778 in __GI_open_memstream (bufloc=0x7ffece34, sizeloc=0x7ffece30) at libc/stdio/open_memstream.c:139
        cookie = 0xa44390
        fp = <optimized out>
#5  0x0040128c in s46_to_env (state=state@entry=STATE_S46_MAPE, data=data@entry=0x0, len=<optimized out>) at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-10-12/src/script.c:234
        name = 0x405e38 "MAPE"
        str = 0x77d66120 <__GI___dn_expand+48> "\030@"
        strsize = 2010487872
        fp = <optimized out>
        type = <optimized out>
        odata = <optimized out>
        otype = <optimized out>
        olen = <optimized out>
#6  0x00405210 in script_call (status=status@entry=0x4058b4 "stopped") at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-10-12/src/script.c:377
        buf = <optimized out>
        dns_len = 0
        search_len = 0
        custom_len = 0
        sntp_ip_len = 0
        ntp_ip_len = 0
        ntp_dns_len = 0
        sip_ip_len = 0
        sip_fqdn_len = 0
        aftr_name_len = 0
        cer_len = 0
        addr_len = 0
        s46_mapt_len = 0
        s46_mape_len = 0
        s46_lw_len = 0
        passthru_len = 0
        addr = <optimized out>
        dns = <optimized out>
        search = <optimized out>
        custom = 0x0
        sntp = 0x0
        ntp = 0x0
        ntp_dns = 0x0
        sip = 0x0
        sip_fqdn = 0x0
        aftr_name = 0x0
        cer = 0x0
        s46_mapt = 0x0
        s46_mape = 0x0
        s46_lw = 0x0
        passthru = 0x0
        prefix_len = 0
        address_len = 0
        ra_pref_len = 0
        ra_route_len = 0
        ra_dns_len = 0
        prefix = 0x0
        address = 0x0
        ra_pref = 0x0
        ra_route = 0x0
        ra_dns = 0x0
#7  0x00401de2 in main (argc=<optimized out>, argv=<optimized out>) at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-10-12/src/odhcp6c.c:410
        pidfile = 0x0
        script = 0x7ffedf3c "/lib/netifd/dhcpv6.script"
        l = <optimized out>
        buf = "\177\376\324\230\000\000\000\000w\333NL\000\000\000\003w\334\261\270\177\376\324p\177\376\324xw\333\244l\177\376\324\230\000\000\000\000w\335\060\000\177\376\326\220w\333DHw\333I(\000\000\000\000\000\000\000\000\177\376\337\061w\330\243\260\000\000\004\205w\322\307\211\000\000\004V\000\000\001\377\000\000\017\367w\344GX\177\376\324\300w\333c\350w\322\307\211", '\000' <repeats 20 times>, "w\335\060\000\000"
        optpos = 0x7ffed5c0 ""
        opttype = 40000
        optlen = 30677
        ia_na_mode = IA_MODE_TRY
        ia_pd_mode = IA_MODE_TRY
        ia_pd_iaid_index = <optimized out>
        ifid = {__in6_u = {__u6_addr8 = '\000' <repeats 15 times>, __u6_addr16 = {0, 0, 0, 0, 0, 0, 0, 0}, __u6_addr32 = {0, 0, 0, 0}}}
        sol_timeout = 120
        help = <optimized out>
        daemonize = false
        logopt = 1
        c = <optimized out>
        client_options = <optimized out>
        ifname = 0x7ffedf60 "eth0.2"
(gdb) 

Attachments (0)

Change History (10)

comment:1 follow-up: Changed 3 years ago by cyrus

  • Resolution set to fixed
  • Status changed from new to closed

Could it be that your devices runs OOM?
I honestly tried my best to reproduce your crashes or make sense of them but couldn't.
I now removed some unnecessary bigger mallocs maybe this will help.

comment:2 in reply to: ↑ 1 Changed 3 years ago by bittorf@…

Replying to cyrus:

Could it be that your devices runs OOM?

unlikely. it's a 32mb device which not much running and even zram activated (which is unused/untouched). thanks for your changes, will rebuild and report if something happens...

comment:3 Changed 3 years ago by bittorf@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

sorry, have to reopen - another crash with r43056 including the last fix:

bastian@server1:~/openwrt$ scripts/remote-gdb r43056.ar71xx.odhcp6c.2001.11.1414261689.core staging_dir/target-mips_34kc_uClibc-0.9.33.2/root-ar71xx/usr/sbin/odhcp6c
Using target mips_34kc (uClibc-0.9.33.2)
GNU gdb (Linaro GDB) 7.6-2013.05
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "--host=x86_64-linux-gnu --target=mips-openwrt-linux-uclibc".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/root-ar71xx/usr/sbin/odhcp6c...done.
[New LWP 2001]
Core was generated by `                                                     '.
Program terminated with signal 11, Segmentation fault.
#0  0x00403dfa in dhcpv6_request (type=type@entry=DHCPV6_MSG_SOLICIT) at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-10-25/src/dhcpv6.c:611
611                     if (retx->handler_finish)
(gdb) bt full
#0  0x00403dfa in dhcpv6_request (type=type@entry=DHCPV6_MSG_SOLICIT) at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-10-25/src/dhcpv6.c:611
        round_end = <optimized out>
        rc = 198 '\306'
        timeout = <optimized out>
        retx = 0x0
        start = 33740
        round_start = <optimized out>
        elapsed = <optimized out>
        trid = "\211\254\322"
        len = -1
        rto = 0
#1  0x00401c62 in main (argc=<optimized out>, argv=<optimized out>) at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-10-25/src/odhcp6c.c:283
        mode = <optimized out>
        ia_pd_len = <optimized out>
        ia_na_len = <optimized out>
        server_id_len = <optimized out>
        pidfile = 0x0
        script = 0x7f92cf3c "/lib/netifd/dhcpv6.script"
        l = <optimized out>
        buf = "\177\222\313\230\000\000\000\000v\376NL\000\000\000\003v\377\261\270\177\222\313p\177\222\313xv\376\244l\177\222\313\230\000\000\000\000w\000\060\000\177\222\315\220v\376DHv\376I(\000\000\000\000\000\000\000\000\177\222\317\061v\373\243\260\000\000\004\205v\365\307\211\000\000\004V\000\000\001\377\000\000\017\367w\322WX\177\222\313\300v\376c\350v\365\307\211", '\000' <repeats 20 times>, "w\000\060\000\000"
        optpos = 0x7f92ccc0 ""
        opttype = 40000
        optlen = 30456
        ia_na_mode = IA_MODE_TRY
        ia_pd_mode = IA_MODE_TRY
        ia_pd_iaid_index = <optimized out>
        ifid = {__in6_u = {__u6_addr8 = '\000' <repeats 15 times>, __u6_addr16 = {0, 0, 0, 0, 0, 0, 0, 0}, __u6_addr32 = {0, 0, 0, 0}}}
        sol_timeout = 120
        help = <optimized out>
        daemonize = false
        logopt = 1
        c = <optimized out>
        client_options = <optimized out>
        ifname = 0x7f92cf60 "eth0.2"
(gdb) 

comment:4 Changed 3 years ago by bittorf@…

here again (seems to be nearly the same):

bastian@server1:~/openwrt$ scripts/remote-gdb r43056.ar71xx.odhcp6c.3527.11.1414293793.core staging_dir/target-mips_34kc_uClibc-0.9.33.2/root-ar71xx/usr/sbin/odhcp6c
Using target mips_34kc (uClibc-0.9.33.2)
GNU gdb (Linaro GDB) 7.6-2013.05
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "--host=x86_64-linux-gnu --target=mips-openwrt-linux-uclibc".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/root-ar71xx/usr/sbin/odhcp6c...done.
[New LWP 3527]
Core was generated by `odhcp6c -s /lib/netifd/dhcpv6.script -P0 -t120 pppoe-wan'.
Program terminated with signal 11, Segmentation fault.
#0  0x00403dfa in dhcpv6_request (type=type@entry=DHCPV6_MSG_SOLICIT) at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-10-25/src/dhcpv6.c:611
611                     if (retx->handler_finish)
(gdb) bt full
#0  0x00403dfa in dhcpv6_request (type=type@entry=DHCPV6_MSG_SOLICIT) at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-10-25/src/dhcpv6.c:611
        round_end = <optimized out>
        rc = 8 '\b'
        timeout = <optimized out>
        retx = 0x6f742061
        start = 52262250
        round_start = <optimized out>
        elapsed = <optimized out>
        trid = "\230\226\001"
        len = -1
        rto = 7812741925116993897
#1  0x00401c62 in main (argc=<optimized out>, argv=<optimized out>) at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-10-25/src/odhcp6c.c:283
        mode = <optimized out>
        ia_pd_len = <optimized out>
        ia_na_len = <optimized out>
        server_id_len = <optimized out>
        pidfile = 0x0
        script = 0x7fa62f39 "/lib/netifd/dhcpv6.script"
        l = <optimized out>
        buf = "\177\246+\330\000\000\000\000wmnL\000\000\000\003wn\321\270\177\246+\260\177\246+\270wm\304l\177\246+\330\000\000\000\000woP\000\177\246-\320wmdHwmi(\000\000\000\000\000\000\000\000\177\246/.wj\303\260\000\000\004\205wd\347\211\000\000\004V\000\000\001\377\000\000\017\367wN\367X\177\246,\000wm\203\350wd\347\211", '\000' <repeats 20 times>, "woP\000\000"
        optpos = 0x7fa62d00 ""
        opttype = 48192
        optlen = 30567
        ia_na_mode = IA_MODE_TRY
        ia_pd_mode = IA_MODE_TRY
        ia_pd_iaid_index = <optimized out>
        ifid = {__in6_u = {__u6_addr8 = '\000' <repeats 15 times>, __u6_addr16 = {0, 0, 0, 0, 0, 0, 0, 0}, __u6_addr32 = {0, 0, 0, 0}}}
        sol_timeout = 120
        help = <optimized out>
        daemonize = false
        logopt = 1
        c = <optimized out>
        client_options = <optimized out>
        ifname = 0x7fa62f5d "pppoe-wan"
(gdb) 

comment:5 Changed 3 years ago by bittorf@…

here again with r43589.

bastian@server1:~/openwrt$ scripts/remote-gdb r43589.ar71xx.odhcp6c.3444.6.1418695225.core staging_dir/target-mips_34kc_uClibc-0.9.33.2/root-ar71xx/usr/sbin/odhcp6c
Using target mips_34kc (uClibc-0.9.33.2)
GNU gdb (Linaro GDB) 7.6-2013.05
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "--host=x86_64-linux-gnu --target=mips-openwrt-linux-uclibc".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/root-ar71xx/usr/sbin/odhcp6c...done.
warning: exec file is newer than core file.
[New LWP 3444]
Core was generated by `odhcp6c -s /lib/netifd/dhcpv6.script -P0 -t120 pppoe-wan'.
Program terminated with signal 6, Aborted.
#0  0x773d97d0 in __GI_raise (sig=6) at libpthread/nptl/sysdeps/unix/sysv/linux/raise.c:67
67        int res = INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
(gdb) bt full
#0  0x773d97d0 in __GI_raise (sig=6) at libpthread/nptl/sysdeps/unix/sysv/linux/raise.c:67
        err = 0
        result_var = 0
        pd = 0x77430000
        pid = 3444
        selftid = 3444
        res = <optimized out>
#1  0x773d27c8 in __GI_abort () at libc/stdlib/abort.c:89
        sigs = {__val = {32, 0, 0, 0}}
#2  0x773c848c in map_newlink (idx=<optimized out>, ifas=0x8115f0, map=0x7ffc6250, max=10) at libc/inet/ifaddrs.c:339
        i = <optimized out>
#3  0x773c8eb0 in __GI_getifaddrs (ifap=0x7ffc6310) at libc/inet/ifaddrs.c:579
        ifam = 0x811540
        rta = <optimized out>
        rtasize = <optimized out>
        ifa_index = 0
        nlh = 0x811530
        size = 144
        nh = {fd = 8, pid = -4102, seq = 1418695226, nlm_list = 0x80e050, end_ptr = 0x8115c8}
        nlp = 0x811370
        ifas = 0x8115f0
        i = <optimized out>
        newlink = 10
        newaddr = <optimized out>
        newaddr_idx = 12
        map_newlink_data = 0x7ffc6250
        ifa_data_size = <optimized out>
        ifa_data_ptr = 0x81258c ""
        result = 0
#4  0x00404bb4 in ra_process () at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-11-28/src/ra.c:265
        ifaddr = 0x0
        ifa = <optimized out>
        found = false
        changed = false
        has_lladdr = false
        buf = "\000\000\000\000\000\000\000\003\000\000\000\000\000\000\000\005\000\000\000\000\000\000\000\066\000\000\000\000\000\000\000\200", '\000' <repeats 152 times>, "\002\220\000\032\000x\000\002\000t\000\001\000\000\000\001"...
        cmsg_buf = '\000' <repeats 20 times>, "\177\374i\270\000\000\000\016\000\200\340\060\000\000\000\032\177\374i\360\000\000\000\000\000\200\340\030\000\000\000\016\000\000\000\000\000\000\000\000\177\374i\320", '\000' <repeats 12 times>, "\177\374i\314", '\000' <repeats 12 times>, "\177\374i\334\000\000\000\004\177\374f\370\000\000\000\024\177\374i\250\000\000\000\020\177\374f\270\000\000\000\000\177\374f\270"
        adv = 0x7ffc6310
        entry = {router = {__in6_u = {__u6_addr8 = '\000' <repeats 15 times>, __u6_addr16 = {0, 0, 0, 0, 0, 0, 0, 0}, __u6_addr32 = {0, 0, 0, 0}}}, length = 0, priority = 0, target = {__in6_u = {__u6_addr8 = '\000' <repeats 15 times>, __u6_addr16 = {0, 0, 0, 0, 0, 0, 0, 0}, __u6_addr32 = {0, 0, 0, 0}}}, valid = 0, preferred = 0, t1 = 0, t2 = 0, class = 0, iaid = 0}
        any = {__in6_u = {__u6_addr8 = '\000' <repeats 15 times>, __u6_addr16 = {0, 0, 0, 0, 0, 0, 0, 0}, __u6_addr32 = {0, 0, 0, 0}}}
#5  0x00402222 in odhcp6c_signal_process () at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-11-28/src/odhcp6c.c:486
        ra_updated = <optimized out>
#6  0x00403aa4 in dhcpv6_request (type=type@entry=DHCPV6_MSG_SOLICIT) at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-11-28/src/dhcpv6.c:563
        buf = "N\251\264i*\r I\177\374j\200wA\374Xw?\200\000w?\201,wC\260\000wA\374XwC\260\000\177\374k\000w8\260\000wC\022\260\177\374j\250wA\375Hw?\200\000wC\021\\\177\374j\270wA\375HwC\260\000\000\000\000\000wC\260\000wC\000\000wC\000\000wC\022\260wC\022\230\177\374k\000\177\374j\340wB\v<wC\021D\177\374k\020wC\260\000wB\v<\000\000\000\000\000\000\000\000wC\260", '\000' <repeats 11 times>, "*\031\000\000\000\000w?#\260w8\262\204w9\035\300w8\324\340", '\000' <repeats 14 times>, "*T\000\000\000\020\000\004\370\354\000\000\000\000\000\000"...
        t = <optimized out>
        opt_end = <optimized out>
        cmsg_buf = "\177\322\361xwB&0\000B:p\000Al`\000Aj\250\177\374x\020\000\000\000\004\000Aj\224"
        msg = {msg_name = 0x7ffc718c, msg_namelen = 28, msg_iov = 0x7ffc71d0, msg_iovlen = 1, msg_control = 0x7ffc7150, msg_controllen = 32, msg_flags = 0}
        pktinfo = 0x0
        opt = <optimized out>
        iov = {iov_base = 0x7ffc6a70, iov_len = 1536}
        addr = {sin6_family = 30527, sin6_port = 8832, sin6_flowinfo = 2147250592, sin6_addr = {__in6_u = {__u6_addr8 = "\000\000\000\034\000\000\000\000\000\000\000\000\000\n\000", __u6_addr16 = {0, 28, 0, 0, 0, 0, 10, 0}, __u6_addr32 = {28, 0, 0, 655360}}}, sin6_scope_id = 0}
        tv = {tv_sec = 127, tv_usec = 404000}
        round_end = 82004544
        rc = 177 '\261'
        timeout = <optimized out>
        retx = 0x416984 <dhcpv6_retx+24>
        start = 76567
        round_start = 81895420
        elapsed = 81800573
        trid = "\177\347\321"
        len = -1
        rto = 127404
#7  0x00401d10 in main (argc=<optimized out>, argv=<optimized out>) at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-11-28/src/odhcp6c.c:291
        mode = <optimized out>
        ia_pd_len = <optimized out>
        ia_na_len = <optimized out>
        server_id_len = <optimized out>
        pidfile = 0x0
        script = 0x7ffc7f39 "/lib/netifd/dhcpv6.script"
        l = <optimized out>
        buf = "w?\212\300w?\234\300\000\000\000\000\000\000\000\000wC\020\024\000@\020\374\000@\n\301\177\374v\300\000B:p\177\322\361w\000\000\017\367w&WXwC\260\000wA\345\000wA\304HwA\311(\000\000\000\000\000\000\000\000\177\374\177.w?#\260\000\000\004\205w9G\211\000\000\004V\000\000\001\377\000\000\017\367w&WX\177\374w\020wA\343\350w9G\211", '\000' <repeats 17 times>, "A"
        optpos = 0x7ffc7f2e "odhcp6c"
        opttype = 4348
        optlen = 64
        ia_na_mode = IA_MODE_TRY
        ia_pd_mode = IA_MODE_TRY
        ia_pd_iaid_index = <optimized out>
        ifid = {__in6_u = {__u6_addr8 = '\000' <repeats 15 times>, __u6_addr16 = {0, 0, 0, 0, 0, 0, 0, 0}, __u6_addr32 = {0, 0, 0, 0}}}
        sol_timeout = 120
        verbosity = 0
        help = <optimized out>
        daemonize = false
        logopt = 1
        c = <optimized out>
        client_options = <optimized out>
        ifname = 0x7ffc7f5d "pppoe-wan"
(gdb) 

comment:6 Changed 3 years ago by bittorf@…

another one with r43738

bastian@server1:~/openwrt$ scripts/remote-gdb r43738.ar71xx.odhcp6c.7512.11.1418958427.core staging_dir/target-mips_34kc_uClibc-0.9.33.2/root-ar71xx/usr/sbin/odhcp6c
Using target mips_34kc (uClibc-0.9.33.2)
GNU gdb (Linaro GDB) 7.6-2013.05
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "--host=x86_64-linux-gnu --target=mips-openwrt-linux-uclibc".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/root-ar71xx/usr/sbin/odhcp6c...done.
[New LWP 7512]
Core was generated by `odhcp6c -s /lib/netifd/dhcpv6.script -P0 -t120 eth0.2'.
Program terminated with signal 11, Segmentation fault.
#0  malloc (bytes=<optimized out>) at libc/stdlib/malloc-standard/malloc.c:957
957             if (size == nb) {
(gdb) bt full
#0  malloc (bytes=<optimized out>) at libc/stdlib/malloc-standard/malloc.c:957
        __infunc_pthread_cleanup_buffer = {__routine = 0x771484ac <pthread_mutex_unlock>, __arg = 0x77160280 <__malloc_lock>, __canceltype = 4340336, __prev = 0x7fb9f447}
        av = 0x77164fec <__malloc_state>
        nb = 16
        idx = 2
        bin = <optimized out>
        fb = <optimized out>
        victim = 0x5da420
        size = 0
        victim_index = <optimized out>
        remainder = <optimized out>
        remainder_size = <optimized out>
        block = <optimized out>
        bit = <optimized out>
        map = <optimized out>
        fwd = <optimized out>
        bck = 0x0
        retval = <optimized out>
#1  0x7713f794 in realloc (oldmem=0x0, bytes=8) at libc/stdlib/malloc-standard/realloc.c:51
        nb = <optimized out>
        oldp = <optimized out>
        oldsize = <optimized out>
        newp = <optimized out>
        newsize = <optimized out>
        newmem = <optimized out>
        next = <optimized out>
        remainder = <optimized out>
        remainder_size = <optimized out>
        bck = <optimized out>
        fwd = <optimized out>
        copysize = <optimized out>
        ncopies = <optimized out>
        s = <optimized out>
        d = <optimized out>
        retval = <optimized out>
#2  0x0040125e in ipv6_to_env (name=name@entry=0x406110 "SERVER", addr=addr@entry=0x0, cnt=<optimized out>) at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-12-10/src/script.c:86
        buf_len = 6
        buf = <optimized out>
#3  0x004052d6 in script_call (status=status@entry=0x405a6c "stopped") at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-12-10/src/script.c:369
        buf = <optimized out>
        dns_len = 0
        search_len = 0
        custom_len = 0
        sntp_ip_len = 0
        ntp_ip_len = 0
        ntp_dns_len = 0
        sip_ip_len = 0
        sip_fqdn_len = 0
        aftr_name_len = 0
        cer_len = 0
        addr_len = 0
        s46_mapt_len = 0
        s46_mape_len = 0
        s46_lw_len = 0
        passthru_len = 0
        addr = 0x0
        dns = 0x0
        search = 0x0
        custom = 0x0
        sntp = 0x0
        ntp = 0x0
        ntp_dns = 0x0
        sip = 0x0
        sip_fqdn = 0x0
        aftr_name = 0x0
        cer = 0x0
        s46_mapt = 0x0
        s46_mape = 0x0
        s46_lw = 0x0
        passthru = 0x0
        prefix_len = 0
        address_len = 0
        ra_pref_len = 0
        ra_route_len = 0
        ra_dns_len = 0
        prefix = 0x0
        address = 0x0
        ra_pref = 0x0
        ra_route = 0x0
        ra_dns = 0x0
#4  0x00401ea8 in main (argc=<optimized out>, argv=<optimized out>) at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-12-10/src/odhcp6c.c:416
        pidfile = 0x0
        script = 0x7f94bf3c "/lib/netifd/dhcpv6.script"
        l = <optimized out>
        buf = "w\026j\300w\026|\300\000\000\000\000\000\000\000\000w\032 \024\000@\021\034\000@\n\325\177\224\255\260\000B:p\177\271\364G\000\000\017\367wy\347Xw\032\220\000w\030\305\000w\030\244Hw\030\251(\000\000\000\000\000\000\000\000\177\224\277\061w\026\003\260\000\000\004\205w\020'\211\000\000\004V\000\000\001\377\000\000\017\367wy\347X\177\224\256\000w\030\303\350w\020'\211", '\000' <repeats 17 times>, "A"
        optpos = 0x7efcf8fe <Address 0x7efcf8fe out of bounds>
        opttype = 48945
        optlen = 32660
        ia_na_mode = IA_MODE_TRY
        ia_pd_mode = IA_MODE_TRY
        ia_pd_iaid_index = <optimized out>
        ifid = {__in6_u = {__u6_addr8 = '\000' <repeats 15 times>, __u6_addr16 = {0, 0, 0, 0, 0, 0, 0, 0}, __u6_addr32 = {0, 0, 0, 0}}}
        sol_timeout = 120
        verbosity = 0
        help = <optimized out>
        daemonize = false
        logopt = 1
        c = <optimized out>
        client_options = <optimized out>
        ifname = 0x7f94bf60 "eth0.2"
(gdb) 

comment:7 Changed 3 years ago by bittorf@…

another one with r44011 - seems it happens at 4.04 o'clock - when pppoe reconnects nightly (german telekom), but the crash is not reliable. uptime is 7 days and it only happens 1 time.

bastian@gcc20:~/openwrt$ scripts/remote-gdb r44011.ar71xx.odhcp6c.28064.6.1421723058.core staging_dir/target-mips_34kc_uClibc-0.9.33.2/root-ar71xx/usr/sbin/odhcp6c
Using target mips_34kc (uClibc-0.9.33.2)
GNU gdb (Linaro GDB) 7.6-2013.05
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "--host=x86_64-linux-gnu --target=mips-openwrt-linux-uclibc".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/root-ar71xx/usr/sbin/odhcp6c...done.
[New LWP 28064]
Core was generated by `odhcp6c -s /lib/netifd/dhcpv6.script -P0 -t120 pppoe-wan'.
Program terminated with signal 6, Aborted.
#0  0x77d2f7d0 in __GI_raise (sig=6) at libpthread/nptl/sysdeps/unix/sysv/linux/raise.c:67
67        int res = INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
(gdb) bt full
#0  0x77d2f7d0 in __GI_raise (sig=6) at libpthread/nptl/sysdeps/unix/sysv/linux/raise.c:67
        err = 0
        result_var = 0
        pd = 0x77d87000
        pid = 28064
        selftid = 28064
        res = <optimized out>
#1  0x77d287c8 in __GI_abort () at libc/stdlib/abort.c:89
        sigs = {__val = {32, 0, 0, 0}}
#2  0x77d1e48c in map_newlink (idx=<optimized out>, ifas=0xad05f0, map=0x7f80eae8, max=8) at libc/inet/ifaddrs.c:339
        i = <optimized out>
#3  0x77d1eeb0 in __GI_getifaddrs (ifap=0x7f80eba0) at libc/inet/ifaddrs.c:579
        ifam = 0xad0178
        rta = <optimized out>
        rtasize = <optimized out>
        ifa_index = 0
        nlh = 0xad0168
        size = 512
        nh = {fd = 8, pid = -4337, seq = 1421723059, nlm_list = 0xacd050, end_ptr = 0xad05c8}
        nlp = 0xad0158
        ifas = 0xad05f0
        i = <optimized out>
        newlink = 8
        newaddr = <optimized out>
        newaddr_idx = 0
        map_newlink_data = 0x7f80eae8
        ifa_data_size = <optimized out>
        ifa_data_ptr = 0xad1428 ""
        result = 0
#4  0x00404c14 in ra_process () at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-12-10/src/ra.c:265
        ifaddr = 0x0
        ifa = <optimized out>
        found = false
        changed = false
        has_lladdr = false
        buf = "\000\000\000\000\000\000\000\003\000\000\000\000\000\000\000\004\000\000\000\000\000\000\000\066\000\000\000\000\000\000\000D", '\000' <repeats 152 times>, "\002\220\000\032\000x\000\002\000t\000\001\000\000\000\001"...
        cmsg_buf = '\000' <repeats 20 times>, "\177\200\362H\000\000\000\016\000\254\320\060\000\000\000\032\177\200\362\200\000\000\000\000\000\254\320\030\000\000\000\016\000\000\000\000\000\000\000\000\177\200\362`", '\000' <repeats 12 times>, "\177\200\362\\", '\000' <repeats 12 times>, "\177\200\362l\000\000\000\004\177\200\357\210\000\000\000\024\177\200\362\070\000\000\000\020\177\200\357H\000\000\000\000\177\200\357H"
        adv = 0x7f80eba0
        entry = {router = {__in6_u = {__u6_addr8 = '\000' <repeats 15 times>, __u6_addr16 = {0, 0, 0, 0, 0, 0, 0, 0}, __u6_addr32 = {0, 0, 0, 0}}}, length = 0, priority = 0, target = {__in6_u = {__u6_addr8 = '\000' <repeats 15 times>, __u6_addr16 = {0, 0, 0, 0, 0, 0, 0, 0}, __u6_addr32 = {0, 0, 0, 0}}}, valid = 0, preferred = 0, t1 = 0, t2 = 0, class = 0, iaid = 0}
        any = {__in6_u = {__u6_addr8 = '\000' <repeats 15 times>, __u6_addr16 = {0, 0, 0, 0, 0, 0, 0, 0}, __u6_addr32 = {0, 0, 0, 0}}}
#5  0x00402232 in odhcp6c_signal_process () at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-12-10/src/odhcp6c.c:484
        ra_updated = <optimized out>
#6  0x00403b04 in dhcpv6_request (type=type@entry=DHCPV6_MSG_SOLICIT) at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-12-10/src/dhcpv6.c:574
        buf = "\364#k\227\003\302r\213\177\200\363\020w\327\\Xw\324\340\000w\324\341,w\331\020\000w\327\\Xw\331\020\000\177\200\363\220w\316\020\000wآ\260\177\200\363\070w\327]Hw\324\340\000wء\\\177\200\363Hw\327]Hw\331\020\000\000\000\000\000w\331\020\000w\330p\000w\330p\000wآ\260wآ\230\177\200\363\220\177\200\363pw\327k<wءD\177\200\363\240w\331\020\000w\327k<\000\000\000\000\000\000\000\000w\331\020", '\000' <repeats 11 times>, "*\031\000\000\000\000wԃ\260w\316\022\204w\316}\300w\316\064\340", '\000' <repeats 14 times>, "*T\000\000\000\020\000\004\370\354\000\000\000\000\000\000*\036\000\000\000\000\000\000\000\000"...
        t = <optimized out>
        opt_end = <optimized out>
        cmsg_buf = "\177\344\341\250w׆0\000B:p\000Al\320\000Ak\030\177\201\000\240\000\000\000\004\000Ak\004"
        msg = {msg_name = 0x7f80fa1c, msg_namelen = 28, msg_iov = 0x7f80fa60, msg_iovlen = 1, msg_control = 0x7f80f9e0, msg_controllen = 32, msg_flags = 0}
        pktinfo = 0x0
        opt = <optimized out>
        iov = {iov_base = 0x7f80f300, iov_len = 1536}
        addr = {sin6_family = 30676, sin6_port = 33408, sin6_flowinfo = 2139159088, sin6_addr = {__in6_u = {__u6_addr8 = "\000\000\000\034\000\000\000\000\000\000\000\000\000\n\000", __u6_addr16 = {0, 28, 0, 0, 0, 0, 10, 0}, __u6_addr32 = {28, 0, 0, 655360}}}, sin6_scope_id = 0}
        tv = {tv_sec = 116, tv_usec = 532000}
        round_end = 173006852
        rc = 215 '\327'
        timeout = <optimized out>
        retx = 0x4169f4 <dhcpv6_retx+24>
        start = 86563389
        round_start = 172961641
        elapsed = 86326931
        trid = "K\250\026"
        len = -1
        rto = 116532
#7  0x00401d1e in main (argc=<optimized out>, argv=<optimized out>) at /home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/odhcp6c-2014-12-10/src/odhcp6c.c:287
        mode = <optimized out>
        ia_pd_len = <optimized out>
        ia_na_len = <optimized out>
        server_id_len = <optimized out>
        pidfile = 0x0
        script = 0x7f810f39 "/lib/netifd/dhcpv6.script"
        l = <optimized out>
        buf = "w\324\352\300w\324\374\300\000\000\000\000\000\000\000\000w\330\240\024\000@\021\034\000@\n\325\177\200\377P\000B:p\177\344\341\247\000\000\017\367w\272\247Xw\331\020\000w\327E\000w\327$Hw\327)(\000\000\000\000\000\000\000\000\177\201\017.wԃ\260\000\000\004\205wΧ\211\000\000\004V\000\000\001\377\000\000\017\367w\272\247X\177\200\377\240w\327C\350wΧ\211", '\000' <repeats 17 times>, "A"
        optpos = 0x78fefcf8 <Address 0x78fefcf8 out of bounds>
        opttype = 3886
        optlen = 32641
        ia_na_mode = IA_MODE_TRY
        ia_pd_mode = IA_MODE_TRY
        ia_pd_iaid_index = <optimized out>
        ifid = {__in6_u = {__u6_addr8 = '\000' <repeats 15 times>, __u6_addr16 = {0, 0, 0, 0, 0, 0, 0, 0}, __u6_addr32 = {0, 0, 0, 0}}}
        sol_timeout = 120
        verbosity = 0
        help = <optimized out>
        daemonize = false
        logopt = 1
        c = <optimized out>
        client_options = <optimized out>
        ifname = 0x7f810f5d "pppoe-wan"
(gdb) 

comment:8 Changed 3 years ago by nbd

does this still happen in current trunk?

comment:9 Changed 3 years ago by bittorf@…

no, have not seen it since a while - please close, i will reopen if needed.

comment:10 Changed 3 years ago by nbd

  • Resolution set to worksforme
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.