Modify

Opened 3 years ago

Last modified 3 years ago

#18149 new defect

Unifi reboot command failing with LED enabled

Reported by: webtron Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: unifi reboot Cc:

Description

Unifi UAP and Unifi LR both display this where they hang on reboot if the LED is enabled.
I have this in my /etc/config/system

config led 'led'

option sysfs 'ubnt:green:dome'
option default 1

The build is

BARRIER BREAKER (Bleeding Edge, r41336)

Very rarely the ap will come back up after issuing the reboot command but generally you have to power cycle them to get them working again.
I think this forum post is the same issue.
https://forum.openwrt.org/viewtopic.php?id=51917
I have ap's with 00:27 mac addresses through to the latest ones and they all do this.

Attachments (0)

Change History (8)

comment:1 Changed 3 years ago by Shogo

I'm not the only one. Finally, sorry that is happening, but I'm happy also :)
The issue is something in the middle.

U-boot, or at least that Unifi U-boot fails to relocate to RAM when it's initialized.
It's definitely a mix of hardware with software.
This does not happen with the original Ubiquiti firmware.

You LED remark is quite good, did you try putting the box in a reboot loop every 20 seconds with the LED off? Will try that myself.

My workaround was that I changed the U-boot with the airrouter version, which in the last version they added a watchdog in case the u-boot fails to relocate.
It still happens, but it will reset the CPU after 10 seconds.
The downside of that is that I lost the rescue functionality by hardware pressing which is annoying.

comment:2 Changed 3 years ago by Shogo

Ah, also it happens almost on all the MX board range ( AirRouter, UAP, UniFi LR, UAP outdoor ) not sure about the nanostation, bullet and pico

comment:3 Changed 3 years ago by webtron

The exact same build I'm using in the Unifi doesn't display the reboot problem on any of the Pico/Nano/Bullet M2 range and I've got heaps of them running that firmware.

comment:4 Changed 3 years ago by Shogo

That's good.
I can confirm that is happening with the AirRouter UAP, UAP-LR,UAL-Outdoor ( not on the + )

comment:5 Changed 3 years ago by Shogo

I'm testing your LED turned off and reboot thing with the original unifi u-boot.
Lets see if there is a relationship.

When you issue a reboot command on the original firmware, it takes 2-3 time longer than on openwrt.
Maybe it clears/closes something before reboot?

comment:6 Changed 3 years ago by Shogo

Doesn't matter if the LED is on or off, still the same behaviour.
It's something else.

comment:7 Changed 3 years ago by anonymous

"Doesn't matter if the LED is on or off, still the same behaviour.
It's something else."
What mac addresses are the ap's you're testing on?
I'm testing more this morning and it's happening a lot more on the 00:27 and the 24:A4 unifi's than the DC:9F or the 04:18.
I noticed when I first started looking at this ages ago that any custom scripts that were looping or sleep commands had to be exited before the reboot command was executed or the shutdown would hang.

comment:8 Changed 3 years ago by webtron

Can the mods close this ticket please. I've found a process that spawns from one of my scripts that's not exiting and causing this problem.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.