Modify

Opened 3 years ago

Last modified 3 years ago

#18117 new defect

dhcp doesnt work after random time

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

Have to reboot router to get clients working again (get ip). Theres nothing in the logs wndr3800 r42707 Worked for the last 4 days not broken again.

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by anonymous

I just have this issue on one of my three wndr3800 routers, maybe because of the way they connect via wan? The one having this issue has dhcp client modus WAN to a cable modem, the others just have static IP. I also noticed IPv6 lease time is always 24h regardless what number you put in the configs, 12h, 31d which just affects IPv4 lease.

comment:2 Changed 3 years ago by anonymous

After 26h the router is in this "broken state" again, clients dont get IP via DHCP (getting ip... auth failure). restarting dnsmasq doesnt do anything /etc/init.d/dnsmasq restart. Only rebooting the router solves it for a while. Theres nothing in logread about this.

comment:3 Changed 3 years ago by anonymous

It seems the problem is wifi, restarting wifi solves it and clients get IP. My wifi config:

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:11.0'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'TX-STBC'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'
	option txpower '17'
	option country 'DE'
	option hwmode '11g'
	option distance '20'
	option channel '11'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option encryption 'psk2+ccmp'
	option key '...'
	option ssid '...'
	option network 'lan'

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.