Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#18102 closed defect (not_a_bug)

Asterisk/Telephony has errors in Makefile

Reported by: 42@… Owned by: slachta
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

ERROR: please fix package/feeds/telephony/asterisk-1.8.x/Makefile - see logs/package/feeds/telephony/asterisk-1.8.x/dump.txt for details
ERROR: please fix package/feeds/telephony/asterisk-11.x/Makefile - see logs/package/feeds/telephony/asterisk-11.x/dump.txt for details

relevant line in dump.txt:

make[2]: * No rule to make target `/home/x/openwrt-64/include/ltqtapi.mk'. Stop.

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by swalker

  • Owner changed from developers to slachta
  • Status changed from new to assigned

comment:2 Changed 3 years ago by 42@…

This commit caused the problem: http://git.openwrt.org/?p=openwrt.git;a=commit;h=62561304c5e130dcc7450f610c5681da5d043b43

Here's a patch that makes it working again: http://paste.scratchbook.ch/view/c0871b1c
(remove ltqtapi.mk in both Asterisk Makefiles)

comment:3 Changed 3 years ago by slachta

  • Resolution set to not_a_bug
  • Status changed from assigned to closed

Hi,

have you updated your feeds and buildroot? In current trunk (master revision on git telephony repository) there is no include for ltqtapi.mk in asterisk-1.8.x Makefile. I am not sure why the buildroot complaints about missing rules for asterisk-11.x, since the support for chan-lantiq was introduced only for asterisk-1.8.x (see asterisk-11.x Makefile).

Please, update your OpenWrt buildroot by:

git pull

or

svn update

I think you might be using the older Telephony repository located somewhere else. Please, use this feeds.conf.default.

And also update your feeds:

./scripts/feeds update -a && ./scripts/feeds/install -a

The ltqtapi.mk removal was done in this commit.

I would strongly recommend to start with a clean OpenWrt buildroot. I am closing this as a "not a bug", since you might be using the outdated repository. Feel free to reopen, if you are sure that it is a bug. If it is a bug, please, reopen the issue and attach the feeds.conf.default among attachments and paste here the last commit of OpenWrt buildroot you are using.

Regards,
Jiri Slachta

comment:4 Changed 3 years ago by anonymous

Duh, my fault indeed. My feeds.conf pointed to a local git repo which updates itself every night. This local repo had a wrong (old) feed configured. Everything works now, thank you very much for that detailed explanation!

Best regards

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.