Modify

Opened 12 years ago

Closed 12 years ago

Last modified 4 years ago

#181 closed defect (worksforme)

linux-atm does not compile with latest trunk

Reported by: florian Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version:
Keywords: linux atm compile error Cc:

Description

In file included from ../../src/include/atm.h:11,
                 from text2atm.c:15:
/home/florian/openwrt/trunk/openwrt/staging_dir_mipsel/lib/gcc/mipsel-linux-uclibc/3.4.4/../../../../mipsel-linux-uclibc/sys-include/linux/atm.h:211: error: parse error before "uint32_t"
/home/florian/openwrt/trunk/openwrt/staging_dir_mipsel/lib/gcc/mipsel-linux-uclibc/3.4.4/../../../../mipsel-linux-uclibc/sys-include/linux/atm.h:213: error: parse error before '}' token
/home/florian/openwrt/trunk/openwrt/staging_dir_mipsel/lib/gcc/mipsel-linux-uclibc/3.4.4/../../../../mipsel-linux-uclibc/sys-include/linux/atm.h:217: error: parameter `addr' has incomplete type
In file included from text2atm.c:16:
../../src/include/atmsap.h:43: error: parse error before "uint8_t"
../../src/include/atmsap.h:43: warning: function declaration isn't a prototype
text2atm.c: In function `do_try_nsap':

Attachments (1)

linux-atm.patch (697 bytes) - added by VinceLe <vincent.legoll@…> 11 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 12 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

Can't reproduce. Works fine for me

comment:2 Changed 11 years ago by VinceLe <vincent.legoll@…>

This closed-bug seems related to using host include file when cross building, I don't think this is a good practice. The absolute-filename #include looks wrong to me.

Found http://forum.openwrt.org/viewtopic.php?id=3173
and "hacked the hack too" which worked for me ;-)

This looks like an upstream bug to me, as linux-atm trunk cvs has the same hardcoded path, but v2_5_0 branch has no stdint.h file...
I'll raise the discussion with the maintainers...

I've got that patch in my copy of br-ng, is this satisfactory ? Maybe as a temporary workaround until a proper fix is in...
# svn diff

Index: package/linux-atm/patches/400-stdint-local-instead-of-host.patch
===================================================================
--- package/linux-atm/patches/400-stdint-local-instead-of-host.patch (revision 0)
+++ package/linux-atm/patches/400-stdint-local-instead-of-host.patch (revision 0)
@@ -0,0 +1,15 @@
+--- linux-atm-2.4.1/src/include/stdint.h 2001-09-03 20:41:06.000000000 +0200
++++ linux-atm-2.4.1/src/include/stdint.h.my 2006-08-26 22:08:41.000000000 +0200
+@@ -4,11 +4,7 @@
+
+ #include <features.h>
+
+-#if GLIBC >= 2 && GLIBC_MINOR >= 1
+-
+-#include "/usr/include/stdint.h"
+-
+-#elif GLIBC >= 2
++#if GLIBC >= 2
+
+ /* Works for i386 and Alpha */
+

Changed 11 years ago by VinceLe <vincent.legoll@…>

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.