Modify

Opened 3 years ago

#18066 new defect

Using eglibc 2.19 causes valgrind build to fail

Reported by: whotopia@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: toolchain Version: Barrier Breaker 14.07
Keywords: Cc:

Description

When trying to build the toolchain with eglibc 2.19, Valgrind check configure will fail:

checking for unistd.h... yes
checking features.h usability... yes
checking features.h presence... yes
checking for features.h... yes
checking the GLIBC_VERSION version... unsupported version 2.19
configure: error: Valgrind requires glibc version 2.2 - 2.16
make[3]: *** [/mnt/src/stevie/ent/14.07-openwrt/build_dir/target-i386_geode_eglibc-2.19/valgrind-3.8.1/.configured_] Error 1
make[3]: Leaving directory `/mnt/src/stevie/ent/14.07-openwrt/package/devel/valgrind'
make[2]: *** [package/devel/valgrind/compile] Error 2
make[2]: Leaving directory `/mnt/src/stevie/ent/14.07-openwrt'
make[1]: *** [/mnt/src/stevie/ent/14.07-openwrt/staging_dir/target-i386_geode_eglibc-2.19/stamp/.package_compile] Error 2
make[1]: Leaving directory `/mnt/src/stevie/ent/14.07-openwrt'
make: *** [world] Error 2

Attachments (0)

Change History (0)

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.