Modify

Opened 3 years ago

Closed 3 years ago

#18052 closed defect (fixed)

Kernel build error: libnl-tiny

Reported by: mario_lopes Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: libnl-tiny Cc:

Description

Hi.

I did already did "make clean" but issue persists as follows with "make V=s", r42830:

make[4]: Entering directory `/home/user/openwrt/trunk/build_dir/target-arm_mpcore+vfp_uClibc-0.9.33.2_eabi/libnl-tiny-0.1'
arm-openwrt-linux-uclibcgnueabi-gcc -Wall -c -o nl.o -Iinclude -Os -pipe -march=armv6k -mtune=mpcore -mfpu=vfp -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -mfloat-abi=hard -fpic nl.c
In file included from nl.c:84:0:
include/netlink-local.h:16:19: fatal error: stdio.h: No such file or directory
 #include <stdio.h>
                   ^
compilation terminated.
make[4]: *** [nl.o] Error 1
make[4]: Leaving directory `/home/user/openwrt/trunk/build_dir/target-arm_mpcore+vfp_uClibc-0.9.33.2_eabi/libnl-tiny-0.1'
make[3]: *** [/home/user/openwrt/trunk/build_dir/target-arm_mpcore+vfp_uClibc-0.9.33.2_eabi/libnl-tiny-0.1/.built] Error 2
make[3]: Leaving directory `/home/user/openwrt/trunk/package/libs/libnl-tiny'
make[2]: *** [package/libs/libnl-tiny/compile] Error 2
make[2]: Leaving directory `/home/user/openwrt/trunk'
make[1]: *** [/home/user/openwrt/trunk/staging_dir/target-arm_mpcore+vfp_uClibc-0.9.33.2_eabi/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/user/openwrt/trunk'
make: *** [world] Error 2

Thanks

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by anonymous

From #openwrt IRC channel:

17:19:26 < nunojpg> openwrt/trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/netifd-2014-10-02/main.c:14:19: fatal error: stdio.h: No such file or directory
17:19:35 < nunojpg> something wrong?
17:25:37 < matteo> nunojpg: it seems that you did some update recently
17:25:48 < matteo> which affected the toolchain
17:26:02 < matteo> try doing make distclean
17:26:09 < matteo> sorry
17:26:13 < matteo> make dirclean
17:26:26 < matteo> and also rm -rf build_dir stagin_dir
17:26:38 < matteo> you have torebuild the toolchain tought :/
18:20:19 < nunojpg> matteo: thanks. I didn't believe this stdio.h missing error could be caused by a toolchain change

comment:2 Changed 3 years ago by mario_lopes

Hi.

The command "make dirclean" was successful in my case, no need to remove directories build_dir and stagin_dir.

Thanks.

comment:3 Changed 3 years ago by anonymous

There's a closed related issue: https://dev.openwrt.org/ticket/18037#comment:1

comment:4 Changed 3 years ago by cyrus

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.