Modify

Opened 3 years ago

Closed 3 years ago

#18045 closed defect (duplicate)

vif not inherit override MAC address

Reported by: rceccleston Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Barrier Breaker 14.07
Keywords: override MAC address Cc:

Description

An 'override MAC address' bug appears to prevent multiple WDR4900 running BB Final to act as wireless 'access points' and co-exist on the same network.

ERROR - System logs - Multiple entries indicate packets received with the same source and destination MAC address from bridge virtual interface.

br-wifi: received packet on eth0.3 with own address as source address

CAUSE - Duplicate MAC Address - OpenWRT assigns 00:04:9F:EF:01:01 to the first virtual interface, conflicting the same MAC address across multiple devices.

00:04:9F = Freescale Semiconductor SOC

EF:01:01 = Unique 'virtual interface' identifier

RESOLUTION - Override MAC Addresses - Specify unique MAC address in 'Interfaces\interface\Advanced Settings\Override MAC Address' For example, '00:04:9F:EF:01:02'.

Network configuration file

config interface 'wifi'

option _orig_ifname 'wlan1-1'
option _orig_bridge 'true'
option type 'bridge'
option proto 'static'
option ipaddr '###.###.###.###'
option netmask '255.255.255.0'
option macaddr '00:04:9F:EF:01:02'
option ifname 'eth0.#'

BUG - Broken Bridge - The bridged Ethernet interface will not inherited the new MAC address from the 'br-wifi' interface.

br-wifi Link encap:Ethernet HWaddr 00:04:9F:EF:01:02

inet addr:192.168.3.2 Bcast:192.168.3.255 Mask:255.255.255.0
inet6 addr: fe80::204:9fff:feef:102/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:26 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3532 (3.4 KiB) TX bytes:1420 (1.3 KiB)

eth0.3 Link encap:Ethernet HWaddr 00:04:9F:EF:01:01

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:42 errors:0 dropped:0 overruns:0 frame:0
TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4734 (4.6 KiB) TX bytes:1650 (1.6 KiB)

FIX - Repair Bridge - Re-Align / correct the MAC address of the 'virtual interface with the following command.

ifconfig eth0.3 hw ether 00:04:9F:EF:01:02

br-wifi Link encap:Ethernet HWaddr 00:04:9F:EF:01:02

inet addr:192.168.3.2 Bcast:192.168.3.255 Mask:255.255.255.0
inet6 addr: fe80::204:9fff:feef:102/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:26 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3532 (3.4 KiB) TX bytes:1420 (1.3 KiB)

eth0.3 Link encap:Ethernet HWaddr 00:04:9F:EF:01:02

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:42 errors:0 dropped:0 overruns:0 frame:0
TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4734 (4.6 KiB) TX bytes:1650 (1.6 KiB)

Unfortunately, the command should be issued after rebooting the router, since this fix is lost upon reboot.

Once the above has been completed, the virtual interface will forward / bridge traffic between the chosen SSID and VLAN, allowing multiple WDR4900's to co-exist on the same LAN as wireless 'access points'.

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by bittorf@…

duplicate of /ticket/14714.html

comment:2 Changed 3 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.