Modify

Opened 3 years ago

Closed 3 years ago

#17923 closed defect (worksforme)

Kernel-Problem with "kmod-fs-ext4" installation

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: kmod-fs-ext4 Cc:

Description

I can't install "kmod-fs-ext4" and several other packages needed for USB-Storage support and SAMBA. They all give the same error messages. But it should work, because I read many tutorials where people use these packages with my router model and OpenWRT firmware.

My Router
TP-Link TL-WR1043ND v1.x
OpenWrt Chaos Calmer r42542 (TRUNK) / LuCI Trunk (svn-r10528)
Kernel Version: 3.10.49

Messages from Installation
Installing kmod-fs-ext4 (3.10.49-1) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/base/kmod-fs-ext4_3.10.49-1_ar71xx.ipk.

Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-ext4:
  • kernel (= 3.10.49-1-567826d15415b073430d1fe9be9d91f3) * kernel (= 3.10.49-1-567826d15415b073430d1fe9be9d91f3) * kernel (= 3.10.49-1-567826d15415b073430d1fe9be9d91f3) *
  • opkg_install_cmd: Cannot install package kmod-fs-ext4.

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by anonymous

Your installed OpenWrt trunk is too old for the newer trunk packages which you are trying to install.
Use a proper release instead of trunk, if you want the updates to work properly. Or compile trunk yourself.

comment:2 Changed 3 years ago by anonymous

DOESN'T WORK!
I just flashed the latest stable Firmware. Same error when trying to install these packages. Now even OpenVPN doesnt work!

OpenWrt Barrier Breaker 14.07-rc3 / LuCI Trunk (svn-r10467)


Installing kmod-fs-ext4 (3.10.49-1) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/base/kmod-fs-ext4_3.10.49-1_ar71xx.ipk.
Configuring uhttpd.

usr/lib/opkg/info/uhttpd.postinst: line 4: default_postinst: not found
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-ext4:
  • kernel (= 3.10.49-1-567826d15415b073430d1fe9be9d91f3) * kernel (= 3.10.49-1-567826d15415b073430d1fe9be9d91f3) * kernel (= 3.10.49-1-567826d15415b073430d1fe9be9d91f3) *
  • opkg_install_cmd: Cannot install package kmod-fs-ext4.
  • pkg_run_script: package "uhttpd" postinst script returned status 127.
  • opkg_configure: uhttpd.postinst returned 127.

comment:3 Changed 3 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

The proper repository for 14.07-rc3 is http://downloads.openwrt.org/barrier_breaker/14.07-rc3/ar71xx/generic/packages - you probably retained the old opkg.conf when upgrading to the release image.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.