Modify

Opened 3 years ago

Last modified 3 years ago

#17897 new defect

/etc/init.d/pptpd restart does not work

Reported by: khanamir21 Owned by: developers
Priority: normal Milestone:
Component: packages Version: Barrier Breaker 14.07
Keywords: Cc:

Description

Hi,
/etc/init.d/pptpd restart or start does not start pptpd...

It does start if I enter /usr/sbin/pptpd

root@OpenWrt:/tmp/run# /usr/sbin/pptpd
root@OpenWrt:/tmp/run# ps | grep pptpd
11116 root 796 S /usr/sbin/pptpd
11118 root 1356 S grep pptpd

Router : MyNet N600
Firmware: OpenWrt Barrier Breaker 14.07-rc3 / LuCI Trunk (svn-r10467)

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by patrick@…

I have the same problem with my openwrt router since the update to: OpenWrt Barrier Breaker 14.07 / LuCI Trunk (0.12+svn-r10530)

I figured out the following:

First of all you have to enable the pptpd manually in /etc/config/pptpd

option 'enabled' '1'

After that the pptpd service starts, but the init script has some problems.

Everytime you restart the service the init script reads the usernames/passwords from the /etc/config/pptpd file and writes it again into the /etc/ppp/chap-secrets file. so a user gets inserted multiple times.

The same thing also happens with the localip and remoteip setting -> see setup_config method in the init script.

comment:2 Changed 3 years ago by anonymous

(sorry for being anon)
I wrote short howto with modified init script. http://wiki.openwrt.org/doc/howto/vpn.server.pptpd.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.