Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#17832 closed enhancement (not_a_bug)

Add option for reverse DNS lookup on list of associated stations in LuCI

Reported by: martin.priv@… Owned by: developers
Priority: low Milestone: Barrier Breaker 14.07
Component: packages Version: Barrier Breaker 14.07
Keywords: LuCI Cc:

Description

On "Status-Overview" the list of associated stations show only the MAC-adress. It would be convenient to be able to configure what to show, with MAC always shown and IP and DNS-name selectable.
This applies also to "Network-Wifi", which already shows the IP-adress.

Or simply print MAC + DNS and if DNS is not available MAC+IP and if IP is not available (router did not provide IP and dont have the IP-adress in the ARP-table yet) just show the MAC-adress.

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by d2b40501@…

This is a really great idea. The information could even be taken from the dhcp leases file, so everything that has a hostname associated via static lease is easily identified. The current MAC display is NOT very useful!

comment:2 follow-up: Changed 3 years ago by jow

  • Resolution set to not_a_bug
  • Status changed from new to closed

Please send a PR against LuCI on Github if you like tto have this feature implemented. Closing, as this is a feature request and not a bug report.

comment:3 in reply to: ↑ 2 Changed 3 years ago by d2b40501@…

Replying to jow:

Please send a PR against LuCI on Github if you like tto have this feature implemented. Closing, as this is a feature request and not a bug report.

Hi jow, I understand you closed this as it is not a bug. However I fear I do not have the knowledge to change the code myself. Is there any place this could be raised for discussion to the devs, I feel a lot of users would really welcome this addition and the web gui would definitely profit from this change (which I hope should be quite simple for someone who knows the code).

Thanks!

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.