Modify

Opened 3 years ago

Last modified 3 years ago

#17829 new defect

LuCI with multiple WAN network status - wrong interface

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: luci Version: Trunk
Keywords: Cc:

Description

Following instructions found http://wiki.openwrt.org/doc/howto/mwan3

The issue is that it finds the interface used by the default root to determine which interface is the WAN interface. In configuring multiple WAN interfaces, there are multiple default routes, and it stops when it finds the first default route and uses that interface.

In my case, I have mwan3 configured to route all traffic through a modem connected to this router, with an emergency failover routing back through LAN to a second router on the network. The status page shows details for my lan.

Ideally, it would show all interfaces with default routes sorted by metric, alternatively, show just the interface having a default route and with the lowest metric.

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by anonymous

comment:2 Changed 3 years ago by anonymous

Though he might be a good person to look into fixing it, it really isn't caused by mwan, its just that mwan is a common configuration that can trigger it since that really just uses features that are already there. I will alert him to this bug in case he is interested in taking it on.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.