Modify

Opened 3 years ago

Closed 3 years ago

#17828 closed defect (fixed)

Channel 13 does not always work after boot

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

Thu Sep 11 18:22:13 2014 daemon.notice netifd: radio0 (1276): Configuration file: /var/run/hostapd-phy0.conf
Thu Sep 11 18:22:13 2014 daemon.notice netifd: radio0 (1276): wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Thu Sep 11 18:22:13 2014 daemon.notice netifd: radio0 (1276): wlan0: IEEE 802.11 Configured channel (13) not found from the channel list of current mode (1) IEEE 802.11g
Thu Sep 11 18:22:13 2014 daemon.notice netifd: radio0 (1276): wlan0: IEEE 802.11 Hardware does not support configured channel
Thu Sep 11 18:22:13 2014 daemon.notice netifd: radio0 (1276): Could not select hw_mode and channel. (-3)
Thu Sep 11 18:22:13 2014 daemon.notice netifd: radio0 (1276): wlan0: interface state COUNTRY_UPDATE->DISABLED
Thu Sep 11 18:22:13 2014 daemon.notice netifd: radio0 (1276): wlan0: AP-DISABLED
Thu Sep 11 18:22:13 2014 daemon.notice netifd: radio0 (1276): hostapd_free_hapd_data: Interface wlan0 wasn't started
Thu Sep 11 18:22:13 2014 daemon.notice netifd: radio0 (1276): cat: can't open '/var/run/wifi-phy0.pid': No such file or directory
Thu Sep 11 18:22:13 2014 daemon.notice netifd: radio0 (1276): Command failed: Invalid argument

I have to reboot a few times, it's I would say a 90% chance it works on first boot though, but it can fail and this happens.

Attachments (0)

Change History (5)

comment:1 Changed 3 years ago by anonymous

hello??

comment:2 Changed 3 years ago by bittorf@…

please try a fresh built with r42624 and report again, showing us your /etc/config/wireless and /etc/config/network

comment:3 Changed 3 years ago by anonymous

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option ipaddr '...'
	option _orig_ifname 'eth0.1 wlan0 wlan1'
	option _orig_bridge 'true'
	option ifname 'eth0.1'

config interface 'wan'
	option _orig_ifname 'eth1'
	option _orig_bridge 'false'
	option ifname 'eth1'
	option proto 'static'
	option netmask '255.255.255.0'
	option dns '8.8.8.8 8.8.4.4'
	option ipaddr '...'
	option gateway '...'
	option delegate '0'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config globals 'globals'
	option ula_prefix '...::/48'

config switch
	option name 'rtl8366s'
	option reset '1'
	option enable_vlan '1'
	option blinkrate '2'

config switch_vlan
	option device 'rtl8366s'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_port
	option device 'rtl8366s'
	option port '1'
	option led '6'

config switch_port
	option device 'rtl8366s'
	option port '2'
	option led '9'

config switch_port
	option device 'rtl8366s'
	option port '5'
	option led '2'

config interface 'vpn1'
	option proto 'static'
	option ifname 'tun0'
	option auto '0'
	option delegate '0'

config interface 'vpn2'
	option proto 'static'
	option ifname 'tun1'
	option auto '0'
	option delegate '0'

config interface 'vpn3'
	option proto 'static'
	option auto '0'
	option _orig_ifname 'tap0'
	option _orig_bridge 'false'
	option ifname 'tap0'
	option delegate '0'
config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:11.0'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'TX-STBC'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'
	option txpower '17'
	option hwmode '11g'
	option country 'DE'
	option distance '8'
	option channel '13'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid '...'
	option encryption 'psk2+ccmp'
	option network 'lan'
	option key '...'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:12.0'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'TX-STBC'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'
	option txpower '17'
	option country 'DE'
	option channel '44'
	option distance '8'
	option hwmode '11na'
	option htmode 'HT40'

config wifi-iface
	option device 'radio1'
	option mode 'ap'
	option ssid '...'
	option encryption 'psk2+ccmp'
	option network 'lan'
	option key '...'

comment:4 Changed 3 years ago by nbd

fixed in r45252

comment:5 Changed 3 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.