Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#17824 closed defect (fixed)

procd / hang during shutdown/startup / regression

Reported by: bittorf@… Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: procd hang init Cc:

Description

i while ago, procd implemented a timeout (15 sec) for
hanging tasks during startup/init. this works and can
be easily checked with placing this snippet in any
startup-script:

start()                                                                                                                                                                                        
{                                                                                                                                                                                              
        local i=300                                                                                                                                                                            
        while let i-=1; do                                                                                                                                                                     
                echo "still running: $i" >>/tmp/CHECK                                                                                                                                          
                sleep 1                                                                                                                                                                        
        done                                                                                                                                                                                   
}           

the same for shutdown (STOP-scripts) e.g. umount
tested with r42232 and r42464 this does not work anymore,
but i'am pretty sure it was working with older versions.

this can be vary annoying, when you reboot a far away router and it hangs during bootup or shutdown.

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by bittorf@…

maybe related to /ticket/17839.html

comment:2 Changed 3 years ago by blogic

  • Resolution set to fixed
  • Status changed from new to closed

fixed the stop case, the start case needs a bit more thinking to be fixed as we do have services like dropbear which do indeed take up to several minutes to start

comment:3 Changed 3 years ago by bittorf@…

i'am ok with having a timeout of 1 hour till the issue is fixed. i have no better idea for now.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.