Modify

Opened 3 years ago

Closed 3 years ago

#17819 closed defect (wontfix)

cups and vim: libacl dependency

Reported by: dl9rdz@… Owned by: developers
Priority: low Milestone:
Component: packages Version: Barrier Breaker 14.07
Keywords: libacl Cc:

Description

I'm trying to compile packages for r42444.

Compile fails for vim and for cups packages because of a missing libacl dependency. I am getting the following error from make:
Package vim is missing dependencies for the following libraries:
libacl.so.1
Makefile:188: recipe for target '/home/hans/openwrt-rc2/openwrt/bin/ar71xx/packages/oldpackages/vim_7.3-1_ar71xx.ipk' failed

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by attila.lendvai

i see this too, but i'm not sure it's that simple, because i've seen similar errors with other packages...

did you by any chance enable some ACL related config entry in make menuconfig? (i vaguely remember turning on something ACL)

comment:2 Changed 3 years ago by attila.lendvai

FTR, if i change the relevant line in the package Makefile to this:

DEPENDS:=+libncurses +libacl

then this runs for me without any errors:

make package/vim/compile V=99

comment:3 Changed 3 years ago by nbd

  • Resolution set to wontfix
  • Status changed from new to closed

vim and cups are unmaintained. no changes will be made to those packages until they are submitted to github and maintained there from that point on.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.