Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#17809 closed defect (worksforme)

log daemon crashes when log to file is set

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: base system Version: Trunk
Keywords: Cc:

Description

The new log daemon craps out after less than an hour of logging to a file at the same time as using the memory log. No, the disk is not full. No RAM is not exhausted.

Attachments (0)

Change History (7)

comment:1 Changed 3 years ago by anonymous

Not this also affects rc3

comment:2 Changed 3 years ago by anonymous

Based on rereading uci config wiki page for system I see that configuration is only *supposed* to be allowed for one or the other of circular and file so the bug is actually that if you configure both a log_size and a log_file, but don't specify log_type, that the log daemon tries to do both, and judging by log_type being defined in wiki an an either/or choice this is not a supported option.

Therefore if both log_file and log_size are specified either circular or file should be chosen as the default for for log_type, and log daemon should not try to do both.

comment:3 Changed 3 years ago by blogic

  • Resolution set to worksforme
  • Status changed from new to closed

cannot reproduce the bug. which target are you on ?

comment:4 Changed 3 years ago by anonymous

ar71xx bb-rc3

comment:5 Changed 3 years ago by anonymous

it appears to be an intermittent bug, not every time, as it mysteriously worked for one boot.

comment:6 Changed 3 years ago by anonymous

silly question, but did you set 'log_size'. The circular buffer appears to get used with no issues when 'log_size' is not set but 'log_file' is. The error occurs *only* when both 'log_size' AND 'log_file' are specified in /etc/config/system.

comment:7 Changed 3 years ago by anonymous

Actually I'm not sure the daemon stops logging - it may be instead that the daemon is deleting the log *file* when the circular buffer size gets exceeded. The log file contains only a very small number of entries, but they seem to be current.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.