Modify

Opened 3 years ago

Closed 3 years ago

#17798 closed defect (worksforme)

ARP response sent by router cannot be received by lan host.

Reported by: yousong Owned by: developers
Priority: normal Milestone:
Component: kernel Version: Trunk
Keywords: Cc:

Description

It's HiWiFi HC6361 with AR9331.

Previously I encountered the problem quite often on an Android phone MX3. When the phone go to sleep and wake up again

  • It can be observed from both phone and router that wireless connection stayed connected.
  • IP and other network settings are correct.
  • But ARP entries for router gateway cannot be obtained causing no internet access and "host unreachable" when trying to access router itself.

I need to disconnect and reconnect WiFi to bring the link back. This is readily reproducible.

Just a moment ago this problem happened again on wired connection (Apple A1277 USB Ethernet Adapter). I tried to bring down and up interface br-lan and the problem go away. I do not know what triggered this at the moment.

I tried to monitor the traffic on LAN and found that ARP requests sent by host were properly received by router, then ARP responses were sent but lan host cannot receive it. ping and arping were used to generate ARP traffic.

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by yousong

Nothing special about the default switch config.

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'

comment:2 Changed 3 years ago by yousong

And the swconfig output.

root@OpenWrt:/tmp# swconfig dev eth0 show
Global attributes:
        enable_vlan: 1
Port 0:
        pvid: 1
        link: port:0 link:up speed:1000baseT full-duplex txflow rxflow 
Port 1:
        pvid: 1
        link: port:1 link:down
Port 2:
        pvid: 1
        link: port:2 link:down
Port 3:
        pvid: 1
        link: port:3 link:down
Port 4:
        pvid: 1
        link: port:4 link:up speed:100baseT full-duplex auto
VLAN 1:
        vid: 1
        ports: 0 1 2 3 4 

comment:3 Changed 3 years ago by yousong

I upgraded firmware for my phone and the issue has not occurred for more than a month (OpenWrt version is the same). This ticket can be close for the moment.

comment:4 Changed 3 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.