Modify

Opened 3 years ago

Closed 3 years ago

#17788 closed defect (duplicate)

icmp6_send errors on boot

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

[   32.940000] icmp6_send: no reply to icmp error
[   32.940000] icmp6_send: no reply to icmp error
[   32.940000] icmp6_send: no reply to icmp error
[   32.950000] icmp6_send: no reply to icmp error
[   32.950000] icmp6_send: no reply to icmp error
[   36.090000] icmp6_send: no reply to icmp error
[   36.090000] icmp6_send: no reply to icmp error
[   36.090000] icmp6_send: no reply to icmp error
[   36.100000] icmp6_send: no reply to icmp error
[   36.100000] icmp6_send: no reply to icmp error
[   39.950000] net_ratelimit: 1 callbacks suppressed
[   39.950000] icmp6_send: no reply to icmp error
[   39.950000] icmp6_send: no reply to icmp error
[   39.960000] icmp6_send: no reply to icmp error
[   39.960000] icmp6_send: no reply to icmp error
[   44.010000] icmp6_send: no reply to icmp error
[   44.010000] icmp6_send: no reply to icmp error
[   44.010000] icmp6_send: no reply to icmp error
[   44.020000] icmp6_send: no reply to icmp error
[   44.020000] icmp6_send: no reply to icmp error
[   47.950000] icmp6_send: no reply to icmp error
[   47.950000] icmp6_send: no reply to icmp error
[   47.950000] icmp6_send: no reply to icmp error

Attachments (0)

Change History (9)

comment:1 Changed 3 years ago by anonymous

IT seems somewhat is hitting your Firewall :(

what kind of access Type (ipv6 do you using? (aiccu, 6in4, 6rd or native?)

comment:2 Changed 3 years ago by anonymous

I am using default settings:

config dhcp 'wan6'
	option dhcpv6 'hybrid'
	option ra 'hybrid'
	option ndp 'hybrid'
	option master '1'

Or what do you mean?

comment:3 Changed 3 years ago by anonymous

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option leasetime '12h'
	option dhcpv6 'hybrid'
	option ra 'hybrid'
	option ndp 'hybrid'
	option limit '50'
	option ra_management '1'
	option force '1'

comment:4 Changed 3 years ago by anonymous

i mean, did you have check yor Firewall settings, you posted also DHCP settings for wan6, that are normaly not are default settings, or your build may be required it.

what you can do:

  1. try to remove the dhcp settings for "wan6"... im do not have this by default... for any type of wan access, openwrt will create specified interfaces, like "6in4-wan"

im also append my config... so that you can compare yours with mine...

my config:

root@WNDR3700:~# cat /etc/config/dhcp 

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option filterwin2k '1'
	option nonegcache '1'
	option strictorder '1'

config dhcp 'lan'
	option interface 'lan'
	option start '11'
	option limit '254'
	option leasetime 'infinite'
	option dhcpv6 'server'
	option ra 'server'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'

config dhcp
	option leasetime '6h'
	option interface 'WLAN'
	option start '2'
	option limit '20'
	option force '1'

config dhcp
	option leasetime '12h'
	option interface 'bat0'
	option start '2'
	option limit '900'
	option ra 'server'
	option dhcpv6 'server'
	option ra_default '1'
	option ra_management '1'

config dhcp
	option leasetime '12h'
	option interface 'pptp0'
	option start '2'
	option limit '15'
	option force '1'

config dhcp
	option interface 'VPN'
	option start '2'
	option limit '10'
	option leasetime 'infinite'
	option ra 'server'
	option dhcpv6 'server'
	option ra_default '1'
	option ra_management '1'

root@WNDR3700:~# 

also you can check your settings for "wan6" on /etc/config/network

comment:5 Changed 3 years ago by anonymous

Im confused now. I dont even use IPv6, my ISP doesnt support IPv6. Here are my configs:

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option leasetime '12h'
	option dhcpv6 'hybrid'
	option ra 'hybrid'
	option ndp 'hybrid'
	option limit '50'
	option ra_management '1'
	option force '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'

config dhcp 'wan6'
	option dhcpv6 'hybrid'
	option ra 'hybrid'
	option ndp 'hybrid'
	option master '1'
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option ipaddr '10.0.0.201'
	option _orig_ifname 'eth0.1 wlan0 wlan1'
	option _orig_bridge 'true'
	option ifname 'eth0.1'

config interface 'wan'
	option _orig_ifname 'eth1'
	option _orig_bridge 'false'
	option ifname 'eth1'
	option proto 'static'
	option netmask '255.255.255.0'
	option dns '8.8.8.8 8.8.4.4'
	option ipaddr '10.0.1.201'
	option gateway '10.0.1.203'
	option delegate '0'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config globals 'globals'
	option ula_prefix '...'

config switch
	option name 'rtl8366s'
	option reset '1'
	option enable_vlan '1'
	option blinkrate '2'

config switch_vlan
	option device 'rtl8366s'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_port
	option device 'rtl8366s'
	option port '1'
	option led '6'

config switch_port
	option device 'rtl8366s'
	option port '2'
	option led '9'

config switch_port
	option device 'rtl8366s'
	option port '5'
	option led '2'

config interface 'vpn1'
	option proto 'static'
	option ifname 'tun0'
	option auto '0'
	option delegate '0'

config interface 'vpn2'
	option proto 'static'
	option ifname 'tun1'
	option auto '0'
	option delegate '0'

config interface 'vpn3'
	option proto 'static'
	option auto '0'
	option _orig_ifname 'tap0'
	option _orig_bridge 'false'
	option ifname 'tap0'
	option delegate '0'

comment:6 Changed 3 years ago by anonymous

try to remove the settings for "wan6" (by commenting it out) in your DHCP-Settings... :

from:

config dhcp 'wan6'
	option dhcpv6 'hybrid'
	option ra 'hybrid'
	option ndp 'hybrid'
	option master '1'

to

#config dhcp 'wan6'
#	option dhcpv6 'hybrid'
#	option ra 'hybrid'
#	option ndp 'hybrid'
#	option master '1'

after that run:

uci commit && /etc/init.d/network reload

and look at your sytem logs... and report back :)

DO NOT REMOVE only comment it out!, you maybe need to rollback this settings later... when you need it!

comment:7 Changed 3 years ago by anonymous

That didnt change anything, still get those erros after boot.

comment:8 Changed 3 years ago by christian@…

duplicate of /ticket/14173.html

comment:9 Changed 3 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.