Modify

Opened 3 years ago

Last modified 23 months ago

#17751 new defect

netdiscover discovers nothing (r42321)

Reported by: juanriccio@… Owned by: developers
Priority: low Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: netdiscover, scan finding no device Cc:

Description

Chaos Calmer r42321
Netdiscover

Via LuCI: Network -> Configure Diagnostics -> Network Device Scan -> Perform Device Scans (this can take a few minutes)

The operation takes no time at all, but no device is found, even though the LAN is populated with lots of devices.

The scan is configured on the LAN (bridged ethernet/radio) interface, 192.168..../24. I can't find the configuration file, but I'll upload it (or any other info) if asked.

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by anonymous

i'm pretty sure netdiscover isn't installed as it's not in the github packages feed

comment:2 Changed 3 years ago by anonymous

Aha, thanks for your answer, I see!

Netdiscover was included in my previous build (r38350), and I haven't changed my .config, so I thought it would still be there. How could I go about including in this build? How do I add the proper feed (if such a feed exists)?

comment:3 Changed 23 months ago by jkr@…

Same problem. Netdiscover installed in version 0.3-beta6-3 on OpenWrt turris 14.07

comment:4 Changed 23 months ago by jkr@…

The error screen contain:

Scans for devices on specified networks.
Devices discovered for SCAN_LAN (10.0.0.0/255, lan)

[H[JNetwork
Error spliiting mac address string

Powered by LuCI 8035e0f66cd54eee9f45d92990d8e818d49f88f7 Branch (0.12+git-15.293.57125-8035e0f) OpenWrt turris 14.07

My device LuCI pages are locallized to Czech language!

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.