Modify

Opened 3 years ago

Closed 3 years ago

#17748 closed defect (duplicate)

ar71xx: wifi capabilities / wifi detect not working - wr741nd and others

Reported by: musti@… Owned by: developers
Priority: highest Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc: nbd

Description

Applies to trunk r42397 and previous version, not sure how far back. Router TP-Link wr741nd v4

wifi detect command does not return anything for this router, however it works correctly in AA.

As a result of this wifi is incorrectly configured, for this router option hwmode is 11g although the router supports 11ng which was previously correctly detected.

The problem applies also to UBNT 5GHz routers, where hwmode is detected to be 11a, although previously it has been detected correctly as 11n.

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by duvi

Since a while hwmode 11a or 11g has only been deciding whether it's 5 GHz or 2.4 GHz, n hasn't been there anymore.
To use n speeds you need to add 'htmode HT20' or 'htmode HT40'.

comment:2 Changed 3 years ago by musti@…

Ok, duplicate here as well, #17541

This is rather illogical and poorly documented, please add a note to relevant documentation pages.

comment:3 Changed 3 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.