Modify

Opened 3 years ago

Closed 3 years ago

#17737 closed defect (duplicate)

Packages fail to build when using an external toolchain

Reported by: m.bintz@… Owned by: developers
Priority: normal Milestone:
Component: toolchain Version: Trunk
Keywords: Cc:

Description

Using an OpenWRT snapshot from around Jul-16-2014 I am able to successfully build for a WNDR4300 platform with LuCI enabled (with local toolchain). If I then take the toolchain (as generated as a byproduct of the aforementioned build) and configure a clean tree (of the same vintage) to use that external toolchain, a few packages will fail to build.

For example dmesg from linux-utils will be missing -lpthread, polarisssl will be missing -ldl, iptables is missing -ldl in a number of makefiles.

This feels like it may be an error with libtool or pkgconfig not picking up shlibs from the external toolchain's lib directory.

After hacking the generated makefiles for those packages cyassl fails to build because it build-aux/missing can't find automake-1.14 which I can't figure out because I can only find references to automake-1.11

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by swalker

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #17736.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.