Modify

Opened 3 years ago

Closed 3 years ago

#17735 closed defect (fixed)

OpenWRT fails to build host packages when CONFIG_SITE is defined

Reported by: luizluca@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

On systems that defines CONFIG_SITE env var, OpenWRT cannot build packages for host system (make package/xxx/host/compile). This happens on OpenSuSE 13.1, that has CONFIG_SITE=/usr/share/site/x86_64-unknown-linux-gnu by default.

In OpenWRT, CONFIG_SITE defines some cached values for autoconf script, as size of var types. This improves ./configure times.

When building packages to firmware target system, OpenWRT defines the CONFIG_SITE to the correct target dependent config site file. For package built for host system, I guess the CONFIG_SITE is not defined (as there is no "configure: loading site script ..." msg in ./configure).

Whenever CONFIG_SITE is defined previously the make (as in OpenSuSE), OpenWRT build scripts always redefine it to the target CONFIG_SITE. For target builds, this is an expected behavior. However, when building for host system, the usage of the target CONFIG_SITE will probably result in unusable programs as the size of vars (like void*, long, etc) differs from arch to arch.

So, OpenWRT build scripts should, alternatively:
a) not replace CONFIG_SITE when building host packages
b) unset CONFIG_SITE previously build
b) replace CONFIG_SITE to match host arch when building host packages

As an easy workaround, CONFIG_SITE can be unset previously make:

unset CONFIG_SITE; make

Setting CONFIG_SITE to empty value is not enough. It must be unset.

This affects BB and trunk but not AA.

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by anonymous

Seems to be fixed in trunk. Thanks.

comment:2 Changed 3 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.