Modify

Opened 3 years ago

Closed 3 years ago

#17711 closed defect (not_a_bug)

DHCP issue with VLAN

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

I've some issues assigning DCHP ipv4 address to my VLAN WAN port ( work perfectly on AA )

Here is the end of my network file :

config interface 'lan'

option ifname 'eth0.1'

...

config switch

option name 'eth0'
option reset '1'
option enable_vlan '1'

config switch_vlan

option device 'eth0'
option vlan '1'
option ports '1 2 3 4 5t'

config switch_vlan

option device 'eth0'
option vlan '2'
option ports '0 5'

config interface 'wan'

option _orig_ifname 'wan'
option _orig_bridge 'false'
option ifname 'eth0.2'
option proto 'dhcp'

My WAN port is the 0 and is well connected but it can't get a DHCP address,

udhcpc is correctly running : udhcpc -p /var/run/udhcpc-eth0.2.pid -s /lib/netifd/dhcp.script -f -t 0 -i eth0.2 -C

If I run it in command line, I can easily assign an address to eth0 but not to eth0.2

Thanks

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by anonymous

Not defect. You forgot to tag port 5. It should read:

config switch_vlan
    option device 'eth0'
    option vlan '2'
    option ports '0 5t'

comment:2 Changed 3 years ago by nbd

  • Resolution set to not_a_bug
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.