Modify

Opened 3 years ago

Closed 3 years ago

#17698 closed defect (no_response)

netifd segfault and sometimes eats all cpu

Reported by: cz <chengzhicn@…> Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: base system Version: Barrier Breaker 14.07
Keywords: netifd Cc:

Description

I'm running BARRIER BREAKER (14.07, r42258) x86 on vmware.
Sometimes netifd eats all cpu, and web interface becomes unusable, 'top' shows netifd take 100% cpu, 'reboot' command takes no effect until netifd been killed.

Today I also encountered segfault, here is kernel log

[   11.581373] br-lan: port 1(eth0) entered forwarding state
[   12.428512] br-lan: port 2(wlanap) entered forwarding state
[   24.958430] nf_conntrack: automatic helper assignment is deprecated and it will be removed soon. Use the iptables CT target to attach helpers instead.
[32741.085403] netifd[2052]: segfault at 10 ip 080509a3 sp bff78c40 error 4 in netifd[8048000+1b000]
[32746.163564] device wlanap left promiscuous mode
[32746.164313] br-lan: port 2(wlanap) entered disabled state
[32746.559308] br-lan: port 1(eth0) entered disabled state

Attachments (3)

segfault1.txt (4.1 KB) - added by cz <chengzhicn@…> 3 years ago.
stack trace
segfault2.txt (4.1 KB) - added by cz <chengzhicn@…> 3 years ago.
stack trace
segfault3.txt (4.8 KB) - added by cz <chengzhicn@…> 3 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 3 years ago by anonymous

You'll need to provide to the developers either the corresponding netifd core file(s) or gdb backtraces of those core files.

A (sanitized) copy of your /etc/config/network would also help.

comment:2 Changed 3 years ago by anonymous

Please copy the segfault core files somewhere onto your build system and issue the following command in your buildroot:

./scripts/remote-gdb /path/corefile build_dir/target-i386_i486_uClibc-0.9.33.2/netifd-2014-08-13/netifd

In the resulting gdb shell type "bt" and "bt full" and send (attach file) the resulting stacktraces.

Changed 3 years ago by cz <chengzhicn@…>

stack trace

Changed 3 years ago by cz <chengzhicn@…>

stack trace

comment:3 Changed 3 years ago by anonymous

A (sanitized) copy of your /etc/config/network would also help.

comment:4 Changed 3 years ago by cz <chengzhicn@…>

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'guest'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.93.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth1'
        option 'proto' 'pppoe'
        option 'username' 'xxxxxxx'
        option 'password' 'xxxxxxx'

config 'interface' 'office'
        option 'proto' 'pptp'
        option 'server' 'office.example.com'
        option 'username' 'xxxxxxx'
        option 'password' 'xxxxxxx'
        option 'defaultroute' '0'
        option 'mtu' '1404'
        option 'auto' '1'

config 'interface' 'vpn'
        option 'proto' 'pptp'
        option 'server' 'vpn.example.com'
        option 'username' 'xxxxxxx'
        option 'password' 'xxxxxxx'
        option 'defaultroute' '0'
        option 'auto' '1'

config 'interface' 'vpn2'
        option 'proto' 'pptp'
        option 'server' 'vpn2.example.com'
        option 'username' 'xxxxxxx'
        option 'password' 'xxxxxxx'
        option 'defaultroute' '0'
        option 'mtu' '1404'
        option 'auto' '0'

config interface 'wan6'
       option ifname '@wan'
       option proto 'dhcpv6'

config globals 'globals'
        option ula_prefix 'fd5a:9273:657f::/48'

/etc/config/wireless

config wifi-device  radio0
        option type     mac80211
        option channel  11
        option hwmode   11g
        option path     'pci0000:00/0000:00:11.0/0000:02:04.0/usb1/1-1/1-1:1.0'
        #option htmode  HT20
        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 0

config wifi-iface
        option device   radio0
        option ifname   wlanap
        option network  lan
        option mode     ap
        option ssid     "OpenWrt"
        option encryption psk2
        option pairwise CCMP
        option wmm      0
        option wpa_group_rekey 3600
        option key      "xxxxxx"

comment:5 Changed 3 years ago by nbd

please test r42347

comment:6 Changed 3 years ago by cz <chengzhicn@…>

thanks, r42347 fixed this issue.

comment:7 Changed 3 years ago by anonymous

thanks, r42347 fixed this issue.

comment:8 Changed 3 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

comment:9 Changed 3 years ago by cz <chengzhicn@…>

Today I encountered another segfault, kernel log:

[195758.204256] usb 1-1: restart device (4)
[195759.364545] usb 1-1: device restarted successfully.
[195759.365417] ieee80211 phy0: Hardware restart was requested
[234166.999918] netifd[2046]: segfault at 8 ip b7763124 sp bffc7d30 error 6 in libubox.so[b7761000+8000]
[234172.093790] device wlanap left promiscuous mode
[234172.094549] br-lan: port 2(wlanap) entered disabled state
[234172.504148] br-lan: port 1(eth0) entered disabled state
[234172.505184] device eth0 left promiscuous mode
[234172.709525] br-lan: port 1(eth0) entered disabled state

Changed 3 years ago by cz <chengzhicn@…>

comment:10 Changed 3 years ago by cz <chengzhicn@…>

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:11 Changed 3 years ago by nbd

can you reproduce this? what are the conditions that trigger it?

comment:12 Changed 3 years ago by nbd

  • Resolution set to no_response
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.