Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#17696 closed defect (not_a_bug)

Luci comes up as "fail-safe"

Reported by: kralikba@… Owned by:
Priority: high Milestone:
Component: luci Version: Trunk
Keywords: luci failsafe Cc:

Description

In r42165, after a sysupgrade (and also after numerous restarts), luci greets me with a screen saying "fail-safe". Luci packages are of version svn-r10520-1.

This web interface lets me to 1) flash the router w/o password, or 2) restart it w/o password or 3) access regular administrative interface w/ password.

I believe failsafe has otherwise not kicked in. (overlay is mounted, procd is up, services are up). I have even tried reboot -f to no avail.

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by jow

  • Resolution set to not_a_bug
  • Status changed from new to closed

Uninstall luci-mod-failsafe.

comment:2 Changed 3 years ago by kralikba@…

Thanks.
What is then the correct way to tell OpenWRT to bring up luci in this failsafe mode precisely when booting failsafe?

comment:3 Changed 3 years ago by anonymous

I don't know. The failsafe module was contributed by a company which used it for a special recovery firmware image that was booted when the primary one is broken. I don't think it has any support for OpenWrts failsafe mechanism.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.