Modify

Opened 3 years ago

Closed 3 years ago

#17687 closed defect (duplicate)

TL-WR1043ND-v2 - unable to setup tagged and untagged vlan on a single port

Reported by: jpirko Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version: Barrier Breaker 14.07
Keywords: Cc:

Description

I have following switch setup /etc/config/network
config switch

option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan

option device 'switch0'
option vlan '1'
option ports '0t 1 2 3 4'

config switch_vlan

option device 'switch0'
option vlan '10'
option ports '0t 1t 2t 3t 4t'

config switch_vlan

option device 'switch0'
option vlan '2'
option ports '5 6'

So basically what I expect is to have "eth1.1" which will receive all untagged frames and eth1.10 which will receive all frames tagged with vid 10.

But my "swconfig dev switch0 show" displays following:
VLAN 1:

vid: 1
ports: 0t 1t 2t 3t 4t

VLAN 2:

vid: 2
ports: 5 6

VLAN 10:

vid: 10
ports: 0t 1t 2t 3t 4t

As you can see, for some reason vlan1 ports are marked "t" as well. Obviously they do not receive untagged traffic.

Is this a misconfiguration? I believe that this is a bug.
I'm free to test any patches.

I'm running BARRIER BREAKER (14.07-rc3, r42056)

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by anonymous

duplicate of #12181

comment:2 Changed 3 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.