Modify

Opened 3 years ago

Closed 3 years ago

#17667 closed defect (not_a_bug)

iptables not working for pppoe interface

Reported by: cz <chengzhicn@…> Owned by: developers
Priority: highest Milestone:
Component: base system Version: Barrier Breaker 14.07
Keywords: iptables Cc:

Description

I'm running BARRIER BREAKER (14.07, r42258) x86 on vmware, configured with two nic, eth0 for lan and eth1 for wan.
here is my /etc/config/network:

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1'
        option 'proto' 'pppoe'
        option 'username' 'abcdefg'
        option 'password' '123456'

after pppoe-wan is up, I run

iptables -I INPUT -i pppoe-wan -j LOG

to log every packet INPUT to this router
but when I run

wget -O /dev/null http://www.google.com

I got nothing in kernel log

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by nbd

From /etc/sysctl.conf:

net.netfilter.nf_conntrack_skip_filter=1

Change it to 0, run sysctl -p and see if your rule gets called again.

comment:2 Changed 3 years ago by cz <chengzhicn@…>

thanks, that's fixed the issue.

comment:3 Changed 3 years ago by nbd

  • Resolution set to not_a_bug
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.