Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#17665 closed defect (wontfix)

No wifi devices after upgrading to Barrier Breaker (Huawey HW556 version C)

Reported by: arcxyz Owned by: developers
Priority: normal Milestone:
Component: kernel Version: Barrier Breaker 14.07
Keywords: hw556 AR9223 brcm63xx Cc:

Description

After upgrade to rc3 from an older snapshot I don't have wifi devices

The problem is that the ath9k module is not included in the image. After installing kmod-ath9k wifi starts working.

This router have different versions with different wifi chipsets. Some models are shipped with Atheros AR9223 and others with Ralink RT3062F.

The exact model is HG55VDFA Ver.C

Attachments (0)

Change History (5)

comment:1 Changed 3 years ago by Dermot McDonnell

Hi.

I had this problem too.

My HG556a was branded by Vodafone. HW Version: HG55VDFA VER.C - It has the Atheros AR9223 radio.

In menuconfig you must choose (version A/B Atheros).

You must flash the firmware named: openwrt-HG556a_B-squashfs-cfe

Regards,

Dermot.

comment:2 Changed 3 years ago by jogo

  • Resolution set to wontfix
  • Status changed from new to closed

I'm pretty sure you also had to manually install wifi drivers on your older snapshot, unless you built it yourself.

Barrier Breaker does not offer any "HG556" profiles, therefore all images come with the default (= b43) wifi driver, and require different drivers to be installed afterwards in case the wifi is not broadcom.

Fixing this requires rewriting the way images are built. This has been done in trunk, but it is too invasive to backport for Barrier Breaker.

comment:3 Changed 3 years ago by ericwong

I have a HG556a HW.C, from Vodafone and I thought it need Atheros radio driver as the wiki says but it turns out my unit needs the rt28xx wireless driver instead (Enable kmod-rt28xx-pci).

My boot log shows this when the wireless radio is detected and correctly installed
[ 16.676000] ieee80211 phy0: rt2x00lib_request_eeprom_file: Info - Loading EEPROM data from 'rt2x00.eeprom'.
[ 22.912000] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 3572, rev 0221 detected
[ 22.920000] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 0008 detected
[ 22.932000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'

If you have similar problems, try install another radio driver, the WIKI is not always correct.

comment:4 Changed 3 years ago by jlfrechina53

I have a HG556a - version C, i tested all last versions , rc1 rc2 rc3 , trunk ... any version NO detect radio internal (Atheros AR9223 ), installed kmod-ath packages . Its imposible for me, i bursting . :(.

In the folder /etc/config/wireless , the file is empty .

Please . Can help me?

comment:5 Changed 3 years ago by ericwong

Did you actually read my comment? the solution is there.
https://dev.openwrt.org/ticket/17665#comment:3

Btw, does ALL of your USB port works on HG556?
I only have one usb port working (the one for designed for USB 3G at the back) and I can't figure out why.
Even the factory firmware does not detect anything on the two not working USB port.
I know the not working USB port was working not long ago though... it somehow stopped working after I repeatedly re-flash the ROM the router with usb sound card connected.

See details at
https://dev.openwrt.org/ticket/15012#comment:7

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.