Modify

Opened 3 years ago

Closed 3 years ago

#17661 closed defect (no_response)

x86 14.07-rc3 boot fail, reboot looping

Reported by: phil.lxnet@… Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: base system Version: Barrier Breaker 14.07
Keywords: grub boot via eden c3 Cc:

Description

My EPIA V VIA C3 (E-Series) 533A system fails to boot with just:-

Verify DMI Pool Data....
GRUB loading ...

then the system immediately reboots

I have tried with identical results the combined-ext4 images for all of the following:-
x86 generic 14.07-rc3
snapshot 23/08/2014
alix2
net5501

This same board previously worked very well with x86 generic 12.09.

I am prepared to try and help out with this and have built openwrt previously but am about a year out of date with build procedures so pretty rusty.

Let me know what I can try to diagnose this.
I have ensured a serial port is available, and have tried all obvious chs, lba, non udma etc
install is on a 64MB CHH (old solid state hdd, tried 2 of them) via:-

sudo dd if=openwrt-x86-generic-combined-ext4.img of=/dev/sdb

Attachments (0)

Change History (8)

comment:1 Changed 3 years ago by phil.lxnet@…

I have confirmed the same behaviour on another VIA C3 (E-Series) but this time a 400 MHz model, again a board that has previously been fine with 12.09

comment:2 Changed 3 years ago by anonymous

confirmed - reboot looping with 14.07 on Igel via c7

comment:3 Changed 3 years ago by phil.lxnet@…

I have just tried 14.07 release as well and no change in behaviour since my original post.

comment:4 Changed 3 years ago by phil.lxnet@…

Having now videoed the screen during boot and put the exact same 64MB drive into a P3 coppermine machine and have it boot successfully I can offer a little more information.

Normal boot on P3 coppermine:-
GRUB loading.....
Welcome to GRUB! <- this line flashes up inverse momentarily
Then we have the Grub boot menu screen

With VIA C3 bootup there is no appearance of "Welcome to GRUB!" and an almost instant reboot after the "GRUB loading....." message.

This I think places the blame on GRUB.
I understand that the VIA C3 (not C3-2) is lacking the machine code instruction of cmov (from 686 class) but I have run "grep -r cmov *" on the grub-2.02~beta2 source and don't see any except in alpha architecture; as I understood that there was still some machine code in Grub.

However the cmov suspicion may be a red herring as VIA C7 (also reported in this ticket) is apparently akin to the later C3-2 or Nehemiah core which does have cmov and apparently does qualify as full 686 (but lacks the 3dNow instruction set of the early C3).

Just trying to narrow down where the problem is as I have 2 of these machines and would really like to put them back to use with openwrt which they previously ran a treat but I need 14.07 on them now.

Prior to considering Grub as the issue I have tried builds with each of the following (using trunk r42757):-
Processor family ---> CyrixIII/VIA-C3
unselecting x86 PAT
turning off VM86 support
tried 486 & Generic x86 support turned off
CPU idle PM support (removed option)
Support for old Pentium 5 / WinChip machine checks

Does anyone have any suggestions as to how I might proceed.
I suspect some compiler setting that is building Grub in an incompatible way for these CPU's.

comment:5 Changed 3 years ago by phil.lxnet@…

Emulated a low x86 cpu (486) and booted image via:-

qemu-system-i386 -cpu 486 -hda openwrt-x86-generic-combined-squashfs.img

This boots without issue and its "cat /proc/cpuinfo" confirms 486 DX/4

Also tried "-cpu pentium" which also booted fine (cpuinfo shows Pentium MMX)

So I am assuming this rules out the compiler setting theory.

comment:6 Changed 3 years ago by anonymous

Same here :-(
Boots up GRUB and then immediately reboots

VIA Eden C3 533MHz Processor (Samuel 2)

i also tried Bleeding Edge (download and self-compiled)

what can i do next?

comment:7 Changed 3 years ago by nbd

please try current trunk

comment:8 Changed 3 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.