Modify

Opened 3 years ago

Last modified 4 weeks ago

#17659 new defect

Asus rt-n56u 5ghz radio is not usable

Reported by: moonman Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Barrier Breaker 14.07
Keywords: Asus n56 5ghz radio Cc:

Description

Hello,

I don't know if it os known yet, but n56 does not want tp start 5ghz radio in AP mode. It always goes not client mode (i haven't tested of it works in client mode though). Here is the log:

Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): Configuration file: /var/run/hostapd-phy1.conf Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): wlan1: interface state UNINITIALIZED->COUNTRY_UPDATE Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): ACS: Automatic channel selection started, this may take a bit Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): wlan1: interface state COUNTRY_UPDATE->ACS Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): wlan1: ACS-STARTED Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): ACS: Unable to collect survey data Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): ACS: All study options have failed Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): Interface initialization failed Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): wlan1: interface state ACS->DISABLED Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): wlan1: AP-DISABLED Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): ACS: Possibly channel configuration is invalid, please report this along with your config file. Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): cat: can't open '/var/run/wifi-phy1.pid': No such file or directory Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): Command failed: Invalid argument Wed Aug 20 11:40:42 2014 kern.info kernel: [ 49.850000] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready

Tested with bb rc3

Attachments (0)

Change History (23)

comment:1 Changed 3 years ago by lynxis

Can you post your /etc/config/wireless please. Did you set your wireless regdomain?

comment:2 Changed 3 years ago by moonman

Sorry about the log being squiched into one line. I used my phone to post the msg while away from home.

Here's the same log:

Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): Configuration file: /var/run/hostapd-phy1.conf
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): wlan1: interface state UNINITIALIZED->COUNTRY_UPDATE
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): ACS: Automatic channel selection started, this may take a bit
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): wlan1: interface state COUNTRY_UPDATE->ACS
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): wlan1: ACS-STARTED 
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): ACS: Unable to collect survey data
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): ACS: All study options have failed
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): Interface initialization failed
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): wlan1: interface state ACS->DISABLED
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): wlan1: AP-DISABLED 
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): ACS: Possibly channel configuration is invalid, please report this along with your config file.
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): cat: can't open '/var/run/wifi-phy1.pid': No such file or directory
Wed Aug 20 11:40:42 2014 daemon.notice netifd: radio1 (863): Command failed: Invalid argument
Wed Aug 20 11:40:42 2014 kern.info kernel: [   49.850000] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready

Here's /etc/config/wireless :

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:01.0/0000:01:00.0'
        option txpower '20'
        option htmode 'HT40'
        option noscan '1'
        option country 'CA'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Ira'
        option encryption 'psk2+ccmp'
        option key 'my-key'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11na'
        option path '10180000.wmac'
        option txpower '17'
        option country 'CA'
        option channel '36'
        option htmode 'HT40'
        option noscan '1'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2+ccmp'
        option key 'my-key'
        option ssid 'Ira-5GHz'

The strange thing is: I fiddled for hours before using LuCi and modified /etc/config/wireless by hand and nothing would bring the interface up. It would error out and go into Client mode. After leaving it for 3 days because I was away, I came back to it today and noticed and extra "config wifi-iface" for radio1 under /etc/config/wireless and removed it. It works now, however something is still off since it does not work for anyone out of the box, or after using LuCi to set it up with the above messages in logs.

Last edited 3 years ago by moonman (previous) (diff)

comment:3 follow-ups: Changed 3 years ago by alex.henrie

I struggled with this too and finally came up with a 3-part workaround:

  1. Set the country code to a specific country on BOTH the 5 GHz radio AND the 2.4 GHz radio.
  2. Go to System > Startup, scroll down to Local Startup, add the line "sleep 2 && /etc/init.d/network restart" before the line "exit 0", and click Submit.
  3. Click System > Reboot > Perform reboot.

Please let me know whether or not this workaround helps you. I've already posted it to http://wiki.openwrt.org/toh/asus/rt-n56u#ghz.radio

comment:4 in reply to: ↑ 3 Changed 3 years ago by deesejohn

Replying to alex.henrie:

I struggled with this too and finally came up with a 3-part workaround:

  1. Set the country code to a specific country on BOTH the 5 GHz radio AND the 2.4 GHz radio.
  2. Go to System > Startup, scroll down to Local Startup, add the line "sleep 2 && /etc/init.d/network restart" before the line "exit 0", and click Submit.
  3. Click System > Reboot > Perform reboot.

Please let me know whether or not this workaround helps you. I've already posted it to http://wiki.openwrt.org/toh/asus/rt-n56u#ghz.radio

No luck here, tried your solution but still getting a really weird problem.
My 2.4ghz radio works if I enable my 5ghz radio in luci.
If I disable the 5ghz radio in luci then my 2.4 radio goes out.

comment:5 in reply to: ↑ 3 Changed 3 years ago by deesejohn

...

Last edited 3 years ago by deesejohn (previous) (diff)

comment:6 in reply to: ↑ 3 Changed 3 years ago by deesejohn

Posted my comment three times, wonderful..

Last edited 3 years ago by deesejohn (previous) (diff)

comment:7 follow-up: Changed 3 years ago by anonymous

It sounds like your 5 GHz radio is working though, so the problem you're having is a different bug.

If you are indeed having trouble turning the 5 GHz radio on even if the 2.4 GHz radio is also enabled, try increasing "sleep 2" to "sleep 3" or something crazy like "sleep 60". Let me know what the smallest number is that works for you.

comment:8 follow-up: Changed 3 years ago by alex.henrie

And of course I wasn't signed in for that comment. I didn't even know it was possible to leave comments here anonymously...

comment:9 in reply to: ↑ 8 Changed 3 years ago by deesejohn

Replying to alex.henrie:

And of course I wasn't signed in for that comment. I didn't even know it was possible to leave comments here anonymously...

I figured out my problem! All working now.
It was a bug coming from Padavan's firmware.
The unit wasn't factory reset before flashing to openwrt.
Using the "sleep 2 && /etc/init.d/network restart" before startup it is all working now!

comment:10 Changed 3 years ago by anonymous

"If I disable the 5ghz radio in luci then my 2.4 radio goes out."

only way (so far) able to get stable 2.4 ghz is set my 5ghz(radio1) into "monitor" mode.
Of course then I dont have any 5ghz.

comment:11 Changed 3 years ago by moonman

Everything works as expected in latest Chaos Calmer trunk. Can be closed.

comment:12 Changed 3 years ago by max_b

I'm wondering if anyone else has had serious range issues with this device? I can't seem to get almost any signal in practically the next room over. If I'm near the radio, I get great speeds, but as soon as I move a room or two away they drop significantly, to the point of being unable to connect....

To be fair, it seems like I have these issues no matter what operating system is running on it.

comment:13 Changed 3 years ago by moonman

What band? If tGHz i found that setting region to Norway will allow higher tx power. Otherwise I didn't notice any signal degradation

comment:14 Changed 3 years ago by max_b

It's so bad that I keep thinking that I actually just have a defective unit, except that I RMA'd the first unit I got and ASUS support is such a PITA that I'm not sure it's worth it.

Both 2.4 and 5 are both pretty bad.

This is what my wireless config looks like:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:01.0/0000:01:00.0'
        option htmode 'HT20'
        option txpower '30'
        option country 'US'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Wireless AP'
        option encryption 'psk2'
        option key 'password123'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '10180000.wmac'
        option country 'US'
        option hwmode '11na'
        option log_level '0'
        option channel '36'
        option noscan '1'
        option htmode 'HT40'
        option txpower '17'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'Wireless AP 5Ghz'
        option encryption 'psk2'
        option key 'password123'

comment:15 Changed 3 years ago by anonymous

Switch to snapshot of Chaos Calmer first (read wiki, make sure you tick Keep Settings). I havent really tested stable and chances are with newer kernel the driver has some bugs fixed. Change your region to Norway. See if that helps. If you are using Luci, make sure to install it (opkg install luci) as snapshot builds don't come with it

comment:16 follow-up: Changed 3 years ago by ssieb

I'm using Chaos Calmer r46386. I read that this issue was fixed, so I spent a long time trying to figure out why the 5GHz radio wasn't working. I eventually came back to this ticket and tried setting the Country code on both interfaces. After rebooting, it worked. I didn't need to add the delayed network restart.

comment:17 in reply to: ↑ 16 Changed 3 years ago by anonymous

Replying to ssieb:

I'm using Chaos Calmer r46386. I read that this issue was fixed, so I spent a long time trying to figure out why the 5GHz radio wasn't working. I eventually came back to this ticket and tried setting the Country code on both interfaces. After rebooting, it worked. I didn't need to add the delayed network restart.

What country code are you using?
Mine isn't working with USA.

comment:18 Changed 3 years ago by anonymous

I'm pretty sure I was using USA. Make sure you set it on both radios. Then you need to at least restart the networking, but better to just reboot it.

comment:19 Changed 2 years ago by alex.henrie

After upgrading to Chaos Calmer, I still needed the startup script, which makes me think that this bug was at least partly a configuration issue.

Today I used LuCI's "Reset to defaults" button and after that I still had to set the country code on the 5 GHz radio, but it doesn't need the startup script anymore. Plus, the 2.4 GHz radio can be "00 - World" now without affecting the operation of the 5 GHz radio.

comment:20 Changed 2 years ago by molgrum

I have this problem too.

rt2800pci 0000:01:00.0: Direct firmware load for rt2x00pci_1_0.eeprom failed with error -2

Are there any solutions or is this being worked on at all? Using CC 15.05.
I gladly accept solutions on #openwrt @ Freenode but will check here from time to time!

comment:21 Changed 2 years ago by alex.henrie

By the way, when the channel was set to "auto", the 5 GHz wireless would spontaneously turn off after a day or so. In the end I had to set the channel to something specific for the 5 GHz network to continue working for prolonged periods of time.

The problems with automatic channel selection on this device are probably a separate bug, but they're worth mentioning here for the people who have been having trouble getting the 5 GHz to work at all.

comment:22 in reply to: ↑ 7 Changed 19 months ago by anonymous

Replying to anonymous:

It sounds like your 5 GHz radio is working though, so the problem you're having is a different bug.

If you are indeed having trouble turning the 5 GHz radio on even if the 2.4 GHz radio is also enabled, try increasing "sleep 2" to "sleep 3" or something crazy like "sleep 60". Let me know what the smallest number is that works for you.

Alex,

I tried the workaround and the smallest number it worked for me was 10, just to keep the community informed about this.

@miguelraulb

comment:23 Changed 4 weeks ago by targa

I do have 2 RT-N56U Units, so far I never used 5GHz, so this didn't appear to me. Now that my neighbors decided to really fill up all 2.4GHz channels I wanted to try 5G, with no luck. It came up eventually, but now it doesn't. Tried all of the above hints. (LEDE 17.01.4 r3560-79f57e422d)

I was reading on Padavan release notes and he states that he did some backporting and in the forums it says that 5GHz problems (which are still in ASUS fw and WERE in Padavan FW) are fixed now.

Release notes say: 3.X.3.6-069:
https://rt-n56u.soulblader.com/files/README


...

  • Fixed broken 5GHz TxPower adjust w/o clients connected (backport from 2.6.x.x driver).

...

Latest FW bins are stored here:
https://bitbucket.org/padavan/rt-n56u/src/dff9a3421d1da8f6678829a05fb7131997b51e67/trunk/vendors/Ralink/RT3883/?at=master

I tried to replace the firmware binaries, but obviously it requires a Lede Image build which is a bit time consuming if you don't do that regularly.

Last edited 4 weeks ago by targa (previous) (diff)

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.