Modify

Opened 3 years ago

Closed 3 years ago

#17658 closed defect (fixed)

odhcpd will honor request for different IP, even if static lease already exists

Reported by: pdffs Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Barrier Breaker 14.07
Keywords: odhcpd Cc:

Description

If a client has a static lease configured, but sends a DHCPREQUEST for a different IP address, odhcpd will return the IP requested by the client rather than the static IP.

Why would a client do this? I have no idea generally (tracking down a separate bug in NetworkManager), but a potentially legitimate scenario where the client is doing the right thing might be if the static lease is added while the client already has a lease for a different IP address - it will never get the static IP, because odhcpd will honour the DHCPREQUEST in preference to the configured static lease. This is not the expected behaviour.

Attachments (0)

Change History (2)

comment:1 in reply to: ↑ description Changed 3 years ago by pdffs

Replying to pdffs:

If a client has a static lease configured, but sends a DHCPREQUEST for a different IP address, odhcpd will return the IP requested by the client rather than the static IP.

Actually, it looks like the first time a client sends a DHCPREQUEST after odhcpd has been started, it will do the right thing and return the fixed lease, but any subsequent requests will return an IP out of the pool.

Last edited 3 years ago by pdffs (previous) (diff)

comment:2 Changed 3 years ago by cyrus

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for reporting. It seems odhcpd killed static lease entries when the client did a RELEASE or similar.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.