Modify

Opened 3 years ago

Closed 2 years ago

#17654 closed defect (wontfix)

oldpackages / rrdtool fails to compile - freetype missing?

Reported by: bittorf@… Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

bastian@server1:~/openwrt$ make package/rrdtool/compile BUILDLOG=1
 make[1] package/rrdtool/compile
 make[2] -C package/libs/toolchain compile
 make[2] -C package/libs/libtool compile
 make[2] -C feeds/oldpackages/libs/cgilib compile
 make[2] -C feeds/oldpackages/libs/libart compile
 make[2] -C feeds/oldpackages/lang/python host-compile
 make[2] -C feeds/packages/utils/bzip2 compile
 make[2] -C feeds/packages/libs/expat compile
 make[2] -C feeds/packages/libs/gdbm compile
 make[2] -C feeds/packages/libs/libffi compile
 make[2] -C package/libs/libreadline compile
 make[2] -C package/libs/ncurses compile
 make[2] -C feeds/packages/libs/sqlite3 compile
 make[2] -C package/libs/ocf-crypto-headers compile
 make[2] -C package/libs/zlib compile
 make[2] -C package/libs/openssl compile
 make[2] -C feeds/oldpackages/lang/python compile
 make[2] -C feeds/packages/libs/freetype compile
 make[2] -C feeds/packages/libs/libpng compile
 make[2] -C feeds/oldpackages/utils/rrdtool compile
make -r package/rrdtool/compile: build failed. Please re-run make with V=s to see what's going on


bastian@server1:~/openwrt$ tail -n40 logs/package/feeds/oldpackages/rrdtool/compile.txt 
checking for zlibVersion in -lz... yes
checking zlib.h usability... yes
checking zlib.h presence... yes
checking for zlib.h... yes
checking for png_access_version_number in -lpng... yes
checking png.h usability... yes
checking png.h presence... yes
checking for png.h... yes
checking for FT_Init_FreeType in -lfreetype... yes
checking ft2build.h usability... no
checking ft2build.h presence... no
checking for ft2build.h... no
checking for pkg-config... (cached) pkg-config
checking for FT_Init_FreeType in -lfreetype... yes
checking ft2build.h usability... no
checking ft2build.h presence... no
checking for ft2build.h... no
configure: WARNING:
----------------------------------------------------------------------------
* I could not find a working copy of freetype2. Check config.log for hints on why
  this is the case. Maybe you need to set LDFLAGS and CPPFLAGS appropriately
  so that compiler and the linker can find libfreetype and its header files. If
  you have not installed freetype2, you can get it either from its original home on

     http://prdownloads.sourceforge.net/freetype/

  You can find also find an archive copy on

     http://oss.oetiker.ch/rrdtool/pub/libs

  The last tested version of freetype2 is 2.1.10.

       LIBS=-lpng -lz -lm  -lart_lgpl_2  -lfreetype 
   LDFLAGS=-L/home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/usr/lib -L/home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/lib -L/home/bastian/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/usr/lib -L/home/bastian/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/lib  -L/home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/usr/lib    
  CPPFLAGS=-I/home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/usr/include -I/home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/include -I/home/bastian/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/usr/include -I/home/bastian/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/include  -I/home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/usr/include/libart-2.0  -I/usr/include/freetype2 -I/home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/usr/include 

----------------------------------------------------------------------------
                
configure: error: Please fix the library issues listed above and try again.
make[3]: *** [/home/bastian/openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/rrdtool-1.2.30/.configured_nn] Error 1

this is a fresh checkout.
i followed https://forum.openwrt.org/viewtopic.php?id=52219 but it does not help here.

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by bittorf@…

the root cause seems to be a missing 'ft2build.sh':

configure:15428: checking for FT_Init_FreeType in -lfreetype
configure:15453: mips-openwrt-linux-uclibc-gcc -o conftest -Os -pipe -mno-branch-likely -mips32r2 -mtune=34kc -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float -mips16 -minterlink-mips16  -fno-strict-aliasing -Wall -std=gnu99 -pedantic -Wshadow -Wpointer-arith -Wcast-align -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline -W  -fPIC -DPIC -I/home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/usr/include -I/home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/include -I/home/bastian/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/usr/include -I/home/bastian/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/include  -I/home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/usr/include/libart-2.0  -L/home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/usr/lib -L/home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/lib -L/home/bastian/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/usr/lib -L/home/bastian/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/lib  -L/home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/usr/lib   conftest.c -lfreetype  -lpng -lz -lm  -lart_lgpl_2  >&5
configure:15453: $? = 0
configure:15462: result: yes
configure:15466: checking ft2build.h usability
configure:15466: mips-openwrt-linux-uclibc-gcc -c -Os -pipe -mno-branch-likely -mips32r2 -mtune=34kc -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float -mips16 -minterlink-mips16  -fno-strict-aliasing -Wall -std=gnu99 -pedantic -Wshadow -Wpointer-arith -Wcast-align -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline -W  -fPIC -DPIC -I/home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/usr/include -I/home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/include -I/home/bastian/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/usr/include -I/home/bastian/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/include  -I/home/bastian/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/usr/include/libart-2.0  conftest.c >&5
conftest.c:103:22: fatal error: ft2build.h: No such file or directory
 #include <ft2build.h>
                      ^
compilation terminated.
configure:15466: $? = 1

comment:2 Changed 3 years ago by bittorf@…

it seems to be there:

bastian@server1:~/openwrt$ find . -name ft2build.h
./build_dir/target-mips_34kc_uClibc-0.9.33.2/freetype-2.5.3/include/ft2build.h
./build_dir/target-mips_34kc_uClibc-0.9.33.2/freetype-2.5.3/ipkg-install/usr/include/freetype2/ft2build.h
./build_dir/target-mips_34kc_uClibc-0.9.33.2/freetype-2.5.3/devel/ft2build.h
./staging_dir/target-mips_34kc_uClibc-0.9.33.2/usr/include/freetype2/ft2build.h

comment:3 Changed 3 years ago by moguai_xl@…

Hi,

I had the same problem. I wrote script/patch which solved my problem.

$ cat rrdtool-1.2.30-freetype2.sh
#!/bin/bash

cat << "EOF" > rrdtool-1.2.30-freetype2.patch
--- feeds/oldpackages/utils/rrdtool/Makefile.orig	2014-08-28 16:58:12.311008846 +0200
+++ feeds/oldpackages/utils/rrdtool/Makefile	2014-08-28 16:53:36.907016983 +0200
@@ -75,6 +75,7 @@
 	--disable-ruby \
 	--without-x \
 	--with-rrd-default-font="/usr/share/rrdtool/fonts/DejaVuSansMono-Roman.ttf" \
+        CPPFLAGS="-I $(STAGING_DIR)/usr/include/freetype2" \
 
 CONFIGURE_VARS += \
 	rd_cv_ieee_works=yes \
EOF

cp feeds/oldpackages/utils/rrdtool/Makefile feeds/oldpackages/utils/rrdtool/Makefile.orig
patch -p0 < rrdtool-1.2.30-freetype2.patch

Script should be run from 'openwrt' directory.

Regards,
Piotr

comment:4 Changed 2 years ago by nbd

  • Resolution set to wontfix
  • Status changed from new to closed

oldpackages is unmaintained.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.