Modify

Opened 3 years ago

Closed 3 years ago

#17588 closed defect (fixed)

Luci don't understand proto l2tpv2

Reported by: dgerasimov@… Owned by:
Priority: highest Milestone: Barrier Breaker 14.07
Component: luci Version: Trunk
Keywords: Cc:

Description

By this guide
http://wiki.openwrt.org/doc/uci/network#protocol.l2tpv2.ppp.over.l2tp.pseudowire.tunnel

l2tp is l2tpv3tun package (/lib/netifd/proto/l2tp.sh)
l2tpv2 is xl2tp package (/lib/netifd/proto/l2tpv2.sh)

But when selecting L2TP, in protocol field of interface configuration, it asks to install for package xl2tpd, despite on it has alredy installed. It happens because Luci checks /lib/netifd/proto/l2tp.sh, old name of netifd script, today it is renamed for package xl2tpd to l2tpv2.sh

Needs to correct same files to fix it:
First of all
/usr/lib/lua/luci/model/network/proto_ppp.lua
line 23
for _, p in ipairs({"ppp", "pptp", "pppoe", "pppoa", "3g", "l2tp", "l2tpv2"}) do
Insert above line 39
elseif p == "l2tpv2" then

return luci.i18n.translate("L2TPv2")

insert above line 58
elseif p == "l2tp" then

return "l2tpv3tun"

elseif p == "l2tpv2" then

return "xl2tpd"

insert above line 78
elseif p == "l2tpv2" then

return nixio.fs.access("/lib/netifd/proto/l2tpv2.sh")

and next :
cd /usr/lib/lua/luci/model/cbi/admin_network/
cp proto_l2tp.lua proto_l2tpv2.lua

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by cyrus

  • Resolution set to fixed
  • Status changed from new to closed

l2tpv2 was renamed to l2tp again, l2tpv3 seems broken anyway.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.