Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#17569 closed defect (duplicate)

WNDR3800 (/3700) wan speed issue when downloading and uploading

Reported by: robnitro@… Owned by: developers
Priority: normal Milestone:
Component: base system Version: Barrier Breaker 14.07
Keywords: wan speed, wndr 3800 3700 Cc:

Description

WNDR3800, tried trunk, AA, and arokh,hnyman builds.
Fiber 75/75 which tests to 80/80.
When uploading, the download goes to below 1 megaBYte/s (8mbit)
I've tried setting qos off, qos upload only, qos upload to some small speed... it always does it. Cpu load is not maxed out according to htop.

Tried ethtool, setting eth1 to 100 full duplex. It ends up being 8mbit download and regular upload ???!?!
100 half duplex doesn't fix the issue either, and 1000 half duplex just fails to make a wan link.

Stock netgear firmware doesn't do it, and neither does my buffalo g300nh with gargoyle AA or trunk. The buffalo is cpu limited and goes down to about 5 MB/s (40mbit) when uploading at close to full speed.

Really stinks, I bought this router to overcome the cpu limitation brought by the buffalo, but it cannot.

Attachments (0)

Change History (25)

comment:1 Changed 3 years ago by anonymous

It seems like a driver issue, as even setting the upload to HALF the max (35 mbit) still throttles the download to sub 8mbit speed. Pings are consistently below 10 ms to google.com and cpu load much lower...

comment:2 follow-up: Changed 3 years ago by anonymous

tried mss fix off? also please write again, cant understand 90% of what you wrote.

comment:3 in reply to: ↑ 2 Changed 3 years ago by robnitro@…

Replying to anonymous:
How do I set mssfix? I googled it and just see it's some iptables rule.

So I will reiterate.
75Mbit/75Mbit fiber NO PPPOE, just ethernet. Testing w qos off, does 80/80 max.

Run a download, works fine- getting at least 70 mbit with qos, or more without.

BUT when I upload at 35mbit,50mbit, or full upload speed (~75mbit) the download crawls down below 8mbit.
CPU is not maxed out according to htop in SSH. Ping google.com -t is consistently 10 ms or so, not a latency issue.

This happens whether qos is on or off. It happens on AA, trunk, or custom builds, but NOT stock netgear firmware. I tried manually setting the WAN port to 100 full duplex, but that was even worse.

Also, my buffalo g300nh with qos on OR off, does not have this problem with AA, trunk, or gargoyle (based on AA). It has a much weaker CPU, and is maxing out cpu! You would think that would be the one to slow upload to a crawl!

comment:4 Changed 3 years ago by anonymous

Is this wired or wifi or both? I guess wired, right. Seems theres something wrong with the drivers, and it's an older issue but never was looked into :( It's mtu_fix to 0 in firewall config file under wan.

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '0'

comment:5 Changed 3 years ago by robnitro@…

So no idea when they plan to fix the drivers? I figured they would be able to fix it by seeing the netgear source code?

Yes, tested doing wired.

I wonder if I make a VLAN port, ex: eth0.2 and use it for wan, not use eth1... and run it as "normal"?
Perhaps that would eliminate the issue, or is it all the whole chipset.

comment:6 Changed 3 years ago by anonymous

Opened the source here: http://www.downloads.netgear.com/files/GPL/WNDR3800-V1.0.0.48_gpl_src.tar.bz2.zip
And wow, it runs openwrt kamikaze stock???

I wonder if their driver can be ported over?

comment:7 Changed 3 years ago by anonymous

Ok, so I tried WAN on vlan port, eth0.2
The same issue happened.

ARGH! Any clue on whether they will update/fix this?

comment:8 Changed 3 years ago by anonymous

What about the mtu_fix ... did you try turning it off??

comment:9 Changed 3 years ago by anonymous

Yes, no change at all, sorry I forgot to update that!

I even tried another time, specifying mtu_fix on eth0 LAN too.

The irony is that my g300nh slower router uses the same ethernet chipset rtl8366.

It makes me wonder!

comment:10 Changed 3 years ago by anonymous

I cant really test it because my Internet is really slow so I never noticed this behavior mostly :( I just have 12/1. A friend has 50/10 and he never noticed something too. Mostly it just happens in really high band-withes like 20+/20+ at full duplex. Dont we have a dev here whos into maintaining the drivers and can say something about it? My knowledge about driver c and assembler is really limited sadly :/

comment:11 Changed 3 years ago by anonymous

One thing I forgot to mention, I have a buffalo-wzr-hp-g300nh too and I noticed something what could be a bug too. It uses way too much CPU % in my opinion just for normal routing. If I download with 12mbit the buffalo-wzr-hp-g300nh has cpu usage of about 40% just for the routing. I have nothing special on it, no qos, just blank image which can connect with pppoe. I guess the opensource drivers are really bad sadly in OpenWRT. Someone should look into them more closely.

comment:12 Changed 3 years ago by robnitro@…

I think it is because they are not using hardware NAT.
But no problem with that, even below 100% cpu is where I see horrible throttling like your friend does!
The g300nh which I have can do around 60-70 mbit with qos on! I was amazed at that, but yeah the web interface while doing that is slow as crap.

comment:13 Changed 3 years ago by anonymous

robnitro, have you tried Backfire builds? If it works on that, keep going forward until you find when the problematic emerged. That will make it easier to isolate when the regression was introduced.

comment:14 Changed 3 years ago by anonymous

Uhm.. i am compiling my own firmware (BB) for my wndr3700v1 and wndr3800 and did not experiment any problems on it.
Testing with iperf WAN to LAN and static ip settings on wndr3700v1 i had 265 Mbit/s with NAT and 380 Mbit/s with usual routing without MASQ..

comment:15 Changed 3 years ago by robnitro@…

There is no backfire for wndr3800!

It even happened the opposite direction. I was uploading a file to a friend who is 8 ms away though my ftp on my HTPC. Doing 74 mbits or so.. he has a 150 mbit line.

I ran a speed test, and during the download portion... he was receiving at 4 mbit... (500 KB/s) CPU never was maxed out in htop... it was below 70%

The driver is bugged in another ticket I found where the interface is fine one way, but doing 2 way it bugs out:
/ticket/13072.html

comment:16 Changed 3 years ago by robnitro@…

Borrowed a friend's buffalo AG300h, which is similar in terms of cpu speed, running AAr42171.

Same issue happened. So, I tried a few things and only one thing resolved the slow download while uploading (or vice versa).

Used ethtool to set eth1 to 100 full duplex autoneg off.. and it worked fine, like my older router works!

So, definately something wrong with the ethernet gigabit settings/buffers/etc.

Oh and the netgear wndr3800, ethtool eth1 set to 100 full duplex, it runs horribly on anything. Max 4 mbit either way in speed test (despite being on the same 75/75 mbit fiber!

comment:17 Changed 3 years ago by anonymous

I've done testing on this on my side:

http server -- wndr3800 50/10 <--Internet--> 12/1 wndr3800 -- pc

Initiated a download from right side pc to the http server, results in 10mbit (correct).

Initiated a download from left side wndr3800 via (wget http://speedtest.netcologne.de/test_1gb.bin -O /dev/null) on wndr itself simultaneous, results in 50mbit (correct).

50/10 working, still CPU jumps between 5 and 99% on the left side wndr, dont know why, goes like 5-20% for 10 seconds then jumps suddenly to 99% for a while and goes back (bug?).

Now comes the interesting part. Not doing the 2nd parallel download on the left side wndr itself, but on the http server (routing from switch to wan), and now it breaks. Download on the right side breaks to about 300kbit.

However, the test file I initiated from right side also was on http server, but that works.

comment:18 Changed 3 years ago by anonymous

Stumbled onto this, which the patch at the comments below seems to work... but I'm testing double natted right now with another router in production.

/ticket/13072.html

comment:19 Changed 3 years ago by anonymous

Dont apply this "patch" the guy posted in 13072. It toally broke my 3 3800 router, that wan port is resetting every few minutes:

Thu Aug 28 16:25:11 2014 daemon.notice odhcp6c[1383]: carrier => 0 event on eth1
Thu Aug 28 16:25:11 2014 daemon.notice odhcp6c[1383]: (re)starting transaction on eth1
Thu Aug 28 16:25:11 2014 daemon.notice netifd: Network device 'eth1' link is down
Thu Aug 28 16:25:11 2014 daemon.notice netifd: Network alias 'eth1' link is down
Thu Aug 28 16:25:11 2014 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Thu Aug 28 16:25:11 2014 daemon.notice odhcp6c[1383]: Starting SOLICIT transaction (timeout 4294967295s, max rc 0)
Thu Aug 28 16:25:11 2014 daemon.notice netifd: Interface 'wan' has link connectivity loss
Thu Aug 28 16:25:11 2014 daemon.notice netifd: Network device 'eth1' link is up
Thu Aug 28 16:25:11 2014 daemon.notice netifd: Network alias 'eth1' link is up
Thu Aug 28 16:25:11 2014 daemon.notice netifd: Interface 'wan6' has link connectivity
Thu Aug 28 16:25:11 2014 daemon.notice netifd: Interface 'wan6' is setting up now
Thu Aug 28 16:25:11 2014 daemon.notice netifd: Interface 'wan' has link connectivity
Thu Aug 28 16:25:19 2014 daemon.notice netifd: Network device 'tun1' link is down
Thu Aug 28 16:25:19 2014 daemon.notice netifd: Interface 'vpn2' has link connectivity loss
Thu Aug 28 16:25:22 2014 daemon.notice netifd: Network device 'eth1' link is down
Thu Aug 28 16:25:22 2014 daemon.notice netifd: Network alias 'eth1' link is down
Thu Aug 28 16:25:22 2014 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Thu Aug 28 16:25:22 2014 daemon.notice netifd: Interface 'wan' has link connectivity loss
Thu Aug 28 16:25:22 2014 daemon.notice netifd: Network device 'eth1' link is up
Thu Aug 28 16:25:22 2014 daemon.notice netifd: Network alias 'eth1' link is up
Thu Aug 28 16:25:22 2014 daemon.notice netifd: Interface 'wan6' has link connectivity
Thu Aug 28 16:25:22 2014 daemon.notice netifd: Interface 'wan' has link connectivity
Thu Aug 28 16:25:38 2014 daemon.notice netifd: Network device 'eth1' link is down
Thu Aug 28 16:25:38 2014 daemon.notice netifd: Network alias 'eth1' link is down
Thu Aug 28 16:25:38 2014 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Thu Aug 28 16:25:38 2014 daemon.notice netifd: Interface 'wan' has link connectivity loss

and

Thu Aug 28 15:45:02 2014 daemon.notice netifd: Interface 'wan6' is enabled
Thu Aug 28 15:45:02 2014 daemon.notice netifd: Network alias 'eth1' link is up
Thu Aug 28 15:45:02 2014 daemon.notice netifd: Interface 'wan6' has link connectivity
Thu Aug 28 15:45:02 2014 daemon.notice netifd: Interface 'wan6' is setting up now
Thu Aug 28 15:45:02 2014 daemon.notice netifd: Interface 'wan' is now up
Thu Aug 28 15:45:02 2014 daemon.warn odhcpd[1120]: DHCPV6 SOLICIT IA_NA from ...
Thu Aug 28 15:45:19 2014 daemon.notice netifd: Network device 'tun1' link is up
Thu Aug 28 15:45:19 2014 daemon.notice netifd: Interface 'vpn2' has link connectivity
Thu Aug 28 15:45:48 2014 daemon.notice netifd: Network device 'tun0' link is down
Thu Aug 28 15:45:48 2014 daemon.notice netifd: Interface 'vpn1' has link connectivity loss
Thu Aug 28 15:45:52 2014 daemon.notice netifd: Network device 'eth1' link is down
Thu Aug 28 15:45:52 2014 daemon.notice netifd: Network alias 'eth1' link is down
Thu Aug 28 15:45:52 2014 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Thu Aug 28 15:45:52 2014 daemon.notice netifd: Interface 'wan' has link connectivity loss
Thu Aug 28 15:45:52 2014 daemon.notice netifd: Interface 'wan6' is now down
Thu Aug 28 15:45:52 2014 daemon.notice netifd: Interface 'wan6' is disabled
Thu Aug 28 15:45:52 2014 daemon.notice netifd: wan (19506): Received SIGTERM
Thu Aug 28 15:45:53 2014 daemon.notice netifd: Network device 'eth1' link is up
Thu Aug 28 15:45:53 2014 daemon.notice netifd: Interface 'wan' has link connectivity
Thu Aug 28 15:45:53 2014 daemon.notice netifd: Interface 'wan' is setting up now
Thu Aug 28 15:45:53 2014 daemon.notice netifd: wan (20045): udhcpc (v1.22.1) started
Thu Aug 28 15:45:53 2014 daemon.notice netifd: wan (20045): Sending discover...
Thu Aug 28 15:45:53 2014 daemon.notice netifd: wan (20045): Sending select for ......
Thu Aug 28 15:45:53 2014 daemon.notice netifd: wan (20045): Lease of ... obtained, lease time 2864
Thu Aug 28 15:45:53 2014 daemon.notice netifd: Interface 'wan6' is enabled
Thu Aug 28 15:45:53 2014 daemon.notice netifd: Network alias 'eth1' link is up
Thu Aug 28 15:45:53 2014 daemon.notice netifd: Interface 'wan6' has link connectivity
Thu Aug 28 15:45:53 2014 daemon.notice netifd: Interface 'wan6' is setting up now
Thu Aug 28 15:45:53 2014 daemon.notice netifd: Interface 'wan' is now up
Thu Aug 28 15:45:58 2014 daemon.notice netifd: Network device 'tun0' link is up

comment:20 Changed 3 years ago by robnitro@…

Weird, I have no issues. I built from hnyman's configs on both latest BB 42313, and a few versions back trunk. I'll be testing it on a friend's ag300h soon, which also has the issue UNLESS i force 100 full duplex with ethtool -s eth1 speed 100 duplex full autoneg on (some reason autoneg off causes issues).

Oh and on my wndr3800, when I set ethtool -s eth1 speed 100 duplex full, it would take but the speeds would be horribly slow, even just a single speed test. Now with the patch, no issues.

Are you trying to run 3.14 kernel?
Double check you have the wan port plugged in well. My 3800 has one that doesn't click too solidly- I end up wrapping the wire around the router to prevent issues.

I still can't get it to work on AA 42171 gargoyle. Doh.

comment:21 Changed 3 years ago by anonymous

No it is 3.10 kernel. ... I compile every week, and yesterday all three of y 3800 routers were working fine. Applied the patched compiled build this morning and two of them arent working anymore (switch/wan) is resetting every few minutes like seen in the logs. I dont know why my third wndr3800 is working fine so far though. Am compiling without the patch now atm and will revert back.

comment:22 Changed 3 years ago by anonymous

Reflashed without the patch and now everything is working again. It was definitely the patch, and cant say why it's working for you, and not, on two of my wndr3800. Maybe because they had dhcp or IPv6, my other 3rd wndr3800 working so far has static on its WAN and just IPv4.

comment:23 Changed 3 years ago by robnitro@…

Devs, can merge with this ticket or close as the patch seems to be the right direction.
/ticket/13072.html

comment:24 Changed 3 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

comment:25 Changed 3 years ago by robnitro@…

I'm having issues, see ticket 13072.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.