Modify

Opened 3 years ago

Closed 3 years ago

#17542 closed defect (not_a_bug)

Mangled routing broken, sh scripts broken

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

Just updated my three WNDR3800 to newest trunk and nothing is working anymore. Mangled routing is broken, my routing scripts give errors like these:

/etc/openvpn/up/route-up.sh: line 10: stat: not found
sh: 2097152: unknown operand

line 10 is: FILESIZE=$(stat -c%s $UPLOG)

Last week everything worked fine. What did you do? Ive compiled file without any problems, oldpackages enabled. Cant figure out yet why mangled routing doesnt work anymore...

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by anonymous

Seems like you changed something with sh, relating to variables dont work anymore... ?

comment:2 Changed 3 years ago by jow

  • Resolution set to too_vague
  • Status changed from new to closed

Seems you forgot to include "coreutils-stat"

comment:3 Changed 3 years ago by anonymous

  • Resolution too_vague deleted
  • Status changed from closed to reopened

Your site ate my comment on here because of "bad gateway", so I have to cut it short. Stat was there before as basic sh command, I never installed a coreutils-stat before and it worked. And Im doing a compile every week, and this is new. Did you change something there? Also I see there's a coreutils-touch, however, touch is still a basic sh command.

comment:4 Changed 3 years ago by jow

  • Resolution set to not_a_bug
  • Status changed from reopened to closed

I don't recall busybox-stat being enabled by default in the past, at least it was off in the AA release already. Maybe you modified the busybox config in your custom build and failed to port your config to the new defaults format.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.