Modify

Opened 3 years ago

#17540 new defect

LAN as WAN on rt-n56u: issue with internal switch?

Reported by: algemeen@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc:

Description

I'm trying to configure my rt-n56u as a dual WAN router (using the second WAN port for IPTV). But there seems to be a problem when using one of the LAN ports as a WAN ports. Packets (sent from the router or LAN to the 2nd WAN port) only get through occasionaly. I checked my routing tables and can't find anything at fault there. Also, checking the swconfig the counters of the port are not being incremented. The problem occurs also when the LAN port as the only WAN port. Therefore I'm suspecting something is wrong with the switch code. I tried both rc2 and rc3 of Barrier Breaker 14.07.

This is the config I'm using:

config interface 'loopback'

option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'

option ula_prefix 'fda7:7d6c:71ac::/48'

config interface 'lan'

option ifname 'eth0.1'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option delegate '0'

config interface 'wan'

option proto 'dhcp'
option delegate '0'
option _orig_ifname 'eth0.2'
option _orig_bridge 'false'
option peerdns '0'
option dns '208.67.222.222 208.67.220.220'
option ifname 'eth0.3'

config interface 'IPTV'

option proto 'dhcp'
option vendorid '<snip>'
option macaddr '<snip>'
option _orig_ifname 'eth0.2'
option _orig_bridge 'false'
option auto '0'
option delegate '0'
option ifname 'eth0.2'
option defaultroute '0'
option peerdns '0'

config switch

option name 'switch0'
option reset '1'
option enable_vlan4k '1'
option enable_vlan '1'

config switch_vlan

option device 'switch0'
option vlan '1'
option ports '0 1 2 8t'

config switch_vlan

option device 'switch0'
option vlan '2'
option ports '3 8t'

config switch_vlan

option device 'switch0'
option vlan '3'
option ports '4 8t'

Attachments (0)

Change History (0)

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.