Modify

Opened 3 years ago

Closed 3 years ago

#17539 closed defect (invalid)

Various packages do not respect busybox_config_ip

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

│ Symbol: PACKAGE_ip [=y] │

│ Type : tristate │
│ Prompt: ip..................................... Routing control utility (Minimal) │
│ Defined at tmp/.config-package.in:24259 │
│ Location: │
│ -> Network │
│ -> Routing and Redirection │
│ Selects: PACKAGE_librt [=y] && PACKAGE_libpthread [=y] && PACKAGE_libnl-tiny [=y] && PACKAGE_libc [=y] │

│ Selected by: PACKAGE_freifunk-gwcheck [=n] && PACKAGE_firewall [=y] && PACKAGE_olsrd [=y] && PACKAGE_iptables [=y] │ PACKAGE_freifunk-policyrouting [=n] │ PACKAGE_ahcpd [=n] │ OPENVPN_nossl_ENABLE_IPROUTE2 [=n] │ PACKAGE_openvpn-polarssl [=n] && OPENVPN_polarssl_ENABLE_IPROUTE2 [=n] │ PACKAGE_ppp-multilink [=n]) && PACKAGE_kmod-ppp [=m]
\ │
PACKAGE_luci-mod-freifunk-community [=n] && PACKAGE_iptables [=y] && PACKAGE_firewall [=y] \ │
PACKAGE_aiccu [=n] PACKAGE_tayga [=y] PACKAGE_mwan3 [=n] PACKAGE_openvpn-nossl [=n] && \ │
PACKAGE_openvpn-openssl [=n] && OPENVPN_openssl_ENABLE_IPROUTE2 [=n] \ │
PACKAGE_xl2tpd [=n] && (PACKAGE_ppp [=n] \ │
PACKAGE_collectd-mod-netlink [=n] && PACKAGE_collectd [=m] && BROKEN [=n]

Solutions:
PACKAGE_freifunk-gwcheck
package/feeds/luci/freifunk-gwcheck/Makefile:18

DEPENDS:=firewall +BUSYBOX_CONFIG_IP:ip +iptables-mod-ipopt +olsrd-mod-dyn-gw-plain

PACKAGE_ahcpd
./feeds/routing/ahcpd/Makefile:27

DEPENDS:=+kmod-ipv6 +BUSYBOX_CONFIG_IP:ip +librt

PACKAGE-aiccu
./feeds/packages/ipv6/aiccu/Makefile:27

DEPENDS:=+libpthread +BUSYBOX_CONFIG_IP:ip +kmod-sit +kmod-tun

PACKAGE_tayga
./feeds/packages/ipv6/tayga/Makefile:24

DEPENDS:=+BUSYBOX_CONFIG_IP:ip +kmod-ipv6 +kmod-tun

PACKAGE_mwan3
./feeds/packages/net/mwan3/Makefile

DEPENDS:=+BUSYBOX_CONFIG_IP:ip +iptables +iptables-mod-conntrack-extra +iptables-mod-ipopt

PACKAGE_openvpn
./package/network/services/openvpn/Makefile:34
-- DEPENDS:=+kmod-tun +OPENVPN_$(1)_ENABLE_LZO:liblzo +OPENVPN_$(1)_ENABLE_IPROUTE2:ip $(3)
;; ?? Unsure how to solve: http://wiki.openwrt.org/doc/devel/dependencies

PACKAGE_xl2tpd
./feeds/packages/net/xl2tpd/Makefile:35

DEPENDS:=+ppp-mod-pppol2tp +BUSYBOX_CONFIG_IP:ip +resolveip

Remark: resolveip OR dnsmasq?

./feeds/packages/utils/collectd/Makefile:284
-- $(eval $(call BuildPlugin,netlink,netlink input,netlink,+PACKAGE_collectd-mod-netlink:ip @BROKEN))

;; ?? Unsure how to solve: http://wiki.openwrt.org/doc/devel/dependencies

Attachments (0)

Change History (9)

comment:1 Changed 3 years ago by jow

  • Resolution set to not_a_bug
  • Status changed from new to closed

This is a feature request, not a bug report - please send a patch according to ​https://dev.openwrt.org/wiki/SubmittingPatches

comment:2 Changed 3 years ago by anonymous

  • Resolution not_a_bug deleted
  • Status changed from closed to reopened

If OpenWRT was a platform and users ought to compile their own images, as suggested in various developer posts regarding regdomain problems, it should be possible to activated busybox-plugins without collisions with other packages.
Packages not respecting freedom to choose are therefore buggy and are hindering development for special cases. (E.g. dev for devices currently unsupported by OpenWRT).

If the developers would like not to see another fork of OpenWRT out in the wild, which may lead to missing contributions flowing back to it, I would suggest to think it over once more and include those minor changes.

The typical user won't stumble upon this.

Another one:
contrib/package/luci-addons/Makefile:53

delete ip - it's already selected.

comment:3 Changed 3 years ago by anonymous

BTW: it not a feature request, since all functionality is already included with the source.
It's only for makefiles, that are wrongfully ignorant to other ways of implementation. i.e. kind of monoculturally written (is a makefile programmed?).

comment:4 Changed 3 years ago by jogo

  • Resolution set to not_a_bug
  • Status changed from reopened to closed

Still a feature request, and also the wrong location to discuss - note how almost everything is from feeds/, for which this is not the right place.

for feeds/packages, send a pull request to https://github.com/openwrt/packages/, for feeds/routing, to https://github.com/openwrt-routing/packages etc.

comment:5 Changed 3 years ago by anonymous

It's not a feature. It's delivered source, that is selectable.

Busybox is from base.
opkg is from base.

That >>
If opkg would support a "PROVIDES=" and "REPLACES=" we wouldn't have to fiddle with feeds in all cases.
Then I could write simply write meta-package.. setting just busybox options.
<<
would be a feature request.

jogo, closing is not helpful.
Ignorance is not helping either.

comment:6 Changed 3 years ago by anonymous

  • Resolution not_a_bug deleted
  • Status changed from closed to reopened

comment:7 Changed 3 years ago by jogo

  • Resolution set to moved_to_github
  • Status changed from reopened to closed

And reopening is not helpful either.

As previously said, this is the wrong project/bug ticker, as all accept one packages are not from the openwrt core packages, but from the different package feeds on github.

And trac is only for the openwrt core system/packages.

Also note that busybox' ip applet only supports a subset of the features of the full ip package, so chances are those that "don't respect busybox' ip applet" don't actually work with it.

So at the very least you need to prove that they actually work fine with the ip applet.

comment:8 Changed 3 years ago by anonymous

  • Resolution moved_to_github deleted
  • Status changed from closed to reopened

Busybox is in openwrt's base files. The feature set of busybox-ip is sufficient for a majority of setups.
Reporting and communicating dependency problems is a core task of a distribution's development team.
Leave this ticket open until all devs from dependent packages have reported a solution to this.
If a developer of a dependent package finds, that busybox-ip does not meet his needs (what will not be the case in 99%; you can easily prove that yourselves by egrepping the source for other usage that that provided by busybox-ip with a full feature set). Please note, that there are additional features in busybox-ip, that are too, not activated by default.
Another or even better solution would be to build a ip/ifconfig wrapper script (that would even compress better in squashfs than a binary) working with netifd only. Currently, the setup is redundant in multiple ways, eating up precious flash space and likely to fail (as in olsrd-ignorant-netifd some months ago...).

comment:9 Changed 3 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.