Modify

Opened 3 years ago

Last modified 3 years ago

#17534 reopened defect

brcm47xx regdomain world

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

cannot override regdomain settings

Attachments (0)

Change History (12)

comment:1 Changed 3 years ago by Zajec

Do you honestly find info you provided detailed enough to understand the problem?

comment:2 Changed 3 years ago by hauke

  • Resolution set to too_vague
  • Status changed from new to closed

comment:3 Changed 3 years ago by elvirus

  • Resolution too_vague deleted
  • Status changed from closed to reopened

I can confirm that the country setting in wifi config doesn't set all the wireless channel properly.
For example setting an EU country (FR, DE, IT, ecc..) doesn't make available channel 12 and 13.

If you need some output, please let me know.

comment:4 Changed 3 years ago by hauke

Which driver are you talking about?

EU is not a valid country code for mac80211 based drivers.

comment:5 Changed 3 years ago by robnitro

I have WNDR3800 on trunk, arokh build latest.
With country code world 00 in the jow hack using optimized build by arokh, I cannot go beyond the 26dB setting for 2.4ghz, even though option is set to 27,28,29,30.

So it may be related to yours.

comment:6 Changed 3 years ago by anonymous

Oh and forgot to mention... on gargoyle 41503 aa build, I can go up to 30 dB on 2.4 and 5 ghz.

comment:7 Changed 3 years ago by jow

Robnitro: no it is not related, and 30dBm on wifi is wishful thinking. Actual output is likely 18-20dBm, check the FCC datasheets of your model.

comment:8 Changed 3 years ago by elvirus

@hauke for example with brcmsmac. I tried different EU Country codes not EU itself.

Here is what I get from iw list:

Frequencies:
			* 2412 MHz [1] (19.0 dBm)
			* 2417 MHz [2] (19.0 dBm)
			* 2422 MHz [3] (19.0 dBm)
			* 2427 MHz [4] (19.0 dBm)
			* 2432 MHz [5] (19.0 dBm)
			* 2437 MHz [6] (19.0 dBm)
			* 2442 MHz [7] (19.0 dBm)
			* 2447 MHz [8] (19.0 dBm)
			* 2452 MHz [9] (19.0 dBm)
			* 2457 MHz [10] (19.0 dBm)
			* 2462 MHz [11] (19.0 dBm)
			* 2467 MHz [12] (19.0 dBm) (no IR)
			* 2472 MHz [13] (19.0 dBm) (no IR)
			* 2484 MHz [14] (disabled)

14 disabled it's ok, but 12 and 13 should be enabled also for transmission in EU.

And here is kernel log:

[   21.700000] cfg80211: World regulatory domain updated:
[   21.710000] cfg80211:  DFS Master region: unset
[   21.710000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   21.720000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   21.730000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   21.740000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   21.750000] cfg80211:   (5170000 KHz - 5250000 KHz @ 160000 KHz), (N/A, 2000 mBm), (N/A)
[   21.760000] cfg80211:   (5250000 KHz - 5330000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   21.770000] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   21.770000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   21.780000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   21.930000] brcmsmac bcma0:0: mfg 4bf core 812 rev 17 class 0 irq 3
[   21.940000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   33.840000] device eth0.1 entered promiscuous mode
[   33.850000] device eth0 entered promiscuous mode
[   33.860000] br-lan: port 1(eth0.1) entered forwarding state
[   33.860000] br-lan: port 1(eth0.1) entered forwarding state
[   35.860000] br-lan: port 1(eth0.1) entered forwarding state
[   35.900000] cfg80211: Calling CRDA for country: FR
[   35.940000] cfg80211: Regulatory domain changed to country: FR
[   35.940000] cfg80211:  DFS Master region: ETSI
[   35.950000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   35.960000] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   35.960000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   35.970000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz), (N/A, 2000 mBm), (0 s)
[   35.980000] cfg80211:   (5490000 KHz - 5710000 KHz @ 80000 KHz), (N/A, 2700 mBm), (0 s)
[   35.990000] cfg80211:   (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)

I also noticed (maybe is better to open a different ticket - let me know) that this driver not seems to work with 40MHz channel width and HT mode enabled. After this config radio simply does not start.

comment:9 Changed 3 years ago by anonymous

You are right: despite the hardware does not support ist on b43, it should rather fall back to what it is capable and throw and error, imo.

comment:10 Changed 3 years ago by igor

So, is this valid?

comment:11 Changed 3 years ago by annoy

Is there any news or comment on this? Please let me know if you need dumps or debug...

comment:12 Changed 3 years ago by hauke

brcmsmac does not support 40MHz channel

The brcmsmac code [0] looks like it applies always the same regulatory hint.

[0]: drivers/net/wireless/brcm80211/brcmsmac/channel.c

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.