Modify

Opened 3 years ago

Last modified 3 years ago

#17487 new defect

ffmpeg - recursive dependency detected

Reported by: mroek Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

tmp/.config-package.in:19358:error: recursive dependency detected!
tmp/.config-package.in:19358:	symbol PACKAGE_libffmpeg-full is selected by PACKAGE_ffmpeg
tmp/.config-package.in:25638:	symbol PACKAGE_ffmpeg is selected by PACKAGE_sox
tmp/.config-package.in:56429:	symbol PACKAGE_sox depends on PACKAGE_libffmpeg-full

None of these packages are actually used in my config, but it should be resolved nonetheless.

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by thess

Cannot reproduce. Newer package version of sox in CC.

comment:2 Changed 3 years ago by mroek

In my tree there was a link to sox under oldpackages, which caused this error. Manually unlinking did the trick. Why isn't this done automatically when packages are moved?

comment:3 Changed 3 years ago by anonymous

Because the oldpackages feed is not updated by default anymore. To do that, remove the #-sign for the oldpackages feed in feeds.conf.default. In that way, packages that are moved from oldpackages to packages are cleaned up properly when you update the feeds.

comment:4 Changed 3 years ago by mroek

Thanks for the tip!

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.