Modify

Opened 3 years ago

Closed 3 years ago

#17478 closed defect (worksforme)

opkg update failure

Reported by: daniel.petre Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version: Barrier Breaker 14.07
Keywords: Cc:

Description

Hello,
compiled BB branch with r42096 and when trying opkg update it says:

Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Collected errors:

Any idea how to mitigate this?
Thanks!

Attachments (0)

Change History (5)

comment:1 Changed 3 years ago by daniel.petre

root@openwrt:~# cat /etc/opkg.conf
dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay
src/gz barrier_breaker http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages

comment:2 Changed 3 years ago by pablo.covacevich@…

could you upload LUCI?
I have the same problem and i see that in a month the problem wasn't resolved.

comment:3 Changed 3 years ago by hnyman

It is not a bug, but your old config deviates from the current snapshot repository structure. (Defaults have changed since your firmware was built.)

Read https://forum.openwrt.org/viewtopic.php?pid=243943#p243943

In a live Openwrt trunk system, the last lines in /etc/opkg.conf should be:

src/gz chaos_calmer_base http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/base
src/gz chaos_calmer_luci http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/luci
src/gz chaos_calmer_management http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/management
src/gz chaos_calmer_packages http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/packages
src/gz chaos_calmer_routing http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/routing
src/gz chaos_calmer_telephony http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/telephony

comment:4 Changed 3 years ago by pablo.covacevich@…

Thanks, now it worked for me.

comment:5 Changed 3 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.