Modify

Opened 3 years ago

Closed 3 years ago

#17474 closed defect (worksforme)

404 error downloading Packages.gz - brcm2708

Reported by: andreagott Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

I can't use opkg on my Raspberry Pi, as the packages list cannot be found on the server. Have I missed an update maybe?

Downloading http://downloads.openwrt.org/snapshots/trunk/brcm2708/packages/Packages.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/brcm2708/packages/Packages.gz, wget returned 1.

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by hnyman

Yes. You have missed the PER_FEED_REPO change.

The snapshot packages are since last week in subdirectories below that packages.

See http://downloads.openwrt.org/snapshots/trunk/brcm2708/packages/
there are now base, luci, management, packages, routing, telephony subdirectories, inside which are separate Packages.gz files for that feed.

You need to either edit your old /etc/opkg.conf to have all those 5 feed dirs defined, or you need to flash a newer build with that setting built in.

Buildbot snapshots have defaulted to the new structure since last Thursday(?) and default settings for private builds have changed been changed today by r42112.

comment:2 Changed 3 years ago by andreagott

Thank you!

comment:3 Changed 3 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.