Modify

Opened 3 years ago

Closed 3 years ago

#17470 closed task (not_a_bug)

in barrier breaker php5 ipk files do not find

Reported by: 12607540@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: php5 Cc:

Description

http://downloads.openwrt.org/barrier_breaker/14.07-rc2/ramips/rt305x/packages/

we can find ramips rt305x python ipk file,but several days ago, php5 and php5* ipk file found in beta version,but now they are gone。

please release php5 and php5* ipk as soon as possible

Attachments (0)

Change History (9)

comment:1 Changed 3 years ago by anonymous

Not a bug. All-mighty devs decided to delete 90% of the important packages, php5 included, because "no one is maintaining them". They still work of course but, "no one is maintaining them" :P :X <3 <3 <'3 Say bye bye to your phpy :PP

comment:2 Changed 3 years ago by etienne.champetier

Hi anonymous,
You should spend less time complaining and more time helping, maybe fixing bugs or maintaining packages.
Also if it's so important why nobody step up and maintain php ...

All "oldpackages" should be built for BB release, if it doesn't show up maybe it's really broken

"oldpackages" are not built anymore in CC/trunk/snapshot

comment:3 Changed 3 years ago by anonymous

There was no reason to deactivate oldpackages if 99% of them still compile, it was a random and insane movement and doesnt do anything good for the community. PHP5 is missing in BB, whatever reason for, and no it wasnt broken. Also some of the broken packages from oldpackages were "broken" because of the move to github and simple path errors. Stop saying stupid nonsense when you have no idea. At least 10 packages of the oldpackages are important, things like iftop, bmon, netstat-nat, ect, and theyre gone now.

comment:4 Changed 3 years ago by hauke

So please step up and maintain some of the packages that are important for you and your problem is solved.

Many of the oldpackages have know security problems, see:
https://home.comcast.net/~sdwalker/uscan/index.html

comment:5 Changed 3 years ago by anonymous

where to download php or php5 "oldpackages".
PLS give us a clue

comment:6 Changed 3 years ago by anonymous

downloads.openwrt.org
and
forum.openwrt.org
seem to be down right now: pingable, but no http/https service.

comment:7 Changed 3 years ago by anonymous

A few hints:
feeds.conf.default
src-git oldpackages http://git.openwrt.org/packages.git

comment:8 Changed 3 years ago by anonymous

svn co svn://svn.openwrt.org/openwrt/trunk
unset SED
cd trunk
cp feeds.conf.default feeds.conf
echo "src-git oldpackages http://git.openwrt.org/packages.git" >> feeds.conf
./scripts/feeds update -a
./scripts/feeds install -a
make package/symlinks
make menuconfig
make

And youll have your php5, and others.

comment:9 Changed 3 years ago by mhei

  • Resolution set to not_a_bug
  • Status changed from new to closed

Precompiled packages are available for BB, see for example http://downloads.openwrt.org/barrier_breaker/14.07/ramips/rt305x/packages/oldpackages
So I'm closing this ticket.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.