Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#17430 closed defect (fixed)

New PER_FEED_REPO causes firmware generation problems?

Reported by: hnyman Owned by: developers
Priority: highest Milestone: Chaos Calmer 15.05
Component: toolchain Version: Trunk
Keywords: Cc:


This may be jumping the gun, but I tried to test the new PER_FEED_REPO package directory feature that the buildbot has been configured to use since yesterday. The feature has been introduced my r42002, r42003 and r42004.

I get 1 MB firmware package. Apparently the kernel without anything else.

It looks to me that the package installation step fails. Packages to be installed are searched from ar71xx/packages/, not from ar71xx/packages/base, ar71xx/packages/luci etc. directories.

For my ar71xx/wndr3700 build I tried to clean everything including the package indices (but did not quite do distclean).

I looked into the buildbot to see how it succeeds there.

The ar71xx buildbot failed yesterday to upload after build, so there are no actual firmware files to verify if everything is ok. But there are build logs from the build run, as the build itself completed.

And the buildbot logs contain a crop of new errors in the "package install" step. Note the wrong path without feed name:

/usr/bin/find: `/store/buildbot/slave/slave/ar71xx/build/bin/ar71xx/packages/base-files_*.ipk': No such file or directory
/usr/bin/find: `/store/buildbot/slave/slave/ar71xx/build/bin/ar71xx/packages/uboot-envtools_*.ipk': No such file or directory
/usr/bin/find: `/store/buildbot/slave/slave/ar71xx/build/bin/ar71xx/packages/kmod-gpio-button-hotplug_*.ipk': No such file or directory
/usr/bin/find: `/store/buildbot/slave/slave/ar71xx/build/bin/ar71xx/packages/kernel_*.ipk': No such file or directory
/usr/bin/find: `/store/buildbot/slave/slave/ar71xx/build/bin/ar71xx/packages/kmod-crypto-core_*.ipk': No such file or directory
/usr/bin/find: `/store/buildbot/slave/slave/ar71xx/build/bin/ar71xx/packages/kmod-crypto-aes_*.ipk': No such file or directory
/usr/bin/find: `/store/buildbot/slave/slave/ar71xx/build/bin/ar71xx/packages/kmod-crypto-arc4_*.ipk': No such file or directory
/usr/bin/find: `/store/buildbot/slave/slave/ar71xx/build/bin/ar71xx/packages/kmod-ledtrig-usbdev_*.ipk': No such file or directory

In the previous successful build the same packages installed ok:

Installing base-files (155-r41997) to root...
Installing libc ( to root...
Installing libgcc (4.8-linaro-1) to root...
Installing netifd (2014-07-30-4f5b41cf789fcc30e142dfdb1123a8adc12112d5) to root...
Installing libuci (2014-04-11.1-1) to root...
Installing libubox (2014-07-16-bd388d2b6c2c151bf513c1e449417d18ce02d10b) to root...
Installing libnl-tiny (0.1-3) to root...
Installing libubus (2014-07-03-f688c7ad0b2435a89bfd13f5496cabf596b54c8f) to root...
Installing ubus (2014-07-03-f688c7ad0b2435a89bfd13f5496cabf596b54c8f) to root...

Similar errors have appeared also to logs of other platforms, so there may be something wrong in the package installation into the firmware.

My own build log matches the buildbot log.

When looking into possible causes of error, this is my first suspect:

The line is:

@$(FIND) sed -e 's|.*|$(PACKAGE_DIR)/&_*.ipk|' $(PACKAGE_INSTALL_FILES) | sort -u | $(OPKG) install

Does the sed command overlook the package feed subdirs, when formatting argument for find?

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed with r42041

comment:2 Changed 3 years ago by hnyman

The generated firmware file looks normal, again.

Please note that the fix needs to be backported to Barrier Breaker branch, as the problematic r42002 has already been backported there (r42016).

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.