Modify

Opened 3 years ago

#17395 new defect

opkg: force-downgrade option is broken, does not downgrade a package

Reported by: braveheart_leo@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: opkg force downgrade Cc:

Description

I'm trying to downgrade wpad-mini on my system running CHAOS CALMER (Bleeding Edge, r42002), which is running from a pivot overlay-ed external storage. I'm doing this because of r41982.

# opkg info wpad-mini

Package: wpad-mini
Version: 2014-06-03-1
Depends: libc, libnl-tiny, libubus
Status: unknown ok not-installed
Section: net
Architecture: ramips_24kec
Maintainer: Felix Fietkau <nbd@openwrt.org>
MD5Sum: dc694abaee40be556bcc6582d90a0b5c
Size: 217623
Filename: wpad-mini_2014-06-03-1_ramips_24kec.ipk
Source: package/network/services/hostapd
Description: This package contains a minimal IEEE 802.1x/WPA Authenticator and Supplicant (WPA-PSK only).

Package: wpad-mini
Version: 2014-07-29-1
Depends: libc, libnl-tiny, libubus
Status: install user installed
Architecture: ramips_24kec
Installed-Time: 1406723405

However, if I do this:

# opkg --force-downgrade install http://downloads.openwrt.org/snapshots/trunk/ramips/packages/base/wpad-mini_2014-06-03-1_ramips_24kec.ipk

Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/packages/base/wpad-mini_2014-06-03-1_ramips_24kec.ipk
Package wpad-mini (2014-07-29-1) installed in root is up to date.

# opkg list-installed |grep wpad-mini
wpad-mini - 2014-07-29-1

As can be seen from above, the --force-downgrade option did not downgrade the package.

Was such option ever meant to work?

Attachments (0)

Change History (0)

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.