Modify

Opened 4 years ago

Closed 3 years ago

#17385 closed defect (fixed)

RB912UAG-5HPnD, no network after power cycle

Reported by: hvandrie Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: kernel Version: Barrier Breaker 14.07
Keywords: Cc:

Description

Utilizing an Mikrotik as an Wireless AP within a DHCP managed network.

Device: Mikrotik RouterBoard 912G 5HPnD

When configuring br-lan to use DHCP for IP Addressing, it works only until next power cycle.
After power cycle, it never is able to receive DHCP until it's configured static again.
Here's output:

Tue Aug 5 14:59:51 2014 kern.info kernel: [ 18.250000] br-lan: topology change detected, propagating
Tue Aug 5 14:59:51 2014 kern.info kernel: [ 18.250000] br-lan: port 1(eth0) entered forwarding state
Tue Aug 5 14:59:51 2014 kern.info kernel: [ 18.260000] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
Tue Aug 5 14:59:51 2014 daemon.notice netifd: Bridge 'br-lan' link is up
Tue Aug 5 14:59:51 2014 daemon.notice netifd: Interface 'lan' has link connectivity
Tue Aug 5 14:59:51 2014 daemon.notice netifd: Interface 'lan' is setting up now
Tue Aug 5 14:59:51 2014 daemon.notice netifd: lan (1172): udhcpc (v1.22.1) started
Tue Aug 5 14:59:51 2014 daemon.notice netifd: lan (1172): Sending discover...
Tue Aug 5 14:59:52 2014 kern.info kernel: [ 18.680000] br-lan: port 3(wlan0) entered learning state
Tue Aug 5 14:59:52 2014 kern.info kernel: [ 19.290000] br-lan: port 2(wlan1) entered learning state
Tue Aug 5 14:59:54 2014 kern.info kernel: [ 20.680000] br-lan: topology change detected, propagating
Tue Aug 5 14:59:54 2014 kern.info kernel: [ 20.680000] br-lan: port 3(wlan0) entered forwarding state
Tue Aug 5 14:59:54 2014 kern.info kernel: [ 21.290000] br-lan: topology change detected, propagating
Tue Aug 5 14:59:54 2014 kern.info kernel: [ 21.290000] br-lan: port 2(wlan1) entered forwarding state
Tue Aug 5 14:59:54 2014 daemon.notice netifd: lan (1172): Sending discover...
Tue Aug 5 14:59:57 2014 daemon.notice netifd: lan (1172): Sending discover...

Attachments (0)

Change History (16)

comment:1 Changed 4 years ago by hvandrie@…

It appears to be different.
Whenever network ip addressing is changed, meaning other than factory default 192.168.1.1, and the system is power cycled (unplugged, replugged) there's no more connectivity for that interface that was changed to a different setting. Same happens when changing proto to dhcp or back to static, doesn't matter, simply doesn't work anymore. It does remember all it's configuration settings, but that's it...

I've got two brand new Mikrotik RouterBoard 91xG 5HPnD. Both have the same problem.

Anyone got an idea what's going on?!

comment:2 Changed 4 years ago by hvandrie@…

LAN interface assigned to DHCP, receives nothing...
Firewall is disabled.

br-lan Link encap:Ethernet HWaddr 4C:5E:0C:80:ED:AE

inet6 addr: fe80::4e5e:cff:fe80:edae/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:45 errors:0 dropped:0 overruns:0 frame:0
TX packets:29 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:7727 (7.5 KiB) TX bytes:8958 (8.7 KiB)

eth0 Link encap:Ethernet HWaddr 4C:5E:0C:80:ED:AE

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:127 errors:0 dropped:2 overruns:0 frame:0
TX packets:68 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:28957 (28.2 KiB) TX bytes:10986 (10.7 KiB)
Interrupt:4

Utilizing a usb dongle as a backup to be able to get back into the console as the freak'in device doesn't have a working serial:

config interface 'lan'

option ifname 'eth0'
option force_link '0'
option type 'bridge'
option proto 'dhcp'

# option ipaddr '192.168.1.1'
# option netmask '255.255.255.0'
# option ip6assign '60'

option auto '1'
option stp '1'

config interface 'backup'

option ifname 'eth1'
option force_link '0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option auto '1'

Was playing with all kinds of settings in network config.
The auto nor force_link have any effect, tried both boolean values... no difference.

After you power cycle the device, it just can't assign static or dhcp address anymore.

comment:3 Changed 3 years ago by anonymous

Please close this ticket, and refer to #17449 instead.

comment:4 Changed 3 years ago by hvandrie@…

Using openwrt-ar71xx-mikrotik-DefaultNoWifi-rootfs.tar.gz from BB 14.07-rc3 to flash NAND.
Keeping network configuration default, no alterations.
After restart, all ok.
After power cycle, no more network.

Please change caption of ticket to: RB912UAG-5HPnD, no network after power cycle

comment:5 Changed 3 years ago by jogo

  • Component changed from other to kernel
  • Summary changed from Receive no DHCP when setting br-lan to dhcp proto to RB912UAG-5HPnD, no network after power cycle

I don't have access to any RB912, so I can't actually help much.

To me it looks like the switch or the ethernet mac is not initialized by the bootloader when booting from flash, only when netbooting. OpenWrt does not seem to do it either, at least not properly, resulting in the wired networking not working.

comment:6 Changed 3 years ago by anonymous

Problem still exists with RB912UAG-2HPnD (not only 5HPnD) and Chaos Calmer r43205.

comment:7 Changed 3 years ago by anonymous

I've tested RB912UAG-2HPnD with the latest OpenWRT 14.07 Barrier Breaker .

I don't think this board should be listed in OpenWRT's Table of Hardware as compatible if the one and only cable network connection is not available.

It would be nice if its Wiki page would link to this ticket.

comment:8 Changed 3 years ago by hvandrie@…

@jogo,

It seems I do not receive any mail updates on these posts, unfortunately. Now found out by accident that you guys followed up.

Would it help when I grant you remote access to the unit by serial+ethernet+powercycle abilities with PXE from a ubuntu system? I'll set up a lab for you to play with the unit.
My internet connection is a fiberoptic 500/500 Mbps, so you'll have no glitches in accessing.

comment:10 Changed 3 years ago by anonymous

Is there any workaround?

comment:11 Changed 3 years ago by pratnala

Has this issue been resolved or does it still persist? I'm skeptical of using OpenWRT on the RB912UAG-2HPnD I have and I guess I have to stick with Router OS.

comment:12 Changed 3 years ago by anonymous

Thank you for updating the wiki, that's good news...

But Mikrotik changing revisions from time to time without telling at least revision numbers of the parts you purchase is really bad news, even more when it breaks compatibility with OpenWRT, as it has happened before with other Mikrotik Routerboards, experiencing NAND memory corruption and several other issues depending on chips used in different hardware revisions...

comment:13 Changed 3 years ago by hvandrie@…

Okay, so how can we proceed from here?
I like to attempt to solve the matter by investigating myself. But some hints on where to look would be helpful.
Else I am forced to always be running from ramdisk images...

comment:14 Changed 3 years ago by hvandrie

Just tested latest Trunk build r45499, network seems to be working properly now!
Power cycled many times, changed config from dhcp to static and vice versa. Br-Lan is now properly configurable! Thx!

comment:15 Changed 3 years ago by anonymous

Confirmed, ethernet works with CC. Please close ticket.

comment:16 Changed 3 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.