Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#17356 closed defect (not_a_bug)

Whats going on, you removed lots of working and important packages

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

syslog-ng3, php5, netstat-nat, just to count a few, I haven't looked into this yet what else is missing. Whats going on?

Attachments (0)

Change History (7)

comment:1 Changed 4 years ago by anonymous

p910nd, bmon, iptraf, paris-traceroute, zoneinfo-core, zoneinfo-europe, all missing.

comment:2 Changed 4 years ago by jogo

  • Resolution set to not_a_bug
  • Status changed from new to closed

As announced on https://lists.openwrt.org/pipermail/openwrt-devel/2014-June/025810.html, the old packages feed was disabled for the buildbots.

If you need any of these packages then please consider taking over maintainership as described in https://github.com/openwrt/packages, which will make them built again as a side effect.

comment:3 Changed 4 years ago by anonymous

  • Resolution not_a_bug deleted
  • Status changed from closed to reopened

lol? just because there's no "maintainer" doesnt mean they dont work. you cant just make dictator like decisions which you maybe like but 99% of the people who use openwrt dislike. how do I get the "oldpackages" back into the trunk folder and compile myself. let people decide themself if they need those "obsolete" packages please.

comment:4 Changed 4 years ago by anonymous

Please update http://wiki.openwrt.org/doc/howto/build and add a hint on how to get the oldpackages if you need them. It isnt included anymore by a svn co svn://svn.openwrt.org/openwrt/trunk How do I pull it now to implement?

comment:5 Changed 4 years ago by cyrus

  • Resolution set to not_a_bug
  • Status changed from reopened to closed

You are free to compile oldpackages yourself.
Also we still provide binaries for the BB release just not in the snapshots.
See e.g. http://downloads.openwrt.org/barrier_breaker/14.07-rc2

To build packages from "oldpackages" by yourself:

  1. Copy feeds.conf.default to feeds.conf
  2. Open feeds.conf and remove the # in front of "src-git oldpackages [...]"
  3. Do ./scripts/feeds update

You can now use ./scripts/feeds install xyz to make a package appear in make menuconfig.
To make all of them visible use ./scripts/feeds install -a -p oldpackages

comment:6 Changed 4 years ago by anonymous

Thank you. Worked :) Maybe add this to the wiki for other people too.

comment:7 Changed 4 years ago by anonymous

PHP5 is missing too in that BB snapshot...

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.