Modify

Opened 4 years ago

Last modified 3 years ago

#17353 new defect

unable to PPPoE connect to wan on HC6361 (trunk - r41954)

Reported by: ballgotz Owned by: developers
Priority: normal Milestone:
Component: base system Version: Barrier Breaker 14.07
Keywords: pppoe Cc:

Description

Hi,

Not sure if this is a bug or my misconfiguration, but PPPoE keeps getting timeout when trying to connect to wan on my HC6361.

Connect: pppoe-wan <--> /dev/pts/0
LCP: timeout sending Config-Requests
Connection terminated.
Modem hangup

According to wiki my HC6361 should work after r40975.

Whenever I flash my HC6361 with BB RC2, from the nightly snapshots, or self-built from the newest trunk (r41954), I can't get PPPoE to connect wan, it'll just keep getting timeout and restart. However, with the exact same configurations, I can use other people's pre-built firmware based on r40975 without any problems.

When sysupgrading to BB RC2 or the newest trunk, the PPPoE will be dead again. (It'll boot just fine and all else seems to be good, but PPPoE just won't work.)

I'm not sure if something happened between now and 6/2, but from the svn changesets I can't notice anything off the top of my head. Perhaps someone can figure out what's wrong or point me in the right direction?

My /etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd70:3b78:8d30::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'pppoe'
        option username 'xxxxxxxx'
        option password 'xxxxxxxx'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'

My dmesg output:

[    0.000000] Linux version 3.10.49 (mclee@o1.recordcup.com) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r41954) ) #1 Sun Aug 3 20:27:09 CST 2014
[    0.000000] MyLoader: sysp=9dbf3185, boardp=4cb3196d, parts=bdc1e69e
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 00019374 (MIPS 24Kc)
[    0.000000] SoC: Atheros AR9330 rev 1
[    0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:25.000MHz
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x03ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x03ffffff]
[    0.000000] On node 0 totalpages: 16384
[    0.000000] free_area_init_node: node 0, pgdat 803109b0, node_mem_map 81000000
[    0.000000]   Normal zone: 128 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 16384 pages, LIFO batch:3
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0 
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line:  board=HiWiFi-HC6361 console=ttyATH0,115200 mtdparts=spi0.0:64k(u-boot)ro,64k(bdinfo)ro,1280k(kernel),14848k(rootfs),64k(backup)ro,64k(art)ro,16128k@0x20000(firmware) rootfstype=squashfs,jffs2 noinitrd
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 61272k/65536k available (2239k kernel code, 4264k reserved, 603k data, 228k init, 0k highmem)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:51
[    0.080000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[    0.080000] pid_max: default: 32768 minimum: 301
[    0.080000] Mount-cache hash table entries: 512
[    0.090000] NET: Registered protocol family 16
[    0.100000] MIPS: machine is HiWiFi HC6361
[    0.550000] bio: create slab <bio-0> at 0
[    0.560000] Switching to clocksource MIPS
[    0.560000] NET: Registered protocol family 2
[    0.570000] TCP established hash table entries: 512 (order: 0, 4096 bytes)
[    0.570000] TCP bind hash table entries: 512 (order: -1, 2048 bytes)
[    0.570000] TCP: Hash tables configured (established 512 bind 512)
[    0.580000] TCP: reno registered
[    0.580000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.590000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.600000] NET: Registered protocol family 1
[    0.600000] PCI: CLS 0 bytes, default 32
[    0.620000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.620000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.630000] msgmni has been set to 119
[    0.640000] io scheduler noop registered
[    0.640000] io scheduler deadline registered (default)
[    0.650000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[    0.650000] ar933x-uart: ttyATH0 at MMIO 0x18020000 (irq = 11) is a AR933X UART
[    0.660000] console [ttyATH0] enabled, bootconsole disabled
[    0.670000] ath79-spi ath79-spi: master is unqueued, this is deprecated
[    0.680000] m25p80 spi0.0: found s25fl129p1, expected m25p80
[    0.680000] m25p80 spi0.0: s25fl129p1 (16384 Kbytes)
[    0.690000] 7 cmdlinepart partitions found on MTD device spi0.0
[    0.690000] Creating 7 MTD partitions on "spi0.0":
[    0.700000] 0x000000000000-0x000000010000 : "u-boot"
[    0.710000] 0x000000010000-0x000000020000 : "bdinfo"
[    0.710000] 0x000000020000-0x000000160000 : "kernel"
[    0.720000] 0x000000160000-0x000000fe0000 : "rootfs"
[    0.720000] mtd: device 3 (rootfs) set to be root filesystem
[    0.730000] 1 squashfs-split partitions found on MTD device rootfs
[    0.730000] 0x000000330000-0x000000fe0000 : "rootfs_data"
[    0.740000] 0x000000fe0000-0x000000ff0000 : "backup"
[    0.750000] 0x000000ff0000-0x000001000000 : "art"
[    0.750000] 0x000000020000-0x000000fe0000 : "firmware"
[    0.770000] libphy: ag71xx_mdio: probed
[    1.320000] ag71xx-mdio.1: Found an AR7240/AR9330 built-in switch
[    2.360000] eth0: Atheros AG71xx at 0xba000000, irq 5, mode:GMII
[    2.910000] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.1:04 [uid=004dd041, driver=Generic PHY]
[    2.920000] eth1: Atheros AG71xx at 0xb9000000, irq 4, mode:MII
[    2.930000] TCP: cubic registered
[    2.930000] NET: Registered protocol family 17
[    2.930000] 8021q: 802.1Q VLAN Support v1.8
[    2.950000] VFS: Mounted root (squashfs filesystem) readonly on device 31:3.
[    2.950000] Freeing unused kernel memory: 228K (80327000 - 80360000)
[    5.770000] usbcore: registered new interface driver usbfs
[    5.780000] usbcore: registered new interface driver hub
[    5.780000] usbcore: registered new device driver usb
[    5.790000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    5.800000] ehci-platform: EHCI generic platform driver
[    5.800000] ehci-platform ehci-platform: EHCI Host Controller
[    5.810000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[    5.820000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[    5.840000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[    5.840000] hub 1-0:1.0: USB hub found
[    5.840000] hub 1-0:1.0: 1 port detected
[    5.850000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    6.300000] usb 1-1: new high-speed USB device number 2 using ehci-platform
[    8.430000] eth0: link up (1000Mbps/Full duplex)
[   10.730000] jffs2_scan_eraseblock(): End of filesystem marker found at 0x50000
[   10.740000] jffs2_build_filesystem(): unlocking the mtd device... done.
[   10.740000] jffs2_build_filesystem(): erasing all blocks after the end marker... done.
[   40.050000] jffs2: notice: (309) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[   45.760000] eth0: link down
[   47.710000] NET: Registered protocol family 10
[   47.730000] nf_conntrack version 0.5.0 (960 buckets, 3840 max)
[   47.740000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   47.760000] Loading modules backported from Linux version master-2014-05-22-0-gf2032ea
[   47.760000] Backport generated by backports.git backports-20140320-37-g5c33da0
[   47.770000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   47.830000] xt_time: kernel timezone is -0000
[   47.860000] cfg80211: Calling CRDA to update world regulatory domain
[   47.860000] cfg80211: World regulatory domain updated:
[   47.870000] cfg80211:  DFS Master region: unset
[   47.870000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   47.880000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   47.890000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   47.900000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   47.900000] cfg80211:   (5170000 KHz - 5250000 KHz @ 160000 KHz), (N/A, 2000 mBm), (N/A)
[   47.910000] cfg80211:   (5250000 KHz - 5330000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   47.920000] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   47.930000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   47.940000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   48.000000] PPP generic driver version 2.4.2
[   48.020000] NET: Registered protocol family 24
[   48.080000] ath: EEPROM regdomain: 0x0
[   48.080000] ath: EEPROM indicates default country code should be used
[   48.080000] ath: doing EEPROM country->regdmn map search
[   48.080000] ath: country maps to regdmn code: 0x3a
[   48.080000] ath: Country alpha2 being used: US
[   48.080000] ath: Regpair used: 0x3a
[   48.090000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   48.110000] cfg80211: Calling CRDA for country: US
[   48.120000] cfg80211: Regulatory domain changed to country: US
[   48.120000] cfg80211:  DFS Master region: FCC
[   48.120000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   48.130000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
[   48.140000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 1700 mBm), (N/A)
[   48.150000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz), (N/A, 2300 mBm), (0 s)
[   48.160000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm), (N/A)
[   48.170000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[   48.170000] ieee80211 phy0: Atheros AR9330 Rev:1 mem=0xb8100000, irq=2
[   57.580000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   57.590000] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
[   57.590000] device eth0.1 entered promiscuous mode
[   57.600000] device eth0 entered promiscuous mode
[   57.600000] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   57.650000] IPv6: ADDRCONF(NETDEV_UP): eth0.2: link is not ready
[   58.180000] eth0: link up (1000Mbps/Full duplex)
[   58.180000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   58.220000] br-lan: port 1(eth0.1) entered forwarding state
[   58.220000] br-lan: port 1(eth0.1) entered forwarding state
[   58.230000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
[   58.230000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.2: link becomes ready
[   58.240000] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   58.710000] cfg80211: Calling CRDA for country: TW
[   58.720000] cfg80211: Regulatory domain changed to country: TW
[   58.720000] cfg80211:  DFS Master region: JP
[   58.720000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   58.730000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
[   58.740000] cfg80211:   (5270000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 1700 mBm), (0 s)
[   58.750000] cfg80211:   (5490000 KHz - 5590000 KHz @ 80000 KHz), (N/A, 3000 mBm), (0 s)
[   58.760000] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 3000 mBm), (0 s)
[   58.770000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm), (N/A)
[   60.220000] br-lan: port 1(eth0.1) entered forwarding state
[   60.740000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   60.740000] device wlan0 entered promiscuous mode
[   61.360000] br-lan: port 2(wlan0) entered forwarding state
[   61.360000] br-lan: port 2(wlan0) entered forwarding state
[   61.370000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   63.360000] br-lan: port 2(wlan0) entered forwarding state
[   71.550000] device wlan0 left promiscuous mode
[   71.550000] br-lan: port 2(wlan0) entered disabled state
[   72.170000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   72.200000] device wlan0 entered promiscuous mode
[   72.210000] br-lan: port 2(wlan0) entered forwarding state
[   72.210000] br-lan: port 2(wlan0) entered forwarding state
[   72.560000] br-lan: port 2(wlan0) entered disabled state
[   72.890000] br-lan: port 2(wlan0) entered forwarding state
[   72.890000] br-lan: port 2(wlan0) entered forwarding state
[   72.900000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   74.890000] br-lan: port 2(wlan0) entered forwarding state

Thanks!

Attachments (0)

Change History (8)

comment:1 Changed 3 years ago by anonymous

I'm having this issue as well. Any ideas?

comment:2 Changed 3 years ago by anonymous

我在官方编译的14.07rc3(http://downloads.openwrt.org/barrier_breaker/14.07-rc3/ar71xx/generic/openwrt-ar71xx-generic-hiwifi-hc6361-squashfs-sysupgrade.bin) 上同样有这个问题,pppoe运行十几分钟后会停止并重启

comment:3 Changed 3 years ago by yousong

i now use hc6361 a lot. pppoe works quite well now. in my own case, it didn't before because of bad wiring work by the ISP.

the swconfig of yours is not the default one. are you sure that wan link from ISP are actually plugged into port 1?

comment:4 follow-up: Changed 3 years ago by ballgotz

I'm sure the ISP link is properly plugged into port 1 (WAN port). The PPPoE works fine with the custom built firmware in description, but won't work anymore after sysupgrading. Neither will it work if flashed the Barrier Breaker rc3 ROM.

Thanks for your reply yousong, greatly appreciated if you can shed some light on this.

comment:5 in reply to: ↑ 4 ; follow-up: Changed 3 years ago by yousong

Replying to ballgotz:

I'm sure the ISP link is properly plugged into port 1 (WAN port). The PPPoE works fine with the custom built firmware in description, but won't work anymore after sysupgrading. Neither will it work if flashed the Barrier Breaker rc3 ROM.

The board setup code is different between what's in OpenWrt and that of openwrt-hiwifi in code.google.com.

If I understand it correctly, with firmware built from openwrt-hiwifi project, those 3 ethernet ports at the back of the device are managed by the built-in switch and you have to enable VLAN to use the WAN port. That's how openwrt-hiwifi project did before and so is your current config.

But with firmwares built from OpenWrt, WAN port is not managed by swconfig. So port 1 in your VLAN config is not WAN port as indicated on the case of the device. You can confirm this by plugging out and in the ISP link to WAN port and see if the result of command swconfig dev swich0 show changes. I guess it won't with your posted config. You can find the default config at #17798.

What I do not understand is the following log. Looks like it has finished the pppoe session setup (it shouldn't if there is no PPPoE server present). You can debug pppd by adding option pppd_options 'debug' into the /e/c/network.

Connect: pppoe-wan <--> /dev/pts/0
LCP: timeout sending Config-Requests
Connection terminated.
Modem hangup

comment:6 in reply to: ↑ 5 ; follow-up: Changed 3 years ago by ballgotz

Replying to yousong:

If I understand it correctly, with firmware built from openwrt-hiwifi project, those 3 ethernet ports at the back of the device are managed by the built-in switch and you have to enable VLAN to use the WAN port. That's how openwrt-hiwifi project did before and so is your current config.

But with firmwares built from OpenWrt, WAN port is not managed by swconfig. So port 1 in your VLAN config is not WAN port as indicated on the case of the device. You can confirm this by plugging out and in the ISP link to WAN port and see if the result of command swconfig dev swich0 show changes. I guess it won't with your posted config. You can find the default config at #17798.

Thanks a lot for the pointer yousong, I think you got me on the right track: the link status won't change if I used the default OpenWRT build and plugged the cable to WAN port, using the default swconfig you provided in #17798:

root@OpenWrt:/tmp# swconfig dev switch0 show
Global attributes:
        enable_vlan: 1
Port 0:
        pvid: 1
        link: port:0 link:up speed:1000baseT full-duplex txflow rxflow
Port 1:
        pvid: 1
        link: port:1 link:down
Port 2:
        pvid: 1
        link: port:2 link:down
Port 3:
        pvid: 1
        link: port:3 link:down
Port 4:
        pvid: 1
        link: port:4 link:down
VLAN 1:
        vid: 1
        ports: 0 1 2 3 4

And if I plug the cable into another port (not marked as WAN on case), it can be shown on swconfig:

root@OpenWrt:/tmp# swconfig dev eth0 show
Global attributes:
        enable_vlan: 1
Port 0:
        pvid: 1
        link: port:0 link:up speed:1000baseT full-duplex txflow rxflow
Port 1:
        pvid: 1
        link: port:1 link:down
Port 2:
        pvid: 1
        link: port:2 link:down
Port 3:
        pvid: 1
        link: port:3 link:down
Port 4:
        pvid: 1
        link: port:4 link:up speed:100baseT full-duplex auto
VLAN 1:
        vid: 1
        ports: 0 1 2 3 4

However, if I plug the cable into one of the non-WAN ports and let pppd do the dialup, it can't complete the discovery:

Send PPPOE Discovery V1T1 PADI session 0x0 length 12
 dst ff:ff:ff:ff:ff:ff  src d4:ee:07:01:8d:2e
 [service-name] [host-uniq  00 00 07 bd]
Send PPPOE Discovery V1T1 PADI session 0x0 length 12
 dst ff:ff:ff:ff:ff:ff  src d4:ee:07:01:8d:2e
 [service-name] [host-uniq  00 00 07 bd]
Send PPPOE Discovery V1T1 PADI session 0x0 length 12
 dst ff:ff:ff:ff:ff:ff  src d4:ee:07:01:8d:2e
 [service-name] [host-uniq  00 00 07 bd]
Timeout waiting for PADO packets
Unable to complete PPPoE Discovery

So I guess my problem now becomes: If I'm using the default OpenWRT build, how should I setup my config to let PPPoE do it's job? (Plugging the cable into WAN won't work since swconfig won't pick it up, and plugging it into other ports can't complete the PPPoE discovery.)

Sorry if the question seems elementary, I'm kinda lost. Thanks again!

comment:7 in reply to: ↑ 6 ; follow-up: Changed 3 years ago by yousong

Replying to ballgotz:

[...]

However, if I plug the cable into one of the non-WAN ports and let pppd do the dialup, it can't complete the discovery:

Send PPPOE Discovery V1T1 PADI session 0x0 length 12
 dst ff:ff:ff:ff:ff:ff  src d4:ee:07:01:8d:2e
 [service-name] [host-uniq  00 00 07 bd]
Send PPPOE Discovery V1T1 PADI session 0x0 length 12
 dst ff:ff:ff:ff:ff:ff  src d4:ee:07:01:8d:2e
 [service-name] [host-uniq  00 00 07 bd]
Send PPPOE Discovery V1T1 PADI session 0x0 length 12
 dst ff:ff:ff:ff:ff:ff  src d4:ee:07:01:8d:2e
 [service-name] [host-uniq  00 00 07 bd]
Timeout waiting for PADO packets
Unable to complete PPPoE Discovery

So I guess my problem now becomes: If I'm using the default OpenWRT build, how should I setup my config to let PPPoE do it's job? (Plugging the cable into WAN won't work since swconfig won't pick it up, and plugging it into other ports can't complete the PPPoE discovery.)

With firmwares built from OpenWrt, WAN port is kind of working on its own without being part of the built-in switch so it is expected that swconfig won't pick it up. Are you still using option ifname eth0.2 in config interface wan with the vlan config being the default? If that is the case, then option ifname eth1 should work for you.

With OpenWrt firmware for HC6361, eth1 is the interface name for WAN port and eth0 for the built-in switch (the 2 LAN ports on the case).

comment:8 in reply to: ↑ 7 Changed 3 years ago by ballgotz

Replying to yousong:

With firmwares built from OpenWrt, WAN port is kind of working on its own without being part of the built-in switch so it is expected that swconfig won't pick it up. Are you still using option ifname eth0.2 in config interface wan with the vlan config being the default? If that is the case, then option ifname eth1 should work for you.

With OpenWrt firmware for HC6361, eth1 is the interface name for WAN port and eth0 for the built-in switch (the 2 LAN ports on the case).

Thank you for your kind help yousong, you really made my day. Thanks!

For developers: sorry that this seems not a bug but rather poor config on my side. I can't close this ticket, I hope someone with permission could close this as an invalid bug.

Thanks again to yousong for your help.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.