Modify

Opened 4 years ago

Last modified 3 years ago

#17328 new defect

Installed 14.07 RC2 m xw in a New Nanostation loco M5 and hangs after one ping

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Barrier Breaker 14.07
Keywords: m xw Cc:

Description

Installation done via TFTP, while booting one or two pings respond, after that, ping is lost and first green led stops flashing and nothing else happens.

Attachments (3)

ubnt-nanostation-loco-m5-xw.txt (12.0 KB) - added by sven-ola 3 years ago.
Some Dbg Info (Stock FW)
0001-ar71xx-refactor-ubnt-xw-mach-code-and-add-loco-m-xw.patch (9.1 KB) - added by lynxis 3 years ago.
cpuinfo-ifconfig-14ofAugustversion.txt (2.9 KB) - added by jb 3 years ago.
cpuinfo+ifconfig of 14 of August version

Download all attachments as: .zip

Change History (26)

comment:1 follow-up: Changed 4 years ago by blogic

can you get a serial log output ?

comment:3 Changed 3 years ago by sven-ola

Same here. There's only one RJ45 jack on a XW Nanostation M5 loco. I see DHCP-requests coming in via VLAN2, seems there's a quirks with VLAN/WAN/LAN config.

Changed 3 years ago by sven-ola

Some Dbg Info (Stock FW)

comment:4 Changed 3 years ago by lynxis

I think the loco XW doesn't have the external switch

comment:5 Changed 3 years ago by lynxis

@sven-ola can you test please this image? https://lynxis.crew.c-base.org/locoxw/

comment:6 follow-up: Changed 3 years ago by sven-ola

Flashed your openwrt-ar71xx-generic-ubnt-loco-m-xw-squashfs-factory.bin. Works. Results:

[sven-ola@pcmac Downloads]$ telnet 192.168.1.1
Trying 192.168.1.1...
Connected to 192.168.1.1.
Escape character is '^]'.
 === IMPORTANT ============================
  Use 'passwd' to set your login password
  this will disable telnet and enable SSH
 ------------------------------------------


BusyBox v1.22.1 (2014-08-14 15:19:11 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 CHAOS CALMER (Bleeding Edge, r42162)
 -----------------------------------------------------
  * 1 1/2 oz Gin            Shake with a glassful
  * 1/4 oz Triple Sec       of broken ice and pour
  * 3/4 oz Lime Juice       unstrained into a goblet.
  * 1 1/2 oz Orange Juice
  * 1 tsp. Grenadine Syrup
 -----------------------------------------------------
root@OpenWrt:/# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          7fff.0418d6270622       no              eth0
root@OpenWrt:/# ip l
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-lan state UP mode DEFAULT group default qlen 1000
    link/ether 04:18:d6:27:06:22 brd ff:ff:ff:ff:ff:ff
3: sit0: <NOARP> mtu 1480 qdisc noop state DOWN mode DEFAULT group default 
    link/sit 0.0.0.0 brd 0.0.0.0
4: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 04:18:d6:26:06:22 brd ff:ff:ff:ff:ff:ff
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default 
    link/ether 04:18:d6:27:06:22 brd ff:ff:ff:ff:ff:ff

comment:7 in reply to: ↑ 1 Changed 3 years ago by jb

Replying to blogic:

can you get a serial log output ?

U-Boot 1.1.4-s776 (Nov 27 2013 - 15:58:45)

Board: Ubiquiti Networks AR9342 board (e845-51.1122.0030)
Reset: Normal
DRAM: 64 MB
Flash: 8 MB (0xc2, 0x20, 0x17)
Net: AR8032 Detected
eth0, eth1
Radio: 0777:e845
Hit any key to stop autoboot: 0
## Booting image at 9f050000 ...

Image Name: MIPS OpenWrt Linux-3.10.49
Created: 2014-08-10 2:37:05 UTC
Image Type: MIPS Linux Kernel Image (lzma compressed)
Data Size: 1109393 Bytes = 1.1 MB
Load Address: 80060000
Entry Point: 80060000
Verifying Checksum at 0x9f050040 ...OK
Uncompressing Kernel Image ... OK

Starting kernel ...

[ 0.000000] Linux version 3.10.49 (openwrt@gb-10) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r42092) ) #1 Sun Aug 10 02:32:17 UTC 2014
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU revision is: 0001974c (MIPS 74Kc)
[ 0.000000] SoC: Atheros AR9342 rev 2
[ 0.000000] Clocks: CPU:535.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:40.000MHz
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 04000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] Zone ranges:
[ 0.000000] Normal [mem 0x00000000-0x03ffffff]
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0x00000000-0x03ffffff]
[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 16256
[ 0.000000] Kernel command line: board=UBNT-NM-XW console=ttyS0,115200 mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,7552k(firmware),256k(cfg)ro,64k(EEPROM)ro rootfstype=squashfs,jffs2 noinitrd
[ 0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[ 0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[ 0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[ 0.000000] Writing ErrCtl register=00000000
[ 0.000000] Readback ErrCtl register=00000000
[ 0.000000] Memory: 61076k/65536k available (2375k kernel code, 4460k reserved, 623k data, 264k init, 0k highmem)
[ 0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] NR_IRQS:51
[ 0.000000] Calibrating delay loop... 266.64 BogoMIPS (lpj=1333248)
[ 0.080000] pid_max: default: 32768 minimum: 301
[ 0.080000] Mount-cache hash table entries: 512
[ 0.090000] NET: Registered protocol family 16
[ 0.100000] MIPS: machine is Ubiquiti Nanostation M XW
[ 0.310000] bio: create slab <bio-0> at 0
[ 0.320000] Switching to clocksource MIPS
[ 0.330000] NET: Registered protocol family 2
[ 0.330000] TCP established hash table entries: 512 (order: 0, 4096 bytes)
[ 0.330000] TCP bind hash table entries: 512 (order: -1, 2048 bytes)
[ 0.340000] TCP: Hash tables configured (established 512 bind 512)
[ 0.340000] TCP: reno registered
[ 0.350000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.350000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.360000] NET: Registered protocol family 1
[ 0.380000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.390000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[ 0.400000] msgmni has been set to 119
[ 0.400000] io scheduler noop registered
[ 0.400000] io scheduler deadline registered (default)
[ 0.410000] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[ 0.440000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
[ 0.450000] console [ttyS0] enabled, bootconsole disabled
[ 0.450000] console [ttyS0] enabled, bootconsole disabled
[ 0.460000] ath79-spi ath79-spi: master is unqueued, this is deprecated
[ 0.470000] m25p80 spi0.0: found mx25l6405d, expected m25p80
[ 0.480000] m25p80 spi0.0: mx25l6405d (8192 Kbytes)
[ 0.480000] 5 cmdlinepart partitions found on MTD device spi0.0
[ 0.490000] Creating 5 MTD partitions on "spi0.0":
[ 0.490000] 0x000000000000-0x000000040000 : "u-boot"
[ 0.500000] 0x000000040000-0x000000050000 : "u-boot-env"
[ 0.510000] 0x000000050000-0x0000007b0000 : "firmware"
[ 0.520000] 2 uimage-fw partitions found on MTD device firmware
[ 0.530000] 0x000000050000-0x00000015edd1 : "kernel"
[ 0.530000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[ 0.550000] 0x00000015edd1-0x0000007b0000 : "rootfs"
[ 0.550000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[ 0.570000] mtd: device 4 (rootfs) set to be root filesystem
[ 0.570000] 1 squashfs-split partitions found on MTD device rootfs
[ 0.580000] 0x000000330000-0x0000007b0000 : "rootfs_data"
[ 0.590000] 0x0000007b0000-0x0000007f0000 : "cfg"
[ 0.590000] 0x0000007f0000-0x000000800000 : "EEPROM"
[ 0.600000] libphy: ag71xx_mdio: probed
[ 1.160000] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.0:01 [uid=004dd023, driver=Generic PHY]
[ 1.170000] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:MII
[ 1.180000] TCP: cubic registered
[ 1.180000] NET: Registered protocol family 17
[ 1.190000] Bridge firewalling registered
[ 1.190000] 8021q: 802.1Q VLAN Support v1.8
[ 1.200000] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
[ 1.210000] Freeing unused kernel memory: 264K (8034e000 - 80390000)
procd: Console is alive
procd: - watchdog -
[ 3.510000] usbcore: registered new interface driver usbfs
[ 3.520000] usbcore: registered new interface driver hub
[ 3.520000] usbcore: registered new device driver usb
[ 3.530000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 3.540000] ehci-platform: EHCI generic platform driver
[ 3.550000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
procd: - preinit -
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[ 6.170000] eth0: link up (100Mbps/Full duplex)
jffs2 is ready
jffs2 is ready
[ 7.180000] jffs2: notice: (310) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (0 unchecked, 0 orphan) and 14 of xref (0 dead, 2 orphan) found.
switching to overlay
[ 7.220000] eth0: link down
procd: - early -
procd: - watchdog -
procd: - ubus -
procd: - init -
Please press Enter to activate this console.
[ 8.650000] NET: Registered protocol family 10
[ 8.670000] nf_conntrack version 0.5.0 (958 buckets, 3832 max)
[ 8.680000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[ 8.690000] Loading modules backported from Linux version master-2014-05-22-0-gf2032ea
[ 8.700000] Backport generated by backports.git backports-20140320-37-g5c33da0
[ 8.710000] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 8.760000] xt_time: kernel timezone is -0000
[ 8.790000] cfg80211: Calling CRDA to update world regulatory domain
[ 8.790000] cfg80211: World regulatory domain updated:
[ 8.800000] cfg80211: DFS Master region: unset
[ 8.800000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 8.810000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 8.820000] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 8.830000] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[ 8.840000] cfg80211: (5170000 KHz - 5250000 KHz @ 160000 KHz), (N/A, 2000 mBm), (N/A)
[ 8.840000] cfg80211: (5250000 KHz - 5330000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[ 8.850000] cfg80211: (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[ 8.860000] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[ 8.870000] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[ 8.950000] PPP generic driver version 2.4.2
[ 8.960000] NET: Registered protocol family 24
[ 9.040000] ieee80211 phy0: Atheros AR9340 Rev:0 mem=0xb8100000, irq=47
[ 9.050000] cfg80211: Calling CRDA for country: US
[ 9.050000] cfg80211: Regulatory domain changed to country: US
[ 9.060000] cfg80211: DFS Master region: FCC
[ 9.060000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 9.070000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
[ 9.080000] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 1700 mBm), (N/A)
[ 9.090000] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz), (N/A, 2300 mBm), (0 s)
[ 9.100000] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm), (N/A)
[ 9.110000] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
procd: - init complete -
[ 16.490000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 16.510000] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
[ 16.530000] device eth0.1 entered promiscuous mode
[ 16.540000] device eth0 entered promiscuous mode
[ 16.550000] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[ 16.580000] IPv6: ADDRCONF(NETDEV_UP): eth0.2: link is not ready
[ 17.240000] eth0: link up (100Mbps/Full duplex)
[ 17.240000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 17.270000] br-lan: port 1(eth0.1) entered forwarding state
[ 17.270000] br-lan: port 1(eth0.1) entered forwarding state
[ 17.280000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
[ 17.280000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.2: link becomes ready
[ 17.290000] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[ 19.270000] br-lan: port 1(eth0.1) entered forwarding state

U-Boot 1.1.4-s776 (Nov 27 2013 - 15:58:45)

Board: Ubiquiti Networks AR9342 board (e845-51.1122.0030)
Reset: Normal
DRAM: 64 MB
Flash: 8 MB (0xc2, 0x20, 0x17)
Net: AR8032 Detected
eth0, eth1
Radio: 0777:e845
Hit any key to stop autoboot: 0
## Booting image at 9f050000 ...

Image Name: MIPS OpenWrt Linux-3.10.49
Created: 2014-08-10 2:37:05 UTC
Image Type: MIPS Linux Kernel Image (lzma compressed)
Data Size: 1109393 Bytes = 1.1 MB
Load Address: 80060000
Entry Point: 80060000
Verifying Checksum at 0x9f050040 ...OK
Uncompressing Kernel Image ... OK

Starting kernel ...

[ 0.000000] Linux version 3.10.49 (openwrt@gb-10) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r42092) ) #1 Sun Aug 10 02:32:17 UTC 2014
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU revision is: 0001974c (MIPS 74Kc)
[ 0.000000] SoC: Atheros AR9342 rev 2
[ 0.000000] Clocks: CPU:535.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:40.000MHz
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 04000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] Zone ranges:
[ 0.000000] Normal [mem 0x00000000-0x03ffffff]
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0x00000000-0x03ffffff]
[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 16256
[ 0.000000] Kernel command line: board=UBNT-NM-XW console=ttyS0,115200 mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,7552k(firmware),256k(cfg)ro,64k(EEPROM)ro rootfstype=squashfs,jffs2 noinitrd
[ 0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[ 0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[ 0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[ 0.000000] Writing ErrCtl register=00000000
[ 0.000000] Readback ErrCtl register=00000000
[ 0.000000] Memory: 61076k/65536k available (2375k kernel code, 4460k reserved, 623k data, 264k init, 0k highmem)
[ 0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] NR_IRQS:51
[ 0.000000] Calibrating delay loop... 266.64 BogoMIPS (lpj=1333248)
[ 0.080000] pid_max: default: 32768 minimum: 301
[ 0.080000] Mount-cache hash table entries: 512
[ 0.090000] NET: Registered protocol family 16
[ 0.100000] MIPS: machine is Ubiquiti Nanostation M XW
[ 0.310000] bio: create slab <bio-0> at 0
[ 0.320000] Switching to clocksource MIPS
[ 0.330000] NET: Registered protocol family 2
[ 0.330000] TCP established hash table entries: 512 (order: 0, 4096 bytes)
[ 0.330000] TCP bind hash table entries: 512 (order: -1, 2048 bytes)
[ 0.340000] TCP: Hash tables configured (established 512 bind 512)
[ 0.340000] TCP: reno registered
[ 0.350000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.350000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.360000] NET: Registered protocol family 1
[ 0.380000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.390000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[ 0.400000] msgmni has been set to 119
[ 0.400000] io scheduler noop registered
[ 0.400000] io scheduler deadline registered (default)
[ 0.410000] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[ 0.440000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
[ 0.450000] console [ttyS0] enabled, bootconsole disabled
[ 0.450000] console [ttyS0] enabled, bootconsole disabled
[ 0.460000] ath79-spi ath79-spi: master is unqueued, this is deprecated
[ 0.470000] m25p80 spi0.0: found mx25l6405d, expected m25p80
[ 0.480000] m25p80 spi0.0: mx25l6405d (8192 Kbytes)
[ 0.480000] 5 cmdlinepart partitions found on MTD device spi0.0
[ 0.490000] Creating 5 MTD partitions on "spi0.0":
[ 0.490000] 0x000000000000-0x000000040000 : "u-boot"
[ 0.500000] 0x000000040000-0x000000050000 : "u-boot-env"
[ 0.510000] 0x000000050000-0x0000007b0000 : "firmware"
[ 0.520000] 2 uimage-fw partitions found on MTD device firmware
[ 0.530000] 0x000000050000-0x00000015edd1 : "kernel"
[ 0.530000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[ 0.550000] 0x00000015edd1-0x0000007b0000 : "rootfs"
[ 0.550000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[ 0.570000] mtd: device 4 (rootfs) set to be root filesystem
[ 0.570000] 1 squashfs-split partitions found on MTD device rootfs
[ 0.580000] 0x000000330000-0x0000007b0000 : "rootfs_data"
[ 0.580000] 0x0000007b0000-0x0000007f0000 : "cfg"
[ 0.590000] 0x0000007f0000-0x000000800000 : "EEPROM"
[ 0.600000] libphy: ag71xx_mdio: probed
[ 1.160000] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.0:01 [uid=004dd023, driver=Generic PHY]
[ 1.170000] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:MII
[ 1.180000] TCP: cubic registered
[ 1.180000] NET: Registered protocol family 17
[ 1.190000] Bridge firewalling registered
[ 1.190000] 8021q: 802.1Q VLAN Support v1.8
[ 1.200000] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
[ 1.210000] Freeing unused kernel memory: 264K (8034e000 - 80390000)
procd: Console is alive
procd: - watchdog -
[ 3.510000] usbcore: registered new interface driver usbfs
[ 3.520000] usbcore: registered new interface driver hub
[ 3.520000] usbcore: registered new device driver usb
[ 3.530000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 3.540000] ehci-platform: EHCI generic platform driver
[ 3.550000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
procd: - preinit -
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[ 6.170000] eth0: link up (100Mbps/Full duplex)
jffs2 is ready
jffs2 is ready
[ 7.200000] jffs2: notice: (311) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (0 unchecked, 0 orphan) and 14 of xref (0 dead, 2 orphan) found.
switching to overlay
[ 7.240000] eth0: link down
procd: - early -
procd: - watchdog -
procd: - ubus -
procd: - init -
Please press Enter to activate this console.
[ 8.730000] NET: Registered protocol family 10
[ 8.740000] nf_conntrack version 0.5.0 (958 buckets, 3832 max)
[ 8.750000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[ 8.770000] Loading modules backported from Linux version master-2014-05-22-0-gf2032ea
[ 8.780000] Backport generated by backports.git backports-20140320-37-g5c33da0
[ 8.790000] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 8.830000] xt_time: kernel timezone is -0000
[ 8.900000] cfg80211: Calling CRDA to update world regulatory domain
[ 8.910000] cfg80211: World regulatory domain updated:
[ 8.910000] cfg80211: DFS Master region: unset
[ 8.920000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 8.930000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 8.930000] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 8.940000] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[ 8.950000] cfg80211: (5170000 KHz - 5250000 KHz @ 160000 KHz), (N/A, 2000 mBm), (N/A)
[ 8.960000] cfg80211: (5250000 KHz - 5330000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[ 8.970000] cfg80211: (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[ 8.980000] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[ 8.980000] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[ 9.010000] PPP generic driver version 2.4.2
[ 9.030000] NET: Registered protocol family 24
[ 9.110000] cfg80211: Calling CRDA for country: US
[ 9.130000] cfg80211: Regulatory domain changed to country: US
[ 9.130000] cfg80211: DFS Master region: FCC
[ 9.140000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 9.150000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
[ 9.150000] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 1700 mBm), (N/A)
[ 9.160000] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz), (N/A, 2300 mBm), (0 s)
[ 9.170000] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm), (N/A)
[ 9.180000] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[ 9.190000] ieee80211 phy0: Atheros AR9340 Rev:0 mem=0xb8100000, irq=47
procd: - init complete -
[ 16.530000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 16.540000] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
[ 16.540000] device eth0.1 entered promiscuous mode
[ 16.550000] device eth0 entered promiscuous mode
[ 16.550000] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[ 16.590000] IPv6: ADDRCONF(NETDEV_UP): eth0.2: link is not ready
[ 17.420000] eth0: link up (100Mbps/Full duplex)
[ 17.500000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 17.550000] br-lan: port 1(eth0.1) entered forwarding state
[ 17.550000] br-lan: port 1(eth0.1) entered forwarding state
[ 17.560000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
[ 17.560000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.2: link becomes ready
[ 17.570000] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[ 19.550000] br-lan: port 1(eth0.1) entered forwarding state

comment:8 in reply to: ↑ 6 Changed 3 years ago by jb

Replying to sven-ola:

Flashed your openwrt-ar71xx-generic-ubnt-loco-m-xw-squashfs-factory.bin. Works. Results:

[sven-ola@pcmac Downloads]$ telnet 192.168.1.1
Trying 192.168.1.1...
Connected to 192.168.1.1.
Escape character is '^]'.
 === IMPORTANT ============================
  Use 'passwd' to set your login password
  this will disable telnet and enable SSH
 ------------------------------------------


BusyBox v1.22.1 (2014-08-14 15:19:11 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 CHAOS CALMER (Bleeding Edge, r42162)
 -----------------------------------------------------
  * 1 1/2 oz Gin            Shake with a glassful
  * 1/4 oz Triple Sec       of broken ice and pour
  * 3/4 oz Lime Juice       unstrained into a goblet.
  * 1 1/2 oz Orange Juice
  * 1 tsp. Grenadine Syrup
 -----------------------------------------------------
root@OpenWrt:/# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          7fff.0418d6270622       no              eth0
root@OpenWrt:/# ip l
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-lan state UP mode DEFAULT group default qlen 1000
    link/ether 04:18:d6:27:06:22 brd ff:ff:ff:ff:ff:ff
3: sit0: <NOARP> mtu 1480 qdisc noop state DOWN mode DEFAULT group default 
    link/sit 0.0.0.0 brd 0.0.0.0
4: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 04:18:d6:26:06:22 brd ff:ff:ff:ff:ff:ff
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default 
    link/ether 04:18:d6:27:06:22 brd ff:ff:ff:ff:ff:ff

Hello, I also confirm this lynxis build WORKS with New nanostation loco M5 (m xw)!

comment:9 follow-up: Changed 3 years ago by lynxis

Can you test this image, please?
Interesting is cat /proc/cpuinfo + ifconfig

https://lynxis.crew.c-base.org/locoxw_v2/openwrt-ar71xx-generic-ubnt-loco-m-xw-squashfs-factory.bin

comment:10 in reply to: ↑ 9 Changed 3 years ago by jb

Now it's not responding again, i can not ping nor telnet it.
former version was accessible by telnet.

Replying to lynxis:

Can you test this image, please?
Interesting is cat /proc/cpuinfo + ifconfig

https://lynxis.crew.c-base.org/locoxw_v2/openwrt-ar71xx-generic-ubnt-loco-m-xw-squashfs-factory.bin

Changed 3 years ago by jb

cpuinfo+ifconfig of 14 of August version

comment:11 Changed 3 years ago by jb

Attached cpuinfo + ifconfig from working version (14 of August)

comment:12 Changed 3 years ago by lynxis

Thank you for testing. I'm building a new image for the loco.

comment:14 in reply to: ↑ 13 Changed 3 years ago by jb

This build also not responding, i noticed that also the first ping that answered in the previous versions is not responding in these two last ones.

Replying to lynxis:

Next version is ready.
https://lynxis.crew.c-base.org/locoxw_v3/openwrt-ar71xx-generic-ubnt-loco-m-xw-squashfs-factory.bin

comment:15 Changed 3 years ago by jb

Hello Lynxis, any new version to test?

comment:16 Changed 3 years ago by lynxis

Thanks for your stubs. Please tell which one works.
https://lynxis.crew.c-base.org/locoxw_v6/

comment:17 Changed 3 years ago by openwrt@…

Hi,

I have installed the nano-xw firmware from trunk (01-Sep-2014 11:50). The result is quite successful.

I can ping link local IPv6 address of the device:

me@pc:~$ ping6 ff02::1%eth0
PING ff02::1%eth0(ff02::1) 56 data bytes
64 bytes from fe80::fab1:56ff:fecf:dd4c: icmp_seq=1 ttl=64 time=0.035 ms
64 bytes from fe80::618:d6ff:fe59:f598: icmp_seq=1 ttl=64 time=0.684 ms (DUP!)

(the first one is my PC, the second is the NSLM5-XW). There's no way to ping it using 192.168.1.1

Then I can telnet it, using the local IPv6 address:

me@pc:~$ telnet fe80::618:d6ff:fe59:f598%eth0
Trying fe80::618:d6ff:fe59:f598%eth0...
Connected to fe80::618:d6ff:fe59:f598%eth0.
Escape character is '^]'.
 === IMPORTANT ============================
  Use 'passwd' to set your login password
  this will disable telnet and enable SSH
 ------------------------------------------


BusyBox v1.22.1 (2014-09-01 11:27:11 UTC) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 CHAOS CALMER (Bleeding Edge, r42345)
 -----------------------------------------------------
  * 1 1/2 oz Gin            Shake with a glassful
  * 1/4 oz Triple Sec       of broken ice and pour
  * 3/4 oz Lime Juice       unstrained into a goblet.
  * 1 1/2 oz Orange Juice
  * 1 tsp. Grenadine Syrup
 -----------------------------------------------------
root@OpenWrt:/# 

The network configuration in /etc/config/network is wrong. It seems to be for a non-Looco NanoStation M5 XW, which has two Ethernet ports:

root@OpenWrt:/# cat /etc/config/network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf2:26c9:8284::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'

In fact, there is no switch in the NSLM5-XW:

root@OpenWrt:/# swconfig list

which makes sense, since there is only one Ethernet port. Now, I change the network configuration and remove all reference to the switch:

root@OpenWrt:/# cat /etc/config/network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf2:26c9:8284::/48'

config interface 'lan'
        option ifname 'eth0'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

and after rebooting the network (/etc/init.d/network restart), ping to 192.168.1.1 works and I can telnet it using the IPv4 address.

Hi,

I have installed the nano-xw firmware from trunk (01-Sep-2014 11:50). The result is quite successful.

I can ping link local IPv6 address of the device:

me@pc:~$ ping6 ff02::1%eth0
PING ff02::1%eth0(ff02::1) 56 data bytes
64 bytes from fe80::fab1:56ff:fecf:dd4c: icmp_seq=1 ttl=64 time=0.035 ms
64 bytes from fe80::618:d6ff:fe59:f598: icmp_seq=1 ttl=64 time=0.684 ms (DUP!)

(the first one is my PC, the second is the NSLM5-XW). There's no way to ping it using 192.168.1.1

Then I can telnet it, using the local IPv6 address:

me@pc:~$ telnet fe80::618:d6ff:fe59:f598%eth0
Trying fe80::618:d6ff:fe59:f598%eth0...
Connected to fe80::618:d6ff:fe59:f598%eth0.
Escape character is '^]'.
 === IMPORTANT ============================
  Use 'passwd' to set your login password
  this will disable telnet and enable SSH
 ------------------------------------------


BusyBox v1.22.1 (2014-09-01 11:27:11 UTC) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 CHAOS CALMER (Bleeding Edge, r42345)
 -----------------------------------------------------
  * 1 1/2 oz Gin            Shake with a glassful
  * 1/4 oz Triple Sec       of broken ice and pour
  * 3/4 oz Lime Juice       unstrained into a goblet.
  * 1 1/2 oz Orange Juice
  * 1 tsp. Grenadine Syrup
 -----------------------------------------------------
root@OpenWrt:/# 

The network configuration in /etc/config/network is wrong. It seems to be for a non-Looco NanoStation M5 XW, which has two Ethernet ports:

root@OpenWrt:/# cat /etc/config/network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf2:26c9:8284::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'

In fact, there is no switch in the NSLM5-XW:

root@OpenWrt:/# swconfig list

which makes sense, since there is only one Ethernet port. Now, I change the network configuration and remove all reference to the switch:

root@OpenWrt:/# cat /etc/config/network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf2:26c9:8284::/48'

config interface 'lan'
        option ifname 'eth0'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

and after rebooting the network (/etc/init.d/network restart), ping to 192.168.1.1 works and I can telnet it using the IPv4 address.

Regards

comment:18 Changed 3 years ago by jb

test results:
phy0 version does not respond to ping IPv4
phy1 version works!

comment:19 follow-up: Changed 3 years ago by lynxis

cool. thanks. Can you please test this version here? https://lynxis.crew.c-base.org/locoxw_v7/

I think this is the last test ;)

comment:20 in reply to: ↑ 19 Changed 3 years ago by jb

Yes, it works!
Thanks :)

Replying to lynxis:

cool. thanks. Can you please test this version here? https://lynxis.crew.c-base.org/locoxw_v7/

I think this is the last test ;)

comment:21 Changed 3 years ago by lynxis

I've send the patch to openwrt-devel ml.

comment:22 Changed 3 years ago by openwrt@…

Thank you very much, lynxis!

Just one thought... On patch 2/2, where the actual name of the device appears, you omited all references to "NanoStation", leaving just the "Loco" term. Wouldn't it be good to name it "NanoStation Loco"? Looking at Ubiquiti's web page, the "NanoStation" product range is used everywhere. Even on the device itself, the first readable line on the label is "NanoStationlocoM5".

In any case, great work! :)

comment:23 Changed 3 years ago by lynxis

I have no feeling in the naming. Can you send your comment to the devel ml in reply of my patch?

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.