Modify

Opened 4 years ago

Closed 4 years ago

#17321 closed defect (not_a_bug)

rDNS records not created - LuCI creating "config host" entries for hostnames

Reported by: Tolstyak Owned by:
Priority: normal Milestone:
Component: luci Version: Barrier Breaker 14.07
Keywords: Cc:

Description

See also: https://forum.openwrt.org/viewtopic.php?pid=242282

For static DHCP leases, rDNS was fixed with /changeset/40799.html

For hostname entries, however, it is still not working. LuCI creates "config domain" sections in /etc/config/dhcp. Additionally, as discussed on http://patchwork.openwrt.org/patch/3747/, "address=" really shouldn't be used for single hosts.

Going behind LuCI's back and changing the hostname entries to "config hostrecord" correctly allows both forward and reverse DNS resolution.

Could LuCI just create hostrecord sections instead?

Attachments (0)

Change History (8)

comment:1 Changed 4 years ago by jow

  • Resolution set to not_a_bug
  • Status changed from new to closed

This is a feature request, not a bug. Please send a tested patch implementing the desired behaviour according to SubmittingPatches.

comment:2 Changed 4 years ago by Tolstyak

If "address=" should not be used for individual host A records, as discussed in http://patchwork.openwrt.org/patch/3747/...
And LuCI creates a dhcp config section that causes "address=" config lines to be created...
Would it not be a bug?

comment:3 Changed 4 years ago by Tolstyak

  • Resolution not_a_bug deleted
  • Status changed from closed to reopened

Additionally, considering the fact that /ticket/13854.html was accepted as a bug, which is exactly the same issue I describe here (reverse DNS lookups not working), how could this not be considered a bug?

comment:4 Changed 4 years ago by jow

  • Resolution set to not_a_bug
  • Status changed from reopened to closed

The LuCI ui always generated those uci sections and that sections continue to fulfil their purpose. What you're asking for is different semantics or a different kind of configuration emitted by the ui to reach a simkilar solution. Since the original behaviour continues to work (host->ip mapping) I see no functional bug in the ui. If you like to rework the way the ui generates the configuration then please provide a patch to do so, I will have no time and do not plan to look into that.

comment:5 Changed 4 years ago by Tolstyak

Then I guess what I'd be looking for is guidance, as I currently have no experience whatsoever developing for OpenWRT. These are the possible approaches I see:

  1. Modify LuCI to generate "hostrecord" sections. This would require somehow changing all existing "config domain" sections to "config hostrecord" ones.
  2. Add another config page to LuCI: "hostnames with rDNS and IPv6 support". This would serve almost the exact function of the hostnames page.
  3. Modify dnsmasq.init to generate host-record= lines from "config domain" sections instead of address=. This would also require appending the Local domain, as names are not expanded with host-record=.

3 is what I would assume would be the best approach, and it doesn't touch LuCI. Given that, is it still something you need me to learn, from scratch, how to develop on OpenWRT for?

comment:6 Changed 4 years ago by Tolstyak

Or, because dnsmasq _does_ expand hosts from hosts-files, a temporary file could be created by dnsmasq.init (much the same as in /changeset/40799.html), then a hosts-file= line added to the generated dnsmasq.conf. I like that more, actually. Saves having to screw with checking if expand-hosts is set.

comment:7 follow-up: Changed 4 years ago by Tolstyak

  • Resolution not_a_bug deleted
  • Status changed from closed to reopened

Sorry to prod, but I'm not sure if you're notified otherwise. Considering the fact that this wouldn't be a LuCI change, but something almost exactly like /changeset/40799.html, would it be something you or one of the other devs would be willing to do? If not, I'll move to the dev forum for help on getting started.

comment:8 in reply to: ↑ 7 Changed 4 years ago by jogo

  • Resolution set to not_a_bug
  • Status changed from reopened to closed

Replying to Tolstyak:

Sorry to prod, but I'm not sure if you're notified otherwise. Considering the fact that this wouldn't be a LuCI change, but something almost exactly like /changeset/40799.html, would it be something you or one of the other devs would be willing to do? If not, I'll move to the dev forum for help on getting started.

Please don't reopen tickets to force answers, it's annoying.

If you look at the linked commit, the changes are not from one of the developers but from a submitted patch by someone else. So if you want to see the same you need to go the same route; submit a patch.

Use IRC, the forums or the mailing lists for discussion and/or help on development.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.